source: projects/specs/trunk/p/perl-common-sense/perl-common-sense-vl.spec @ 12120

Revision 12120, 3.7 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-common-sense
2Summary:        "Common sense" Perl defaults
3Version:        3.74
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/common-sense-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/common-sense
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
10BuildArch:      noarch
11BuildRequires:  perl(ExtUtils::MakeMaker)
12Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
13
14# Obsolete/provide old -tests subpackage (can be removed in F19 development cycle)
15Obsoletes:      %{name}-tests < %{version}-%{release}
16Provides:       %{name}-tests = %{version}-%{release}
17
18Vendor:       Project Vine
19Distribution: Vine Linux
20
21%description
22This module implements some sane defaults for Perl programs, as defined
23by two typical (or not so typical - use your common sense) specimens of
24Perl coders:
25
26  use strict qw(vars subs);
27  use feature qw(say state switch);
28  no warnings;
29
30%prep
31%setup -q -n common-sense-%{version}
32
33%build
34perl Makefile.PL INSTALLDIRS=vendor
35make %{?_smp_mflags}
36
37%install
38rm -rf %{buildroot}
39make pure_install DESTDIR=%{buildroot}
40find %{buildroot} -type f -name .packlist -exec rm -f {} \;
41find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
42%{_fixperms} %{buildroot}
43
44mv -f %{buildroot}%{perl_vendorarch}/* %{buildroot}%{perl_vendorlib}/
45
46%check
47make test
48
49%clean
50rm -rf %{buildroot}
51
52%files
53%defattr(-,root,root,-)
54%doc LICENSE Changes README t/
55%{perl_vendorlib}/common/
56%{_mandir}/man3/common::sense.3pm*
57
58%changelog
59* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.74-1
60- new upstream release.
61- rebuilt with perl-5.26.
62
63* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 3.4-2
64- build with Perl 5.16
65
66* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.4-1
67- initial build for Vine Linux
68
69* Sat Jan 21 2012 Paul Howarth <paul@city-fan.org> - 3.4-5
70- Obsolete/provide old -tests subpackage to support upgrades
71
72* Thu Jan 19 2012 Paul Howarth <paul@city-fan.org> - 3.4-4
73- Reinstate compatibility with older distributions like EL-5
74- Drop -tests subpackage (general lack of interest in this), but include
75  them as documentation for the main package
76- Don't use macros for commands
77- Make %%files list more explicit
78- Use tabs
79
80* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4-3
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
82
83* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 3.4-2
84- Perl mass rebuild
85
86* Sat May 07 2011 Iain Arnell <iarnell@gmail.com> - 3.4-1
87- Update to latest upstream version
88
89* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3-2
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
91
92* Sat Dec 18 2010 Iain Arnell <iarnell@gmail.com> 3.3-1
93- Update to latest upstream version
94- Clean up spec for modern rpmbuild
95
96* Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 3.0-3
97- Rebuild to fix problems with vendorarch/lib (#661697)
98
99* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 3.0-2
100- Mass rebuild with perl-5.12.0
101
102* Sun Mar 14 2010 Chris Weyl <cweyl@alumni.drew.edu> - 3.0-1
103- Update by Fedora::App::MaintainerTools 0.006
104- PERL_INSTALL_ROOT => DESTDIR
105- Updating to latest GA CPAN version (3.0)
106
107* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 1.0-3
108- Rebuild against perl 5.10.1
109
110* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> - 1.0-2
111- Update summary (though now we deviate from upstream)
112
113* Mon Aug 31 2009 Chris Weyl <cweyl@alumni.drew.edu> - 1.0-1
114- Auto-update to 1.0 (by cpan-spec-update 0.01)
115
116* Fri Aug 21 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.04-0
117- Initial RPM packaging
118- Generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.8)
Note: See TracBrowser for help on using the repository browser.