source: projects/specs/trunk/p/perl-YAML/perl-YAML-vl.spec @ 599

Revision 599, 1.8 KB checked in by iwaim, 14 years ago (diff)

new: perl-YAML-0.71-1

Line 
1%define origname YAML
2
3Summary: YAML Ain't Markup Language (tm) for Perl
4Name: perl-YAML
5Version: 0.71
6Release: 1%{?_dist_release}
7License: perl's
8Group: Development/Libraries
9Source0: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/%{origname}-%{version}.tar.gz
10Source1: filter-requires-perl-YAML.sh
11Url: http://search.cpan.org/dist/YAML/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl
15Requires: perl
16
17Distribution: Vine Linux
18Vendor: Project Vine
19Packager: iwaim
20
21%define __find_requires %{SOURCE1}
22
23%description
24This module has been released to CPAN as YAML::Old, and soon YAML.pm
25will be changed to just be a frontend interface module for all the
26various Perl YAML implementation modules, including YAML::Old.
27
28If you want robust and fast YAML processing using the normal Dump/Load
29API, please consider switching to YAML::XS. It is by far the best Perl
30module for YAML at this time. It requires that you have a C compiler,
31since it is written in C.
32
33%prep
34%setup -q -n %{origname}-%{version}
35
36%build
37CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
38make
39
40%install
41rm -rf $RPM_BUILD_ROOT
42mkdir -p $RPM_BUILD_ROOT%{_prefix}
43make DESTDIR=$RPM_BUILD_ROOT install
44
45find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
46
47find $RPM_BUILD_ROOT%{_prefix} -type f -print |
48        sed "s@^$RPM_BUILD_ROOT@@g" |
49        grep -v ^%{_mandir} |
50        grep -v perllocal.pod |
51        grep -v "\.packlist" > %{name}.files
52if [ "$(cat %{name}.files)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56
57%check
58make test
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files -f %{name}.files
64%defattr(-,root,root)
65%doc README Changes LICENSE
66%{perl_vendorlib}/YAML
67%{_mandir}/man3/*
68
69%changelog
70* Mon Feb 22 2010 IWAI, Masaharu <iwai@alib.jp>
71- first release for Vine Linux
Note: See TracBrowser for help on using the repository browser.