source: projects/specs/trunk/p/perl-YAML/perl-YAML-vl.spec @ 8727

Revision 8727, 2.4 KB checked in by iwaim, 10 years ago (diff)

perl-YAML 0.95-1

Line 
1%define origname YAML
2
3Summary: YAML Ain't Markup Language (tm) for Perl
4Name: perl-YAML
5Version: 0.95
6Release: 1%{?_dist_release}
7License: perl's
8Group: Development/Libraries
9Source0: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/%{origname}-%{version}.tar.gz
10Source1: filter-requires-perl-YAML.sh
11Url: http://search.cpan.org/dist/YAML/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl
15BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
16Requires: perl
17
18Distribution: Vine Linux
19Vendor: Project Vine
20Packager: iwaim
21
22%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
23%define __find_requires %{SOURCE1}
24%else if %{?_dist_release} == "vl7"
25%define __perllib_requires %{SOURCE1}
26%else
27%define __perl_requires %{SOURCE1}
28%endif
29
30%description
31This module has been released to CPAN as YAML::Old, and soon YAML.pm
32will be changed to just be a frontend interface module for all the
33various Perl YAML implementation modules, including YAML::Old.
34
35If you want robust and fast YAML processing using the normal Dump/Load
36API, please consider switching to YAML::XS. It is by far the best Perl
37module for YAML at this time. It requires that you have a C compiler,
38since it is written in C.
39
40%prep
41%setup -q -n %{origname}-%{version}
42
43%build
44CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
45make
46
47%install
48rm -rf $RPM_BUILD_ROOT
49mkdir -p $RPM_BUILD_ROOT%{_prefix}
50make DESTDIR=$RPM_BUILD_ROOT install
51
52find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
53
54find $RPM_BUILD_ROOT%{_prefix} -type f -print |
55        sed "s@^$RPM_BUILD_ROOT@@g" |
56        grep -v ^%{_mandir} |
57        grep -v perllocal.pod |
58        grep -v "\.packlist" > %{name}.files
59if [ "$(cat %{name}.files)X" = "X" ] ; then
60    echo "ERROR: EMPTY FILE LIST"
61    exit -1
62fi
63
64%check
65make test
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files -f %{name}.files
71%defattr(-,root,root)
72%doc README Changes LICENSE
73%dir %{perl_vendorlib}/YAML
74%{_mandir}/man3/*
75
76%changelog
77* Tue Jul  1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.95-1
78- build with Perl 5.16
79- update to 0.95
80- add BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
81- update filter (Source1)
82- using __perllibl_requires macro for VineSeed (vl7)
83
84* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 0.72-1
85- new upstream release
86- using __perl_requires macro for VineSeed (vl6)
87
88* Mon Feb 22 2010 IWAI, Masaharu <iwai@alib.jp> 0.71-1
89- first release for Vine Linux
Note: See TracBrowser for help on using the repository browser.