source: projects/specs/trunk/p/perl-XML-Twig/perl-XML-Twig-vl.spec @ 521

Revision 521, 2.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3Name: perl-XML-Twig
4Version: 3.29
5Release: 1%{?_dist_release}
6Summary: A perl module for processing huge XML documents in tree mode.
7License: distributable
8Group: Development/Libraries
9URL: http://search.cpan.org/~mirod/XML-Twig/
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: perl >= 5.8.2, perl-XML-Parser >= 2.23
12Requires: perl >= 5.8.2, perl-XML-Parser >= 2.23
13Buildarch: noarch
14Source0: XML-Twig-%{version}.tar.gz
15
16%description
17This module provides a way to process XML documents. It is build on
18top of XML::Parser.  XML::Twig offers a tree interface to the
19document, while allowing you to output the parts of it that have been
20completely processed.  It allows minimal resource (CPU and memory)
21usage by building the tree only for the parts of the documents that
22need actual processing, through the use of the twig_roots and
23twig_print_outside_roots options.
24
25%prep
26%setup -q -n XML-Twig-%{version}
27
28%build
29CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor <<_OPT_
30y
31_OPT_
32make
33
34%install
35rm -rf $RPM_BUILD_ROOT
36mkdir -p $RPM_BUILD_ROOT%{_prefix}
37make DESTDIR=$RPM_BUILD_ROOT install
38
39[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
40
41find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
42
43find $RPM_BUILD_ROOT/usr -type f -print | \
44        sed "s@^$RPM_BUILD_ROOT@@g" | \
45        grep -v perllocal.pod | \
46        grep -v %{_mandir}    | \
47        grep -v "\.packlist" > XML-Twig-%{version}-filelist
48if [ "$(cat XML-Twig-%{version}-filelist)X" = "X" ] ; then
49    echo "ERROR: EMPTY FILE LIST"
50    exit 1
51fi
52
53#%check
54#make test || /bin/true
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%files -f XML-Twig-%{version}-filelist
60%defattr(-,root,root)
61%{_mandir}/man1/xml*.1*
62%{_mandir}/man3/*3pm*
63
64%changelog
65* Sun Jul 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.29-1
66- rebuilt with perl-5.10.0
67- applied new versioning policy
68
69* Sun Sep 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.29-0vl1
70- new upstream
71- changed Group to Development/Libraries
72
73* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.15-0vl2
74- rebuilt for VineSeed (4.0)
75- changed Group to Development/Languages
76
77* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 3.15-0vl1
78- new upstream release
79- build on perl-5.8.6-0vl1
80
81* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.11-0vl2
82- built on perl-5.8.2
83
84* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.11-0vl1
85- new updtream version
86- built on perl-5.8.1
87
88* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 3.09-3vl2
89- build on perl-5.8.0
90
91* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 3.09-3vl1
92- build for VineLinux
93
94* Tue Dec 10 2002 Chip Turner <cturner@redhat.com>
95- update to latest version from CPAN
96
97* Mon Aug 26 2002 Chip Turner <cturner@redhat.com>
98- rebuild for build failure
99
100* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
101- automated release bump and build
102
103* Wed May 29 2002 cturner@redhat.com
104- Specfile autogenerated
105
Note: See TracBrowser for help on using the repository browser.