source: projects/specs/trunk/p/perl-XML-Parser/perl-XML-Parser-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: XML-Parser module for perl
2Name: perl-XML-Parser
3Version: 2.36
4Release: 1%{?_dist_release}
5License: distributable
6Group: Development/Libraries
7Source0:  http://www.cpan.org/authors/id/C/CO/COOPERCL/XML-Parser-%{version}.tar.gz
8Url: http://search.cpan.org/search?dist=XML-Parser
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: perl >= 5.8.6, libexpat >= 1.95.0, expat-devel
11Requires: perl >= 5.8.6
12
13%description
14This is a Perl extension interface to James Clark's XML parser, expat.
15
16%prep
17%setup -q -n XML-Parser-%{version}
18
19%build
20CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
21make
22find samples -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!%{__perl}|g"
23
24%install
25rm -rf $RPM_BUILD_ROOT
26mkdir -p $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man3}
27make DESTDIR=$RPM_BUILD_ROOT install
28
29find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
30  -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
31
32find $RPM_BUILD_ROOT%{_prefix} -type f -print |
33        sed "s@^$RPM_BUILD_ROOT@@g" |
34        grep -v ^%{_mandir}   |
35        grep -v perllocal.pod |
36        grep -v "\.packlist" > %{name}.files
37if [ "$(cat %{name}.files)X" = "X" ] ; then
38    echo "ERROR: EMPTY FILE LIST"
39    exit -1
40fi
41install -m 644 blib/man3/* %{buildroot}%{_mandir}/man3
42
43%check
44make test
45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49%files -f %{name}.files
50%defattr(-,root,root)
51%doc README Changes samples
52%dir %{perl_vendorarch}/auto/XML
53%dir %{perl_vendorarch}/auto/XML/Parser
54%dir %{perl_vendorarch}/auto/XML/Parser/Expat
55%dir %{perl_vendorarch}/XML
56%dir %{perl_vendorarch}/XML/Parser
57%dir %{perl_vendorarch}/XML/Parser/Encodings
58%{_mandir}/*/*
59
60%changelog
61* Fri May 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.36-1vl5
62- new upstream release
63
64* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.34-1vl5
65- rebuild with perl-5.10.0
66- installed modules into vendor_perl directory
67
68* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.34-0vl5
69- rebuild with expat-2.0.1
70
71* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.34-0vl4
72- s/Copyright/License/
73- add BuildRequires: expat-devel
74
75* Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 2.34-0vl3
76- build on perl-5.8.6-0vl1
77
78* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 2.34-0vl2
79- built on perl-5.8.2
80
81* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 2.34-0vl1
82- new upstream version
83- built on perl-5.8.1
84
85* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 2.31-0vl2
86- rebuild with perl-5.8.0
87
88* Mon Apr 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.31-0vl1
89- first release for Vine Linux
90
Note: See TracBrowser for help on using the repository browser.