source: projects/specs/trunk/p/perl-XML-Encoding/perl-XML-Encoding-vl.spec @ 521

Revision 521, 2.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3%define module  XML-Encoding
4Summary: A module for parsing encoded map XML files.
5Name: perl-%{module}
6Version: 2.07
7Release: 1%{?_dist_release}
8License: Artistic and GPL
9Group: Development/Libraries
10Source0: %{module}-%{version}.tar.gz
11URL: http://search.cpan.org/~shay/XML-Encoding/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: perl-XML-Parser
15Requires: perl >= 5.8.2, perl-XML-Parser
16BuildArch: noarch
17
18%description
19This module, which is built as a subclass of XML::Parser, provides a
20parser for encoding map files, which are XML files. The file
21maps/encmap.dtd in the distribution describes the structure of these
22files.
23
24%prep
25%setup -q -n %{module}-%{version}
26
27%build
28CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
29make
30make test || /bin/true
31
32%clean
33rm -rf $RPM_BUILD_ROOT
34
35%install
36rm -rf $RPM_BUILD_ROOT
37
38make DESTDIR=$RPM_BUILD_ROOT install
39
40[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
41
42find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
43
44find $RPM_BUILD_ROOT/usr -type f -print |
45        sed "s@^$RPM_BUILD_ROOT@@g" |
46        grep -v perllocal.pod |
47        grep -v "\.packlist" > XML-Encoding-%{version}-filelist
48if [ "$(cat XML-Encoding-%{version}-filelist)X" = "X" ] ; then
49    echo "ERROR: EMPTY FILE LIST"
50    exit -1
51fi
52
53%check
54make test
55
56%files -f XML-Encoding-%{version}-filelist
57%defattr(-,root,root)
58
59%changelog
60* Sun Feb 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.07-1
61- new upstream release
62- updated URL
63- changed Group to Development/Libraries
64
65* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 1.01-24vl5
66- applied new versioning policy
67
68* Wed Jul 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.01-23vl6
69- changed Group to Development/Languages
70
71* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 1.01-23vl5
72- build on perl-5.8.6-0vl1
73
74* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 1.01-23vl4
75- rebuilt on perl-5.8.2
76
77* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.01-23vl3
78- rebuilt on perl-5.8.1
79
80* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.01-23vl2
81- build on perl-5.8.0
82
83* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 1.01-23vl1
84- build for VineLinux
85
86* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
87- automated release bump and build
88
89* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
90- automated rebuild
91
92* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.01-2
93- imported from mandrake. tweaked man path.
94
95* Mon Jun 18 2001 Till Kamppeter <till@mandrakesoft.com> 1.01-1mdk
96- Newly introduced for Foomatic.
97
Note: See TracBrowser for help on using the repository browser.