source: projects/specs/trunk/p/perl-XML-Dumper/perl-XML-Dumper-vl.spec @ 521

Revision 521, 3.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3%define name perl-XML-Dumper
4%define module  XML-Dumper
5
6Summary: Perl module for dumping Perl objects from/to XML
7Name: %{name}
8Version: 0.81
9Release: 1%{?_dist_release}
10License: GPL
11Group: Development/Libraries
12Source0: http://www.cpan.org/authors/id/E/EI/EISEN/%{module}-%{version}.tar.gz
13Url: http://www.cpan.org
14BuildRoot: %{_tmppath}/%{name}-%{version}-root/
15Requires: perl >= 5.8.2, perl-XML-Parser
16BuildRequires: perl >= 5.8.2, perl-XML-Parser >= 2.34
17BuildArch: noarch
18
19%description
20XML::Dumper dumps Perl data to XML format. XML::Dumper can also read
21XML data that was previously dumped by the module and convert it back
22to Perl.  Perl objects are blessed back to their original packaging;
23if the modules are installed on the system where the perl objects are
24reconstituted from xml, they will behave as expected. Intuitively, if
25the perl objects are converted and reconstituted in the same
26environment, all should be well.
27
28%prep
29%setup -q -n %{module}-%{version}
30
31%build
32CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
33make
34find ./ -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!%{__perl}|g"
35
36%clean
37rm -rf $RPM_BUILD_ROOT
38
39%install
40rm -rf $RPM_BUILD_ROOT
41mkdir -p $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man3}
42make DESTDIR=$RPM_BUILD_ROOT install
43#make PREFIX=$RPM_BUILD_ROOT%{_prefix} \
44#     NSTALLSITEARCH=%{buildroot}%{perl_sitearch} install
45
46find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
47
48find $RPM_BUILD_ROOT/usr -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v ^%{_mandir}   |
51        grep -v perllocal.pod |
52        grep -v "\.packlist" > XML-Dumper-%{version}-filelist
53if [ "$(cat XML-Dumper-%{version}-filelist)X" = "X" ] ; then
54    echo "ERROR: EMPTY FILE LIST"
55    exit -1
56fi
57install -m 644 blib/man3/* %{buildroot}%{_mandir}/man3
58
59%files -f XML-Dumper-%{version}-filelist
60%defattr(-,root,root)
61%doc README Changes MANIFEST
62%{_mandir}/man3/*3pm*
63
64%changelog
65* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.81-1
66- applied new versioning policy
67- rebuilt with perl-5.10.0
68- changed Group to Development/Libraries
69
70* Wed Jul 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.81-0vl1
71- new upstream release
72- rebuilt with perl-5.8.6
73- changed Group to Development/Languages
74
75* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 0.71-0vl1
76- new upstream release
77
78* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 0.67-0vl2
79- built on perl-5.8.2
80
81* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 0.67-0vl1
82- new upstream version
83- built on perl-5.8.1
84
85* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 0.4-25vl2
86- build on perl-5.8.0
87
88* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 0.4-25vl1
89- build for VineLinux
90
91* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
92- automated release bump and build
93
94* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
95- automated rebuild
96
97* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 2.30-5
98- got it to work.
99
100* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 2.30-4
101- imported from mandrake. tweaked man path.
102
103* Thu Jun 21 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.4-3mdk
104- Fixed an error in changelog.
105
106* Thu Jun 21 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.4-2mdk
107- Clean up spec.
108- Fixed distribution tag.
109- Needed by eGrail.
110
111* Mon Jun 18 2001 Till Kamppeter <till@mandrakesoft.com> 0.4-1mdk
112- Newly introduced for Foomatic.
113
Note: See TracBrowser for help on using the repository browser.