source: projects/specs/trunk/p/perl-XML-DOM/perl-XML-DOM-vl.spec @ 3212

Revision 3212, 3.0 KB checked in by iwaim, 13 years ago (diff)

perl-XML-DOM-1.44-9

Line 
1Name:           perl-XML-DOM
2Version:        1.44
3Release:        9%{?_dist_release}
4Summary:        DOM extension to XML::Parser
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/XML-DOM/
9Source0:        http://www.cpan.org/authors/id/T/TJ/TJMATHER/XML-DOM-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12BuildArch:      noarch
13# perl(XML::Parser::PerlSAX)
14BuildRequires:  perl-libxml-perl
15BuildRequires:  perl-XML-RegExp
16# for testing perl(LWP::UserAgent)
17BuildRequires:  perl-libwww-perl
18Requires:       perl-XML-Parser
19Requires:       perl-libwww-perl
20Requires:       perl >= %(eval "`%{__perl} -V:version`"; echo $version)
21#Obsoletes:      perl-libxml-enno <= 1.02
22Conflicts:      perl-libxml-enno <= 1.02
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28This is a Perl extension to XML::Parser. It adds a new 'Style' to
29XML::Parser, called 'Dom', that allows XML::Parser to build an Object
30Oriented datastructure with a DOM Level 1 compliant interface.  For a
31description of the DOM (Document Object Model), see
32http://www.w3.org/DOM/
33
34
35%prep
36%setup -q -n XML-DOM-%{version}
37
38cat <<EOF > %{name}-prov
39#!/bin/sh
40%{__perl_provides} \$* | grep -v 'perl(XML::XQL::Node)'
41EOF
42%define __perl_provides %{_builddir}/XML-DOM-%{version}/%{name}-prov
43chmod +x %{__perl_provides}
44
45
46%build
47%{__perl} Makefile.PL INSTALLDIRS=vendor
48make %{?_smp_mflags}
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
54find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
55find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
56chmod -R u+w $RPM_BUILD_ROOT/*
57
58
59%check
60make test
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66
67%files
68%defattr(-,root,root,-)
69%doc BUGS Changes README
70%{perl_vendorlib}/XML/
71%{_mandir}/man3/XML::*.3*
72
73
74%changelog
75* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.44-9
76- build with perl 5.12.3
77- add Vendor and Distribution tags
78
79* Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-8
80- s/Obsoletes/Conflicts/
81
82* Sat Aug 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-7
83- Initial build for Vine Linux
84
85* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-6
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
87
88* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-5
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
90
91* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-4
92- Rebuild for perl 5.10 (again)
93
94* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-3
95- rebuild for new perl
96
97* Wed Oct 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2.1
98- correct license tag
99- add BR: perl(ExtUtils::MakeMaker)
100
101* Thu Jun 29 2006 Orion Poplawski <orion@cora.nwra.com> - 1.44-2
102- Bump for new perl version (#196667)
103
104* Sat Nov  5 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-1
105- First Fedora Extras release (#172331).
106
107* Thu Oct 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-0.1
108- First build (#128879).
Note: See TracBrowser for help on using the repository browser.