source: projects/specs/trunk/p/perl-X11-Protocol/perl-X11-Protocol-vl.spec @ 521

Revision 521, 3.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           perl-X11-Protocol
2Version:        0.56
3Release:        1%{?_dist_release}
4Summary:        X11-Protocol - Raw interface to X Window System servers
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/X11-Protocol/
9Source0:        http://search.cpan.org/CPAN/authors/id/S/SM/SMCCAM/X11-Protocol-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12BuildArch:      noarch
13BuildRequires:  perl(ExtUtils::MakeMaker)
14Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
15
16%description
17X11::Protocol is a client-side interface to the X11 Protocol (see X(1) for
18information about X11), allowing perl programs to display windows and
19graphics on X11 servers.
20
21A full description of the protocol is beyond the scope of this documentation;
22for complete information, see the I<X Window System Protocol, X Version 11>,
23available as Postscript or *roff source from C<ftp://ftp.x.org>, or
24I<Volume 0: X Protocol Reference Manual> of O'Reilly & Associates's series of
25books about X (ISBN 1-56592-083-X, C<http://www.oreilly.com>), which contains
26most of the same information.
27
28%prep
29%setup -q -n X11-Protocol-%{version}
30
31# Testing requires X - use "rpmbuild --with X"
32%if 0%{!?_with_X:1}
33%{__perl} -pi -e 'print "print \"Remaining tests require X\n\"; exit 0;"
34    if /Insert your test code below/;' test.pl
35%endif
36
37perldoc -t perlartistic > Artistic
38perldoc -t perlgpl > COPYING
39
40# Remove shebangs from module code
41find . -name '*.pm' -exec sed -i -e '/^#!\/usr\/bin\/perl$/d' {} ';'
42
43
44%build
45%{__perl} Makefile.PL INSTALLDIRS=vendor
46%{__make} %{?_smp_mflags}
47
48
49%install
50%{__rm} -rf $RPM_BUILD_ROOT
51%{__make} pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
52find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
53find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
54%{__chmod} -R u+w $RPM_BUILD_ROOT/*
55
56
57%check
58%{__make} test
59
60
61%clean
62%{__rm} -rf $RPM_BUILD_ROOT
63
64
65%files
66%defattr(-,root,root,-)
67%doc README Changes Todo eg COPYING Artistic
68%{perl_vendorlib}/X11/
69%{_mandir}/man3/*.3*
70
71
72%changelog
73* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.56-1
74- initial build for Vine Linux based on fedora development
75
76* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.56-4
77- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
78
79* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.56-3
80- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
81
82* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.56-2
83Rebuild for new perl
84
85* Tue Sep 18 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 0.56-1
86- New upstream release (bugfix)
87- Added BR for perl(ExtUtils::MakeMaker)
88- License clarification
89- Minor spec cleanup, mainly to suppress rpmlint warnings
90
91* Fri Sep 15 2006 Duncan Ferguson <duncan_j_ferguson@yahoo.co.uk> 0.55-5
92- FC-6 rebuild requests
93
94* Tue Jun 20 2006 Duncan Ferguson <duncan_j_ferguson@yahoo.co.uk> 0.55-4
95- Update due to bug 195879
96
97* Sun Apr 02 2006 Duncan Ferguson <duncan_j_ferguson@yahoo.co.uk> 0.55-3
98- Change tests for X environment
99
100* Sat Apr 01 2006 Duncan Ferguson <duncan_j_ferguson@yahoo.co.uk> 0.55-2
101- Specfile bugfile
102
103* Fri Mar 31 2006 Duncan Ferguson <duncan_j_ferguson@yahoo.co.uk> 0.55-1
104- Update to new version of X11::Protocol
105
106* Fri Aug 26 2005 Paul Howarth <paul@city-fan.org> 0.54-2
107- remove redundant BR: perl
108- remove compiler optimization flags, redundant for noarch package
109- require "rpmbuild --with X" to run tests requiring X
110- include examples as %%doc
111- include license text
112
113* Thu Aug 18 2005 Duncan Ferguson <duncan_j_ferguson@yahoo.co.uk> 0.54-1
114- Initial build
Note: See TracBrowser for help on using the repository browser.