source: projects/specs/trunk/p/perl-WWW-Curl/perl-WWW-Curl-vl.spec @ 12121

Revision 12121, 6.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1Name:           perl-WWW-Curl
2Version:        4.17
3Release:        2%{?_dist_release}
4Summary:        Perl extension interface for libcurl
5License:        MIT
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/WWW-Curl/
8Source0:        http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT/WWW-Curl-%{version}.tar.gz
9Patch0:         WWW-Curl-4.17-Skip-preprocessor-symbol-only-CURL_STRICTER.patch
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14BuildRequires:  perl
15BuildRequires:  perl(inc::Module::Install)
16BuildRequires:  perl(Carp)
17BuildRequires:  perl(Exporter)
18BuildRequires:  perl(ExtUtils::MakeMaker)
19BuildRequires:  perl(File::Temp)
20%{?_with_network_tests: BuildRequires:  perl(lib) }
21BuildRequires:  perl(strict)
22BuildRequires:  perl(Test::More)
23# Test::Pod is optional
24BuildRequires:  perl(warnings)
25BuildRequires:  perl(XSLoader)
26BuildRequires:  curl-devel
27Requires:       perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
28
29%{?perl_default_filter}
30
31%description
32WWW::Curl is a Perl extension interface for libcurl.
33
34%prep
35%setup -q -n WWW-Curl-%{version}
36%patch0 -p1
37rm -rf inc && sed -i -e '/^inc\//d' MANIFEST
38
39%build
40perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
41make %{?_smp_mflags}
42
43%install
44make pure_install DESTDIR=$RPM_BUILD_ROOT
45find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
46find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
47%{_fixperms} $RPM_BUILD_ROOT/*
48
49%check
50# These tests require network, use "--with network_tests" to execute them
51%{?!_with_network_tests: rm t/01basic.t }
52%{?!_with_network_tests: rm t/02callbacks.t }
53%{?!_with_network_tests: rm t/04abort-test.t }
54%{?!_with_network_tests: rm t/05progress.t }
55%{?!_with_network_tests: rm t/08ssl.t }
56%{?!_with_network_tests: rm t/09times.t }
57%{?!_with_network_tests: rm t/14duphandle.t }
58%{?!_with_network_tests: rm t/15duphandle-callback.t }
59%{?!_with_network_tests: rm t/18twinhandles.t }
60%{?!_with_network_tests: rm t/19multi.t }
61%{?!_with_network_tests: rm t/21write-to-scalar.t }
62make test
63
64%files
65%doc Changes LICENSE README
66%{perl_vendorarch}/auto/*
67%{perl_vendorarch}/WWW*
68%{_mandir}/man3/*
69
70%changelog
71* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.17-2
72- rebuilt with perl-5.26.2.
73- added Patch0 for recent curl.
74
75* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.17-1
76- initial build for Vine Linux
77
78
79* Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 4.17-4
80- Perl 5.20 rebuild
81
82* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.17-3
83- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
84
85* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.17-2
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
87
88* Wed Feb 26 2014 Petr Šabata <contyk@redhat.com> - 4.17-1
89- 4.17 bump, license change
90
91* Fri Feb 21 2014 Petr Šabata <contyk@redhat.com> - 4.16-1
92- 4.16 bump
93
94* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-12
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
96
97* Fri Aug 02 2013 Petr Pisar <ppisar@redhat.com> - 4.15-11
98- Perl 5.18 rebuild
99
100* Sun Jul 14 2013 Jitka Plesnikova <jplesnik@redhat.com> - 4.15-10
101- Update dependencies
102- Use DESTDIR rather than PERL_INSTALL_ROOT
103- Remove buildroot cleaning
104
105* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-9
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
107
108* Thu Aug 16 2012 Jitka Plesnikova <jplesnik@redhat.com> - 4.15-8
109- Specify all dependencies
110- Modernize spec file
111
112* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-7
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
114
115* Fri Jun 22 2012 Petr Pisar <ppisar@redhat.com> - 4.15-6
116- Perl 5.16 rebuild
117
118* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-5
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
120
121* Sun Jul 24 2011 Iain Arnell <iarnell@gmail.com> 4.15-4
122- use perl_default_filter
123
124* Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.15-3
125- Perl mass rebuild
126
127* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-2
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
129
130* Tue Nov 30 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.15-1
131- Update to 4.15
132* Thu Oct 28 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.14-1
133- Update to 4.14
134- Add a filter provide to avoid private-shared-object-provides error
135* Sun Sep  5 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.13-1
136- Update to 4.13
137* Wed Aug 25 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.12-1
138- Update to 4.12
139* Thu Jun  3 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.11-3
140- Remove test 19 because it requires network
141* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 4.11-2
142- Mass rebuild with perl-5.12.0
143* Fri Dec 18 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.11-1
144- Update to 4.11
145* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 4.09-3
146- rebuild against perl 5.10.1
147* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.09-2
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
149* Sat Jul 11 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.09-1
150- Rebuild for 4.09
151* Mon Jun  1 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.07-1
152- Rebuild for 4.07
153* Sat Apr 18 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.06-1
154- Step to 4.06
155* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.05-5
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
157* Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-4
158- Licence update
159* Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-3
160- README.Win32 file removed
161* Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-2
162- Timestamp preserved
163- changelog format fix
164- README.Win32 file removed
165* Thu Dec 11 2008 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-1
166- Initial build with cpan2spec
Note: See TracBrowser for help on using the repository browser.