source: projects/specs/trunk/p/perl-Video-ivtv/perl-Video-ivtv-vl.spec @ 521

Revision 521, 2.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perlversion %(rpm -q perl --qf "%%{epoch}:%%{version}")
2%define pkgname Video-ivtv
3%define installdirs site
4
5Summary:        A perl module for ivtv support.
6Name:           perl-%{pkgname}
7Version:        0.13
8Release:        1%{?_dist_release}
9Group:          Development/Libraries
10License:        distributable
11URL:            http://ivtv.sf.net/
12Source0:        %{pkgname}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15Requires:       perl = %{perlversion}
16
17%description
18Video::ivtv is designed to be a quick hack at making the record_ivtv.pl
19script not have to depend on the test_ioctl program included with the ivtv
20utils.  By moving to have the things that have proven difficult to do purely
21in perl to C where they currently are being done, I can concentrate on
22improving the code rather than hitting my head against the wall trying to
23do code cleanups.  ;)
24
25%prep
26%setup -q -n %{pkgname}-%{version}
27
28%build
29CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
30make
31
32%install
33rm -rf $RPM_BUILD_ROOT
34make install
35
36[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
37
38find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
39        sed "s@^$RPM_BUILD_ROOT@@g" | \
40        grep -v perllocal.pod | \
41        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
42if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
43    echo "ERROR: EMPTY FILE LIST"
44    exit -1
45fi
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files -f %{pkgname}-%{version}-filelist
51%defattr(-,root,root)
52%doc README MANIFEST
53
54%changelog
55* Tue Jan 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.13-1
56- apply new versioning policy
57- rebuild with perl v5.10.0
58
59* Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl2
60- add Requires: perl = %%{perlversion}
61
62* Tue  May 16 2006 Takahiro Adachi <tadachi@tadachi-net.com> 0.13-0vl1
63- change source (0.13) for ivtv-0.2 or later version
64
65* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12-0vl1
66- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.