source: projects/specs/trunk/p/perl-Video-Frequencies/perl-Video-Frequencies-vl.spec @ 521

Revision 521, 1.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perlversion %(rpm -q perl --qf "%%{epoch}:%%{version}")
2%define pkgname Video-Frequencies
3
4Summary:        A perl module for the Video4linux tuner frequencies.
5Name:           perl-%{pkgname}
6Version:        0.03
7Release:        1%{?_dist_release}
8Group:          Development/Libraries
9License:        distributable
10URL:            http://ivtv.sf.net/
11Source0:        %{pkgname}-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildArch:      noarch
14Requires:       perl = %{perlversion}
15
16%description
17Video::Frequencies provides a table of hashes that represent all the current
18frequency mappings that are used by Video4Linux programs.
19
20%prep
21%setup -q -n %{pkgname}-%{version}
22
23%build
24CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
25make
26make test
27
28%install
29rm -rf $RPM_BUILD_ROOT
30make install
31
32[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
33
34find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
35        sed "s@^$RPM_BUILD_ROOT@@g" | \
36        grep -v perllocal.pod | \
37        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
38if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
39    echo "ERROR: EMPTY FILE LIST"
40    exit -1
41fi
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%files -f %{pkgname}-%{version}-filelist
47%defattr(-,root,root)
48%doc README MANIFEST
49
50%changelog
51* Tue Jan 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.03-1
52- apply new versioning policy
53- rebuild with perl v5.10.0
54
55* Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.03-0vl3
56- add Require: perl = %%{perlversion}
57
58* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.03-0vl2
59- rebuild with new environment
60
61* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.03-0vl1
62- initial build for Vine Linux
63
Note: See TracBrowser for help on using the repository browser.