source: projects/specs/trunk/p/perl-Unicode-String/perl-Unicode-String-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define realname        Unicode-String
2
3Name:           perl-Unicode-String
4Version:        2.09
5Release:        1%{_dist_release}
6License:        GPL or Artistic
7Group:          Development/Libraries
8Summary:        Unicode-String module for perl
9Source0:        ftp://ftp.perl.org/pub/CPAN/modules/by-module/Unicode/%{realname}-%{version}.tar.gz
10Url:            http://www.cpan.org
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildRequires:  perl >= 5.8.0
13Requires:       perl
14
15
16%description
17These are experimental modules to handle various Unicode issues.  They
18were made before perl included native UTF8 support.
19
20More information on what Unicode is and can do for you are to be found
21at http://www.unicode.org
22
23
24%prep
25%setup -q -n %{realname}-%{version}
26
27%build
28%{__perl} Makefile.PL INSTALLDIRS=vendor
29make
30
31%install
32rm -rf $RPM_BUILD_ROOT
33make install DESTDIR=$RPM_BUILD_ROOT
34
35[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
36
37find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
38find $RPM_BUILD_ROOT -type f -name '*.bs' -a -empty -exec rm -f {} ';'
39
40find $RPM_BUILD_ROOT/usr -type f -print |
41         sed "s@^$RPM_BUILD_ROOT@@g" |
42         grep -v perllocal.pod |
43         grep -v "\.packlist" > Unicode-Strings-%{version}-filelist
44if [ "$(cat Unicode-Strings-%{version}-filelist)X" = "X" ] ; then
45    echo "ERROR: EMPTY FILE LIST"
46    exit -1
47fi
48
49%check
50make test
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files -f Unicode-Strings-%{version}-filelist
56%defattr(-,root,root)
57
58%changelog
59* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.09-1vl5
60- rebuilt with perl-5.10.0
61- applied new versioning policy
62
63* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.09-0vl2
64- changed Group to Development/Libraries
65
66* Sat Jul 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.09-0vl1
67- new upstream release
68- changed Group to Development/Languages
69
70* Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 2.07-3vl2
71- built with perl-5.8.6
72
73* Sat Oct 02 2004 Satoshi MACHINO <machino@vinelinux.org> 2.07-3vl1
74- rebuilt for VineLinux
75
76* Thu Aug 14 2003 Per ŽØyvind Karlsen <peroyvind@linux-mandrake.com> 2.07-3mdk
77- rebuild for new perl
78- drop Prefix tag
79- don't use PREFIX
80- use %%makeinstall_std macro
81
82* Tue May 27 2003 Thierry Vignaud <tvignaud@mandrakesoft.com> 2.07-1mdk
83- rebuild for new auto{prov,req}
84
85* Fri Apr 25 2003 FraníÐis Pons <fpons@mandrakesoft.com> 2.07-1mdk
86- 2.07.
87
88* Wed Jan 29 2003 Lenny Cartier <lenny@mandrakesoft.com> 2.06-5mdk
89- rebuild
90
91* Fri Jan 24 2003 Arnaud de Lorbeau <adelorbeau@mandrakesoft.com> 2.06-4mdk
92- Rebuilt
93
94* Tue Aug 06 2002 Guillaume Rousse <g.rousse@linux-mandrake.com> 2.06-3mdk
95- rebuild for multi-thread perl
96
97* Wed Jul 10 2002 Pixel <pixel@mandrakesoft.com> 2.06-2mdk
98- rebuild for perl 5.8.0
99
100* Fri Mar  8 2002 Arnaud de Lorbeau <adelorbeau@mandrakesoft.com> 2.06-1mdk
101- First MandrakeSoft Package
Note: See TracBrowser for help on using the repository browser.