source: projects/specs/trunk/p/perl-Unicode-Map/perl-Unicode-Map-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?perl_vendorarch: %define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)}
2
3Name:           perl-Unicode-Map
4Version:        0.112
5Release:        8%{?_dist_release}
6Summary:        Perl module for mapping charsets from and to utf16 unicode
7
8Group:          Development/Libraries
9License:        GPL or Artistic
10URL:            http://search.cpan.org/dist/Unicode-Map/
11Source0:        http://www.cpan.org/authors/id/M/MS/MSCHWARTZ/Unicode-Map-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  perl
14
15%description
16This module converts strings from and to 2-byte Unicode UCS2
17format. All mappings happen via 2 byte UTF16 encodings, not via 1 byte
18UTF8 encoding. To convert between UTF8 and UTF16 use Unicode::String.
19For historical reasons this module coexists with Unicode::Map8.
20Please use Unicode::Map8 unless you need to care for >1 byte character
21sets, e.g. chinese GB2312. Anyway, if you stick to the basic
22functionality (see documentation) you can use both modules
23equivalently.
24Practically this module will disappear from earth sooner or later as
25Unicode mapping support needs somehow to get into perl's core. If you
26like to work on this field please don't hesitate contacting Gisle Aas
27and check out the mailing list perl-unicode!
28
29
30%prep
31%setup -q -n Unicode-Map-%{version}
32
33%build
34CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS=vendor
35make %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
36
37%install
38rm -rf $RPM_BUILD_ROOT
39make install \
40  PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
41  INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
42find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
43  -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
44find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
45chmod -R u+w $RPM_BUILD_ROOT/*
46
47%check || :
48make test
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(-,root,root,-)
55%doc COPYING Changes README
56%{_bindir}/m*
57%{perl_vendorarch}/auto/Unicode
58%{perl_vendorarch}/Unicode
59%{_mandir}/man[13]/*.[13]*
60
61
62%changelog
63* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.112-8vl5
64- rebuilt with perl-5.10.0
65- appiled new versioning policy
66
67* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.112-7vl2
68- changed Group to Development/Libraries
69
70* Mon Jul 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.112-7vl1
71- initial build for Vine Linux
72
73* Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 0.112-7
74- rebuild for FC5
75
76* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
77- rebuilt
78
79* Mon Feb  2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.112-0.fdr.5
80- Reduce directory ownership bloat.
81
82* Sat Oct 11 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.112-0.fdr.4
83- Install into vendor dirs.
84- Specfile cleanup.
85
86* Mon Jul  7 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.112-0.fdr.3
87- Regenerate %%install section with cpanflute2.
88- Improve %%description.
89
90* Sun May  4 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.112-0.fdr.2
91- Own more dirs.
92
93* Fri Mar 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.112-0.fdr.1
94- Update to current Fedora guidelines.
95
96* Sun Mar  2 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.112-1.fedora.1
97- First Fedora release.
Note: See TracBrowser for help on using the repository browser.