source: projects/specs/trunk/p/perl-URI/perl-URI-vl.spec @ 8656

Revision 8656, 2.8 KB checked in by iwaim, 10 years ago (diff)

perl-URI 1.58-2

Line 
1%define perlver         %(rpm -q --queryformat %%{version} perl)
2
3Summary: URI module for perl
4Name: perl-URI
5Version: 1.58
6Release: 2%{?_dist_release}
7License: distributable
8Group: Development/Libraries
9Source0: http://www.cpan.org/authors/id/GAAS/URI-%{version}.tar.gz
10Source1: filter-requires-perl-URI.sh
11Url: http://search.cpan.org/search?dist=URI
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl >= %{perlver}
15Requires: perl >= %{perlver}
16
17#BuildRequires:  perl(Business::ISBN)
18%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
19%define __find_requires %{SOURCE1}
20%else
21%define __perl_requires %{SOURCE1}
22%endif
23
24
25%description
26URI module for perl
27
28%prep
29%setup -q -n URI-%{version}
30
31%build
32CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
33make
34
35%install
36rm -rf $RPM_BUILD_ROOT
37mkdir -p $RPM_BUILD_ROOT%{_prefix}
38make DESTDIR=$RPM_BUILD_ROOT install
39
40find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
41
42find $RPM_BUILD_ROOT%{_prefix} -type f -print |
43        sed "s@^$RPM_BUILD_ROOT@@g" |
44        grep -v ^%{_mandir} |
45        grep -v perllocal.pod |
46        grep -v "\.packlist" > %{name}.files
47if [ "$(cat %{name}.files)X" = "X" ] ; then
48    echo "ERROR: EMPTY FILE LIST"
49    exit -1
50fi
51
52%check
53make test
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files -f %{name}.files
59%defattr(-,root,root)
60%doc README Changes
61%dir %{perl_vendorlib}/URI
62%dir %{perl_vendorlib}/URI/file
63%dir %{perl_vendorlib}/URI/urn
64%{_mandir}/man3/*
65
66%changelog
67* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.58-2
68- build with Perl 5.16
69
70* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.58-1
71- new upstream release
72- using __perl_requires macro for VineSeed (vl6)
73- drop rfc2396.txt in %%files: upstream deleted
74
75* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.40-1
76- new upstream release
77
78* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.35-1vl5
79- rebuilt with perl-5.10.0
80- applied new versioning policy
81
82* Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.35-0vl2
83- s/Copyright/License/
84- changed Group to Development/Libraries
85- added Source1 for removing dependancy perl(Business::ISBN)
86
87* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 1.35-0vl1
88- new upstream release
89- build on perl-5.8.6-0vl1
90- define perlver macro
91- run 'make test'
92
93* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 1.27-0vl2
94- built on perl-5.8.2
95
96* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.27-0vl1
97- new upstream version
98- built on perl-5.8.1
99
100* Thu Apr 24 2003 IWAI Masaharu <iwai@alib.jp> 1.23-0vl3
101- add %%{perl_sitelib}/URI/urn directory
102
103* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.23-0vl2
104- build on perl-5.8.0
105
106* Sat Feb 15 2003 IWAI Masaharu <iwai@alib.jp> 1.23-0vl1
107- update to 1.23
108
109* Sun Apr 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.18-0vl1
110- first build for Vine Linux
111
Note: See TracBrowser for help on using the repository browser.