source: projects/specs/trunk/p/perl-TimeDate/perl-TimeDate-vl.spec @ 521

Revision 521, 2.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3Summary: A Perl module for time and date manipulation.
4Name: perl-TimeDate
5Version: 1.16
6Release: 3%{_dist_release}
7License: distributable
8Group: Development/Libraries
9Source0: TimeDate-%{version}.tar.gz
10Url: http://search.cpan.org/search?query=timedate&mode=all
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: perl >= 0:5.00503
13Requires: perl >= 0:5.00503
14BuildArch: noarch
15
16%description
17This module includes a number of smaller modules suited for
18manipulation of time and date strings with Perl.  In particular, the
19Date::Format and Date::Parse modules can display and read times and
20dates in various formats, providing a more reliable interface to
21textual representations of points in time.
22
23# Provide perl-specific find-{provides,requires}.
24%define __find_provides /usr/lib/rpm/find-provides.perl
25%define __find_requires /usr/lib/rpm/find-requires.perl
26
27%prep
28%setup -q -n TimeDate-%{version}
29
30%build
31CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
32make
33
34%check
35make test
36
37%clean
38rm -rf $RPM_BUILD_ROOT
39
40%install
41rm -rf $RPM_BUILD_ROOT
42make DESTDIR=$RPM_BUILD_ROOT install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
47
48find $RPM_BUILD_ROOT%{_prefix} -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v perllocal.pod |
51        grep -v "\.packlist" > TimeDate-%{version}-filelist
52if [ "$(cat TimeDate-%{version}-filelist)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56
57%files -f TimeDate-%{version}-filelist
58%defattr(-,root,root)
59
60%changelog
61* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.16-3
62- built with perl-5.10.0.
63
64* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.16-2vl3
65- changed Group to Development/Libraries
66- changed INSTALLDIRS to vendor from site
67
68* Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 1.16-2vl2
69- built with perl-5.8.6
70
71* Sun Oct 03 2004 Satoshi MACHINO <machino@vinelinux.org> 1.16-2vl1
72- rebuilt for VineLinux
73        -- deleted epoch tag
74        -- changed INSTALLDIR to site from vendor
75
76* Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 1:1.16-2
77- rebuild
78
79* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 1:1.16-1
80- update to 1.16, bump epoch since previous version was 1.1301
81
82* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
83- automated release bump and build
84
85* Tue Aug  6 2002 Chip Turner <cturner@localhost.localdomain>
86- update to 1.301
87
88* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
89- automated rebuild
90
91* Wed Oct 24 2001 root <root@redhat.com>
92- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.