source: projects/specs/trunk/p/perl-Thread-Tie/perl-Thread-Tie-vl.spec @ 9004

Revision 9004, 2.7 KB checked in by inagaki, 9 years ago (diff)

2014-10-11 Ryoichi INAGAKI <ryo1@…>

  • perl-Net-SMTP-SSL, perl-Thread-Tie, perl-Test-MockDBI: rebuild
  • perl-Thread-Serialize, perl-Test-MockObject?, perl-UNIERSAL-can, perl-UNIVERSAL-isa, perl-load: update


Line 
1%define real_name Thread-Tie
2
3Summary:        Tie variables into a thread of their own
4Name:           perl-Thread-Tie
5Version:        0.13
6Release:        2%{?_dist_release}
7License:        Artistic or GPL+
8Group:          Development/Libraries
9URL:            http://search.cpan.org/dist/Thread-Tie/
10
11Source:         http://search.cpan.org/CPAN/authors/id/E/EL/ELIZABETH/Thread-Tie-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildArch:      noarch
14
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(Thread::Serialize) >= 0.07
17BuildRequires:  perl(load) >= 0.11
18Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
19Requires:       perl(Thread::Serialize) >= 0.07
20Requires:       perl(load) >= 0.11
21
22%description
23The standard shared variable scheme used by Perl, is based on tie-ing
24the variable to some very special dark magic. This dark magic ensures
25that shared variables, which are copied just as any other variable
26when a thread is started, update values in all of the threads where
27they exist as soon as the value of a shared variable is changed.
28
29Needless to say, this could use some improvement.
30
31The Thread::Tie module is a proof-of-concept implementation of another
32approach to shared variables. Instead of having shared variables exist
33in all the threads from which they are accessible, shared variable
34exist as "normal", unshared variables in a seperate thread. Only a
35tied object exists in each thread from which the shared variable is
36accesible.
37
38Through the use of a client-server model, any thread can fetch and/or
39update variables living in that thread. This client-server
40functionality is hidden under the hood of tie().
41
42
43This module only functions on Perl versions 5.8.0 and later.
44And then only when threads are enabled with -Dusethreads.  It
45is of no use with any version of Perl before 5.8.0 or without
46threads enabled.
47
48%prep
49%setup -q -n %{real_name}-%{version}
50
51%build
52%{expand: %%define optflags %{optflags} -fPIC}
53perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
54make %{?_smp_mflags}
55
56%install
57rm -rf %{buildroot}
58make pure_install DESTDIR=%{buildroot}
59find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
60find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
61%{_fixperms} %{buildroot}
62
63%check
64make test
65
66%clean
67rm -rf %{buildroot}
68
69%files
70%defattr(-, root, root, 0755)
71%doc MANIFEST README CHANGELOG TODO
72%{perl_vendorlib}/*
73%{_mandir}/man3/*
74
75%changelog
76* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.13-2
77- rebuild with perl 5.16.3
78- moved to Development/Libraries Group
79
80* Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.13-1
81- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.