source: projects/specs/trunk/p/perl-Thread-Pool/perl-Thread-Pool-vl.spec @ 9128

Revision 9128, 2.0 KB checked in by inagaki, 9 years ago (diff)

2014-12-01 Ryoichi INAGAKI <ryo1@…>

  • perl-Algorithm-Depndency, perl-Thread-{Conveyor, Conveyor-Monitored, Pool}: rebuilt
  • perl-BDB, perl-Coro, perl-URI, perl-SUPER: updated


Line 
1%define real_name Thread-Pool
2
3Summary:        Group of threads for performing similar jobs
4Name:           perl-Thread-Pool
5Version:        0.33
6Release:        2%{?_dist_release}
7License:        Artistic
8Group:          Development/Libraries
9URL:            http://search.cpan.org/dist/Thread-Pool/
10
11Source:         http://www.cpan.org/modules/by-module/Thread/Thread-Pool-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildArch:      noarch
15BuildRequires:  perl
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(load)
18BuildRequires:  perl(Thread::Conveyor) >= 0.15
19BuildRequires:  perl(Thread::Conveyor::Monitored) >= 0.11
20Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24
25%description
26The Thread::Pool allows you to set up a group of (worker) threads to
27execute a (large) number of similar jobs that need to be executed
28asynchronously. The routine that actually performs the job (the "do"
29routine), must be specified as a name or a reference to a (anonymous)
30subroutine.
31
32This module only functions on Perl versions 5.8.0 and later.
33And then only when threads are enabled with -Dusethreads.  It
34is of no use with any version of Perl before 5.8.0 or without
35threads enabled.
36%prep
37%setup -q -n %{real_name}-%{version}
38
39%build
40perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
41make %{?_smp_mflags}
42
43%install
44rm -rf %{buildroot}
45make pure_install DESTDIR=%{buildroot}
46find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
47find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
48%{_fixperms} %{buildroot}
49
50%check
51make test
52
53%clean
54%{__rm} -rf %{buildroot}
55
56%files
57%defattr(-, root, root, 0755)
58%doc MANIFEST README CHANGELOG TODO
59%{perl_vendorlib}/*
60%{_mandir}/man3/*
61
62%changelog
63* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.33-2
64- rebuilt with perl 5.16.3
65
66* Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.33-1
67- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.