source: projects/specs/trunk/p/perl-Thread-Conveyor/perl-Thread-Conveyor-vl.spec @ 9128

Revision 9128, 2.6 KB checked in by inagaki, 9 years ago (diff)

2014-12-01 Ryoichi INAGAKI <ryo1@…>

  • perl-Algorithm-Depndency, perl-Thread-{Conveyor, Conveyor-Monitored, Pool}: rebuilt
  • perl-BDB, perl-Coro, perl-URI, perl-SUPER: updated


Line 
1%define real_name Thread-Conveyor
2
3Summary:        Transport of any data-structure between threads
4Name:           perl-Thread-Conveyor
5Version:        0.19
6Release:        2%{?_dist_release}
7License:        Artistic or GPL+
8Group:          Development/Libraries
9URL:            http://search.cpan.org/dist/Thread-Conveyor/
10Source:         http://www.cpan.org/modules/by-module/Thread/Thread-Conveyor-%{version}.tar.gz
11BuildArch:      noarch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires:  perl
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(load)
17BuildRequires:  perl(Thread::Tie) >= 0.09
18BuildRequires:  perl(Thread::Serialize)
19Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23
24%description
25The Thread::Conveyor object is a thread-safe data structure that
26mimics the behaviour of a conveyor belt. One or more worker threads
27can put boxes with frozen values and references on one end of the belt
28to be taken off by one or more worker threads on the other end of the
29belt to be thawed and returned.
30
31A box may consist of any combination of scalars and references to
32scalars, arrays (lists) and hashes. Freezing and thawing is currently
33done with the Thread::Serialize module, but that may change in the
34future. Objects and code references are currently not allowed.
35
36By default, the maximum number of boxes on the belt is limited to 50.
37Putting of boxes on the belt is halted if the maximum number of boxes
38is exceeded. This throttling feature was added because it was found
39that excessive memory usage could be caused by having the belt growing
40too large. Throttling can be disabled if so desired.
41
42This module only functions on Perl versions 5.8.0 and later.
43And then only when threads are enabled with -Dusethreads.  It
44is of no use with any version of Perl before 5.8.0 or without
45threads enabled.
46%prep
47%setup -q -n %{real_name}-%{version}
48
49%build
50%{expand: %%define optflags %{optflags} -fPIC}
51perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
52make %{?_smp_mflags}
53
54%install
55rm -rf %{buildroot}
56make pure_install DESTDIR=%{buildroot}
57find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
58find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
59%{_fixperms} %{buildroot}
60
61%check
62make test
63
64%clean
65rm -rf %{buildroot}
66
67%files
68%defattr(-, root, root, -)
69%doc MANIFEST README CHANGELOG TODO
70%{perl_vendorlib}/*
71%{_mandir}/man3/*
72
73%changelog
74* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.19-2
75- rebuilt with perl 5.16.3
76
77* Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.19-1
78- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.