source: projects/specs/trunk/p/perl-Text-Markdown/perl-Text-Markdown-vl.spec @ 6886

Revision 6886, 2.2 KB checked in by yasumichi, 12 years ago (diff)

first import

Line 
1%define pkgname Text-Markdown
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.000031
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Text::Markdown - Convert Markdown syntax to (X)HTML
18Summary(ja):    Text::Markdown - Markdown 文法から (X)HTML への変換
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27 Markdown is a text-to-HTML filter; it translates an easy-to-read /
28easy-to-write structured text format into HTML. Markdown's text format is
29most similar to that of plain text email, and supports features such as
30headers, *emphasis*, code blocks, blockquotes, and links.
31
32 Markdown's syntax is designed not as a generic markup language, but
33specifically to serve as a front-end to (X)HTML. You can use span-level
34HTML tags anywhere in a Markdown document, and you can use block level HTML
35tags (like <div> and <table> as well).
36
37#%%description -l ja
38
39
40%prep
41%setup -q -n Text-Markdown-1.000031
42
43%build
44%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
45%{__make} %{?_smp_mflags}
46
47%install
48%{__rm} -rf ${RPM_BUILD_ROOT}
49%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
50
51# remove unnecessary files.
52find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
53find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
54find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
55find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
56
57# generate file list
58find $RPM_BUILD_ROOT%{_prefix} -type f -print |
59        sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
60
61if [ "$(cat %{name}.files)X" = "X" ] ; then
62        echo "ERROR: EMPTY FILE LIST"
63        exit -1
64fi
65
66
67%clean
68%{__rm} -rf ${RPM_BUILD_ROOT}
69
70
71%files -f %{name}.files
72%defattr(-,root,root)
73%doc Changes README
74
75%changelog
76* Fri Oct 05 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.000031-1
77- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.