source: projects/specs/trunk/p/perl-Text-CharWidth/perl-Text-CharWidth-vl.spec @ 2394

Revision 2394, 2.3 KB checked in by yasumichi, 13 years ago (diff)

new package "perl-Text-CharWidth?"

Line 
1%include %{_rpmconfigdir}/macros.perl
2
3# Basic Information
4Name:           perl-Text-CharWidth
5Version:        0.04
6Release:        1%{?_dist_release}
7License:        Artistic/GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/K/KU/KUBOTA/Text-CharWidth-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Text-CharWidth module for perl
17Summary(ja):    Perl の Text-CharWidth モジュール
18
19# Dependency
20# 以下に依存関係を記述してください。
21
22Requires:       perl
23Requires:       glibc
24
25BuildRequires:  perl
26BuildRequires:  glibc-devel
27BuildRequires:  glibc-headers
28
29%description
30This is a module to provide equivalent feature as wcwidth(3) and
31wcswidth(3).  This also provides mblen(3) equivalent subroutine.
32mbwidth() and mbswidth() are provided subroutines corresponding
33wcwidth(3) and wcswidth(3) in C language.  The prefix "mb" expresses
34that they handles "multibyte character" in C meaning, i.e., character
35encoding specified by LC_CTYPE locale.
36
37%description -l ja
38このモジュールは、wcwidth(3)、wcswidth(3) および mblen(3) と同等の機能を提供
39します。
40mbwidth() および mbswidth() は、C言語の wcwidth(3) および wcswidth(3) に対応
41するサブルーチンとして提供されます。接頭辞「mb」は、Cでは、「マルチバイト文
42字」を扱うことを意味します。文字エンコーディングは、LC_CTYPE によって指定し
43ます。
44
45%prep
46%setup -q -n Text-CharWidth-%{version}
47
48%build
49CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
50%{__make}
51
52%check
53%{__make} test
54
55%install
56%{__rm} -rf ${RPM_BUILD_ROOT}
57%{__make} install DESTDIR=${RPM_BUILD_ROOT}
58
59find $RPM_BUILD_ROOT%{_prefix} -type f -print |
60        sed "s@^$RPM_BUILD_ROOT@@g" |
61        grep -v ^%{_mandir} |
62        grep -v perllocal.pod |
63        grep -v "\.packlist" > %{name}.files
64if [ "$(cat %{name}.files)X" = "X" ] ; then
65    echo "ERROR: EMPTY FILE LIST"
66    exit -1
67fi
68
69# remove unnecessary files.
70%{__rm} -rf  ${RPM_BUILD_ROOT}/%{perl_archlib}/perllocal.pod
71%{__rm} -rf  ${RPM_BUILD_ROOT}/%{perl_vendorarch}/auto/Text/CharWidth/.packlist
72
73%clean
74%{__rm} -rf ${RPM_BUILD_ROOT}
75
76%files -f %{name}.files
77%defattr(-,root,root)
78%doc Changes README
79%{_mandir}/*/*
80
81%changelog
82* Sun Dec 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.04-1
83- initial build for Vine Linux
84
Note: See TracBrowser for help on using the repository browser.