source: projects/specs/trunk/p/perl-Test2-Plugin-NoWarnings/perl-Test2-Plugin-NoWarnings-vl.spec @ 12120

Revision 12120, 5.1 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Test2-Plugin-NoWarnings
2Version:        0.07
3Release:        2%{?_dist_release}
4Summary:        Fail if tests warn
5License:        Artistic 2.0
6URL:            https://metacpan.org/release/Test2-Plugin-NoWarnings
7Source0:        https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/Test2-Plugin-NoWarnings-%{version}.tar.gz
8
9Vendor:        Project Vine
10Distribution:  Vine Linux
11
12BuildArch:      noarch
13# Build
14BuildRequires:  coreutils
15BuildRequires:  make
16BuildRequires:  perl >= 2:5.26.2
17BuildRequires:  perl(ExtUtils::MakeMaker)
18# Module Runtime
19BuildRequires:  perl(Carp)
20BuildRequires:  perl(parent)
21BuildRequires:  perl(strict)
22BuildRequires:  perl(Test2)
23BuildRequires:  perl(Test2::API)
24BuildRequires:  perl(Test2::Event)
25BuildRequires:  perl(Test2::Util::HashBase)
26BuildRequires:  perl(warnings)
27# Test Suite
28BuildRequires:  perl(Capture::Tiny)
29BuildRequires:  perl(File::Spec)
30BuildRequires:  perl(IPC::Run3)
31BuildRequires:  perl(Test2::Require::Module)
32BuildRequires:  perl(Test2::V0)
33BuildRequires:  perl(Test::More)
34# Optional Tests
35BuildRequires:  perl(CPAN::Meta)
36BuildRequires:  perl(CPAN::Meta::Prereqs)
37# Dependencies
38Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
39
40%description
41Loading this plugin causes your tests to fail if there are any warnings while
42they run. Each warning generates a new failing test and the warning content is
43outputted via diag.
44
45This module uses $SIG{__WARN__}, so if the code you're testing sets this, then
46this module will stop working.
47
48%prep
49%setup -q -n Test2-Plugin-NoWarnings-%{version}
50
51%build
52perl Makefile.PL INSTALLDIRS=vendor NO_PERLLOCAL=1 NO_PACKLIST=1
53%{make_build}
54
55%install
56%{make_install}
57%{_fixperms} -c %{buildroot}
58
59%check
60make test
61
62%files
63%license LICENSE
64%doc Changes CODE_OF_CONDUCT.md README.md
65%{perl_vendorlib}/Test2/
66%{_mandir}/man3/Test2::Event::Warning.3*
67%{_mandir}/man3/Test2::Plugin::NoWarnings.3*
68
69%changelog
70* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.07-2
71- initial build for Vine Linux.
72
73* Mon Apr 22 2019 Paul Howarth <paul@city-fan.org> - 0.07-1
74- Update to 0.07
75  - Reverted back to using the Warning event type, since the bug in the Test2
76    core that caused this to be a problem has since been fixed
77  - Replaced use of Test2::Bundle::Extended with Test2::V0
78- Package new document CODE_OF_CONDUCT.md
79- Modernize spec using %%{make_build} and %%{make_install}
80
81* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.06-6
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
83
84* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.06-5
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
86
87* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.06-4
88- Perl 5.28 rebuild
89
90* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.06-3
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
92
93* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.06-2
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
95
96* Mon Jun 19 2017 Paul Howarth <paul@city-fan.org> - 0.06-1
97- Update to 0.06
98  - Warnings inside a subtest were not emitted as TAP events, breaking the TAP
99    and making for great confusion: this is because of a bug in the core TAP
100    formatter (https://github.com/Test-More/test-more/issues/776); warnings
101    are now emitted as Ok events instead of Warning events
102
103* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.05-3
104- Perl 5.26 rebuild
105
106* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.05-2
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
108
109* Tue Nov  8 2016 Paul Howarth <paul@city-fan.org> - 0.05-1
110- Update to 0.05
111  - Skip compile.t on Windows; this test uses IPC::Run3, which doesn't seem to
112    work well on that platform (CPAN RT#118443)
113
114* Thu Oct 27 2016 Paul Howarth <paul@city-fan.org> - 0.04-2
115- We provide Test2::Event::Warning so we don't need to build-require it
116
117* Mon Oct 24 2016 Paul Howarth <paul@city-fan.org> - 0.04-1
118- Update to 0.04
119  - Load Test2::Event::Warning in the plugin instead of relying on Test2 to do
120    it for us; this should avoid the bug fixed in the previous version and
121    eliminates the need for the INIT block, which caused its own problems
122
123* Tue Oct 18 2016 Paul Howarth <paul@city-fan.org> - 0.03-1
124- Update to 0.03
125  - Add the $SIG{__WARN__} hook in an INIT block; we really don't want to
126    trigger this because of a compile-time warning, and because of a bug in
127    Test::Builder, this can actually cause the warning to be lost entirely
128    (https://github.com/Test-More/test-more/issues/729)
129  - The Test2::Event::Warning event now returns true for increments_count,
130    which means that the test failure caused by a warning will not be output
131    as a TAP test line; previously this was just seen as a diag line, which
132    could be quite confusing
133    (https://github.com/Test-More/test-more/issues/728)
134
135* Mon Sep 19 2016 Paul Howarth <paul@city-fan.org> - 0.02-3
136- Drop unused BR: findutils (#1377228)
137
138* Mon Sep 19 2016 Paul Howarth <paul@city-fan.org> - 0.02-2
139- Sanitize for Fedora submission
140
141* Sun Sep 18 2016 Paul Howarth <paul@city-fan.org> - 0.02-1
142- Initial RPM version
Note: See TracBrowser for help on using the repository browser.