source: projects/specs/trunk/p/perl-Test-Warnings/perl-Test-Warnings-vl.spec @ 9158

Revision 9158, 5.7 KB checked in by inagaki, 9 years ago (diff)

2014-12-16 Ryoichi INAGAKI <ryo1@…>

  • perl-DateTime?-TimeZone?, perl-LDAP: updated
  • perl-List-AllUtils?, perl-Test-Warnings: NEW
  • perl-Unicode-{Map, Map8, MapUTF8, String}: rebuilt
  • perl-X11-Protocol: rebuilt


Line 
1Name:           perl-Test-Warnings
2Version:        0.016
3Release:        3%{?_dist_release}
4Summary:        Test for warnings and the lack of them
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Test-Warnings
8Source0:        http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Test-Warnings-%{version}.tar.gz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12# Build
13BuildRequires:  perl
14BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.30
15# Module
16BuildRequires:  perl(Exporter)
17BuildRequires:  perl(Test::Builder)
18BuildRequires:  perl(parent)
19BuildRequires:  perl(strict)
20BuildRequires:  perl(warnings)
21# Test Suite
22BuildRequires:  perl(CPAN::Meta)
23BuildRequires:  perl(CPAN::Meta::Requirements)
24BuildRequires:  perl(ExtUtils::MakeMaker)
25BuildRequires:  perl(File::Spec::Functions)
26BuildRequires:  perl(if)
27BuildRequires:  perl(List::Util)
28BuildRequires:  perl(Test::More) >= 0.94
29BuildRequires:  perl(Test::Tester) >= 0.108
30BuildRequires:  perl(version)
31# Runtime
32Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38If you've ever tried to use Test::NoWarnings to confirm there are no warnings
39generated by your tests, combined with the convenience of done_testing to not
40have to declare a test count, you'll have discovered that these two features do
41not play well together, as the test count will be calculated before the
42warnings test is run, resulting in a TAP error (see examples/test_nowarnings.pl
43in this distribution for a demonstration).
44
45This module is intended to be used as a drop-in replacement for
46Test::NoWarnings: it also adds an extra test, but runs this test before
47done_testing calculates the test count, rather than after. It does this by
48hooking into done_testing as well as via an END block. You can declare a plan,
49or not, and things will still Just Work.
50
51It is actually equivalent to:
52
53    use Test::NoWarnings 1.04 ':early';
54
55as warnings are still printed normally as they occur. You are safe, and
56enthusiastically encouraged, to perform a global search-replace of the above
57with use Test::Warnings; whether or not your tests have a plan.
58
59%prep
60%setup -q -n Test-Warnings-%{version}
61
62%build
63perl Makefile.PL INSTALLDIRS=vendor
64make %{?_smp_mflags}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make pure_install DESTDIR=$RPM_BUILD_ROOT
69find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
70%{_fixperms} $RPM_BUILD_ROOT
71
72%check
73make test
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%doc Changes CONTRIBUTING LICENSE README README.md examples/
80%{perl_vendorlib}/Test/
81%{_mandir}/man3/Test::Warnings.3pm*
82
83%changelog
84* Sun Dec 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.016-3
85- inital build for Vine Linux
86
87* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.016-2
88- Perl 5.20 rebuild
89
90* Sun Jun 22 2014 Paul Howarth <paul@city-fan.org> - 0.016-1
91- Update to 0.16
92  - Fix prereq problem with last release - now no longer testing the example
93    scripts for user installs
94
95* Fri Jun 20 2014 Paul Howarth <paul@city-fan.org> - 0.015-1
96- Update to 0.15
97  - Adjusted packaging and tests to become perl-5.6 friendly, including only
98    using core or dual-lifed prerequisites
99- Switch to ExtUtils::MakeMaker flow
100
101* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.014-2
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
103
104* Mon Mar  3 2014 Paul Howarth <paul@city-fan.org> - 0.014-1
105- Update to 0.014
106  - Fix test that fails when FOO or BAR environment variables are set
107    (CPAN RT#93447)
108
109* Mon Dec 16 2013 Paul Howarth <paul@city-fan.org> - 0.013-1
110- Update to 0.013
111  - Update configure_requires checking in Makefile.PL
112
113* Mon Oct 14 2013 Paul Howarth <paul@city-fan.org> - 0.012-1
114- Update to 0.012
115  - Re-release to fix t/00-report-prereqs.t use of CPAN::Meta::Requirements
116
117* Sun Oct 13 2013 Paul Howarth <paul@city-fan.org> - 0.011-1
118- Update to 0.011
119  - Unnecessary tests removed
120  - CONTRIBUTING file added
121- Drop buildreqs only needed for removed tests
122- BR: optional test requirement perl(CPAN::Meta::Requirements)
123
124* Wed Sep 25 2013 Paul Howarth <paul@city-fan.org> - 0.010-1
125- Update to 0.010
126  - Re-release with fixed compile test
127- Update dependencies
128- Package examples
129
130* Wed Sep 11 2013 Paul Howarth <paul@city-fan.org> - 0.009-1
131- Update to 0.009
132  - Fixed error in synopsis (we do not export anything by default)
133  - A caveat added to the documentation regarding embedding warning checks
134    inside another sub
135  - ':no_end_test' now also covers side effects of done_testing, as well as
136    END blocks, making it possible to use the warning(s) subs without having an
137    end warning test while using done_testing (necessary when combining with
138    the 'if' pragma)
139  - END tests will not be added by a subequent use of Test::Warnings if a
140    previous one passed ':no_end_test'
141- Update dependencies
142
143* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.008-3
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
145
146* Wed Jul 24 2013 Petr Pisar <ppisar@redhat.com> - 0.008-2
147- Perl 5.18 rebuild
148
149* Mon Jul 15 2013 Paul Howarth <paul@city-fan.org> - 0.008-1
150- Update to 0.008
151  - Compile test updated, to hopefully fix mswin32 parsing issues
152
153* Wed Jul 10 2013 Paul Howarth <paul@city-fan.org> - 0.007-1
154- Update to 0.007
155  - Fix subtest tests to work on Test::More before 0.95_01 (CPAN RT#86802)
156- BR: perl(Capture::Tiny)
157- Bump perl(Module::Build::Tiny) version requirement to 0.024
158- Bump perl(Test::CheckDeps) version requirement to 0.006
159- Drop perl(Test::More) version requirement to 0.94
160
161* Tue Jul  9 2013 Paul Howarth <paul@city-fan.org> - 0.006-2
162- Sanitize for Fedora submission
163
164* Tue Jul  9 2013 Paul Howarth <paul@city-fan.org> - 0.006-1
165- Initial RPM version
Note: See TracBrowser for help on using the repository browser.