source: projects/specs/trunk/p/perl-Test-UseAllModules/perl-Test-UseAllModules-vl.spec @ 4919

Revision 4919, 1.9 KB checked in by yasumichi, 13 years ago (diff)

Import spec file.

Line 
1%define pkgname Test-UseAllModules
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.13
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        do use_ok() for all the MANIFESTed modules
17#Summary(ja):   ここに日本語で概要を記述してください
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26I'm sick of writing 00_load.t (or something like that) that'll do use_ok()
27for every module I write. I'm sicker of updating 00_load.t when I add
28another file to the distro. This module reads MANIFEST to find modules to be
29tested and does use_ok() for each of them. Now all you have to do is update
30MANIFEST. You don't have to modify the test any more (hopefully).
31
32#%%description -l ja
33#ここに日本語で詳細を記述してください。
34
35%prep
36%setup -q -n Test-UseAllModules-0.13
37
38%build
39perl Makefile.PL
40%{__make}
41
42%install
43%{__rm} -rf ${RPM_BUILD_ROOT}
44%{__make} install DESTDIR=${RPM_BUILD_ROOT}
45
46find $RPM_BUILD_ROOT%{_prefix} -type f -print |
47        sed "s@^$RPM_BUILD_ROOT@@g" |
48        grep -v ^%{_mandir} |
49        grep -v perllocal.pod |
50        grep -v "\.packlist" > %{name}.files
51if [ "$(cat %{name}.files)X" = "X" ] ; then
52        echo "ERROR: EMPTY FILE LIST"
53        exit -1
54fi
55
56# remove unnecessary files.
57%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
58%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Test/UseAllModules/.packlist
59
60
61%clean
62%{__rm} -rf ${RPM_BUILD_ROOT}
63
64
65%files -f %{name}.files
66%defattr(-,root,root)
67%doc Changes README
68%{_mandir}/*/*
69
70
71%changelog
72* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-1
73- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.