source: projects/specs/trunk/p/perl-Test-Unit/perl-Test-Unit-vl.spec @ 9165

Revision 9165, 2.9 KB checked in by inagaki, 9 years ago (diff)

2014-12-18 Ryoichi INAGAKI <ryo1@…>

  • clearsilver, perl-AppConfig?, perl-Class-Inner, perl-DateTime?-{Calendar-Mayan, Locale}, perl-Goo-Canvas, perl-Test-Unit: rebuilt
  • perl-DateTime?, perl-Test-Manifest: updated


Line 
1Summary: a unit testing interface for Perl
2Name: perl-Test-Unit
3Version: 0.25
4Release: 3%{?_dist_release}
5License: GPL+ or Artistic
6Group: Development/Libraries
7URL: http://perlunit.sourceforge.net/
8
9Source0: http://prdownloads.sourceforge.net/perlunit/Test-Unit-%{version}.tar.gz
10# https://rt.cpan.org/Public/Bug/Display.html?id=69025
11Patch0: tests5.14.patch
12# https://rt.cpan.org/Public/Bug/Display.html?id=77779
13Patch1: perl5.16.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildArch:      noarch
17BuildRequires:  perl(ExtUtils::MakeMaker)
18BuildRequires:  perl(Carp)
19BuildRequires:  perl(Class::Inner)
20BuildRequires:  perl(Data::Dumper)
21BuildRequires:  perl(Devel::Symdump)
22BuildRequires:  perl(Error)
23BuildRequires:  perl(Exporter)
24BuildRequires:  perl(Test)
25BuildRequires:  perl(Tk)
26BuildRequires:  perl(Tk::Canvas)
27BuildRequires:  perl(Tk::Derived)
28BuildRequires:  perl(Tk::DialogBox)
29BuildRequires:  perl(Tk::ROText)
30Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
31
32%description
33Test::Unit is the procedural style interface to a sophisticated
34unit testing framework for Perl that is derived from the JUnit
35testing framework for Java by Kent Beck and Erich Gamma.
36
37%prep
38%setup -q -n Test-Unit-%{version}
39%patch0 -p1
40%patch1 -p1
41sed -i 's/\r//' examples/Experimental/Sample.pm
42chmod a+x TkTestRunner.pl TestRunner.pl
43
44%build
45CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
46make
47
48%install
49rm -rf $RPM_BUILD_ROOT
50make pure_install DESTDIR=$RPM_BUILD_ROOT
51
52find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
53find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
54chmod -R u+w $RPM_BUILD_ROOT/*
55
56%check
57make test
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(-,root,root)
64%doc AUTHORS ChangeLog Changes COPYING.Artistic COPYING.GPL-2 doc examples README
65%{perl_vendorlib}/*
66%{_mandir}/man3/*
67
68%changelog
69* Wed Dec 17 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.25-3
70- rebuilt with perl 5.16.3
71- added Patch0 and 1 from Fedora
72  * Mon Jun 11 2012 Petr Pisar <ppisar@redhat.com> - 0.25-13
73  - apply patch to for Test::Unit::TestBase RT#77779
74  * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.25-11
75  - apply upstream patch for tests RT#69025
76
77* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25-2
78- rebuild with perl-5.12.3
79
80* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.25-1vl5
81- applied new versioning policy
82- added BuildRequires: perl-Class-Inner, perl-Devel-Symdump, perl-Error
83
84* Thu Feb 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.25-0vl1
85- updated to 0,25
86- changed Group to Development/Libraires
87- added Requires: perl-Tk
88
89* Sat May 10 2003 IWAI Masaharu <iwai@alib.jp> 0.24-0vl1
90- version up to 0.24
91- replace Copyright tag with License tag
92- clarify the License
93- update Requires:
94    add perl-Error, perl-Devel-Symdump and perl-Class-Inner
95
96* Fri Apr  5 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.14-0vl1
97- first release for Vine Linux
98
Note: See TracBrowser for help on using the repository browser.