source: projects/specs/trunk/p/perl-Test-Simple/perl-Test-Simple-vl.spec @ 12120

Revision 12120, 23.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%bcond_with perl_Test_Simple_enables_optional_test
2
3Name:           perl-Test-Simple
4Summary:        Basic utilities for writing tests
5Version:        1.302164
6Release:        2%{?_dist_release}
7# CC0: lib/ok.pm
8# Public Domain: lib/Test/Tutorial.pod
9# GPL+ or Artistic: the rest of the distribution
10License:        (GPL+ or Artistic) and CC0 and Public Domain
11URL:            https://metacpan.org/release/Test-Simple
12Source0:        https://cpan.metacpan.org/modules/by-module/Test/Test-Simple-%{version}.tar.gz
13
14Vendor:        Project Vine
15Distribution:  Vine Linux
16
17BuildArch:      noarch
18# Module Build
19BuildRequires:  coreutils
20BuildRequires:  make
21BuildRequires:  perl >= 2:5.26.2
22BuildRequires:  perl(ExtUtils::MakeMaker)
23# Module Runtime
24BuildRequires:  perl(base)
25BuildRequires:  perl(Carp)
26BuildRequires:  perl(Config)
27BuildRequires:  perl(Data::Dumper)
28BuildRequires:  perl(Exporter)
29BuildRequires:  perl(File::Spec)
30BuildRequires:  perl(File::Temp)
31BuildRequires:  perl(IO::Handle)
32BuildRequires:  perl(List::Util)
33BuildRequires:  perl(overload)
34BuildRequires:  perl(PerlIO)
35BuildRequires:  perl(POSIX)
36BuildRequires:  perl(Scalar::Util)
37BuildRequires:  perl(Storable)
38BuildRequires:  perl(strict)
39BuildRequires:  perl(Symbol)
40BuildRequires:  perl(Term::ANSIColor)
41BuildRequires:  perl(Term::Table)
42BuildRequires:  perl(vars)
43BuildRequires:  perl(warnings)
44# Test Suite
45BuildRequires:  perl(Cwd)
46BuildRequires:  perl(File::Basename)
47BuildRequires:  perl(IO::Pipe)
48BuildRequires:  perl(lib)
49BuildRequires:  perl(threads)
50# Optional Tests
51BuildRequires:  perl(CPAN::Meta)
52BuildRequires:  perl(CPAN::Meta::Requirements)
53BuildRequires:  perl(IPC::Open3)
54BuildRequires:  perl(Module::Metadata)
55BuildRequires:  perl(POSIX)
56BuildRequires:  perl(Test::Harness)
57%if !%{defined perl_bootstrap}
58%if %{with perl_Test_Simple_enables_optional_test}
59BuildRequires:  perl(Test::Class)
60BuildRequires:  perl(Test::Pod)
61BuildRequires:  perl(Test::Script)
62%endif
63%endif
64# Runtime
65Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
66Requires:       perl(Data::Dumper)
67Requires:       perl(Term::ANSIColor)
68Requires:       perl(Term::Table)
69
70%{?perl_default_filter}
71
72%description
73This package provides the bulk of the core testing facilities. For more
74information, see perldoc for Test::Simple, Test::More, etc.
75
76This package is the CPAN component of the dual-lifed core package Test-Simple.
77
78%prep
79%setup -q -n Test-Simple-%{version}
80
81%build
82perl Makefile.PL INSTALLDIRS=vendor NO_PERLLOCAL=1 NO_PACKLIST=1
83%{make_build}
84
85%install
86%{make_install}
87%{_fixperms} -c %{buildroot}
88
89%check
90make test AUTHOR_TESTING=1
91
92%files
93%license LICENSE
94%doc Changes README examples/ t/
95%dir %{perl_vendorlib}/Test/
96%{perl_vendorlib}/ok.pm
97%{perl_vendorlib}/Test/Builder.pm
98%{perl_vendorlib}/Test/Builder/
99%{perl_vendorlib}/Test/More.pm
100%{perl_vendorlib}/Test/Simple.pm
101%{perl_vendorlib}/Test/Tester.pm
102%{perl_vendorlib}/Test/Tester/
103%doc %{perl_vendorlib}/Test/Tutorial.pod
104%{perl_vendorlib}/Test/use/
105%{perl_vendorlib}/Test2.pm
106%{perl_vendorlib}/Test2/
107%exclude %{_mandir}/man3/*
108
109%changelog
110* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.302164-2
111- initial build for Vine Linux.
112
113* Sun Apr 28 2019 Paul Howarth <paul@city-fan.org> - 2:1.302164-1
114- Update to 1.302164
115  - Do not use threads::shared in Test::Tester::Capture (GH#826)
116  - Add missing version info to Info/Table
117  - Fix event in global destruction bug (GH#827)
118  - Proper fix for todo = '' (GH#812, GH#829)
119- Modernize spec using %%{make_build} and %%{make_install}
120- Drop obsoletes/provides for perl-Test2 dating back to Fedora 25
121
122* Wed Feb  6 2019 Paul Howarth <paul@city-fan.org> - 2:1.302162-1
123- Update to 1.302162
124  - Remove SHM Optimization
125  - Typo fixes in documentation
126
127* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.302160-2
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
129
130* Sat Jan 19 2019 Paul Howarth <paul@city-fan.org> - 2:1.302160-1
131- Update to 1.302160
132  - Fix minor typos and missing doc sections
133  - Add table support in info facet and TAP formatter
134  - Fix TAP test on Windows
135  - Fix math errors in table indentation
136  - Devel requires Term::Table
137  - Add table support to ctx->fail and ctx->fail_and_return
138  - Fix Instance.t on haiku-os
139
140* Tue Jan  8 2019 Paul Howarth <paul@city-fan.org> - 2:1.302156-1
141- Update to 1.302156
142  - Fix Windows fork+test failure (GH#814)
143  - Documentation updates (GH#819)
144  - Fix verbose TAP newline regression (GH#810)
145  - Fix local $TODO bugs (GH#812, GH#817)
146  - Fix shm read warning (GH#815)
147  - Merge doc fix PR's from magnolia-k
148  - Fix failure to check error code on shmwrite (GH#815)
149  - Fix localization error in new test (GH#820)
150  - Fix SHM test to work on machines without SHM
151  - Fix locale errors in Instance.t
152  - Windows test fixes
153  - Perl 5.6 test fixes
154  - Add trace to SHM error when possible
155  - Fix test not to fail in non-english locales
156
157* Sun Dec  2 2018 Paul Howarth <paul@city-fan.org> - 2:1.302141-1
158- Update to 1.302141
159  - Fix bug where IPC init failed in preload+fork environments
160
161* Tue Aug 14 2018 Paul Howarth <paul@city-fan.org> - 2:1.302140-1
162- Update to 1.302140
163  - Mask warning from the recent IPC fix generated when threaded Test tools are
164    loaded at run-time
165
166* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.302138-2
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
168
169* Thu Jul 12 2018 Paul Howarth <paul@city-fan.org> - 2:1.302138-1
170- Update to 1.302138
171  - Make it safe to fork before events in IPC
172
173* Sat Jun 30 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2:1.302136-3
174- Perl 5.28 re-rebuild of bootstrapped packages
175
176* Tue Jun 26 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2:1.302136-2
177- Perl 5.28 rebuild
178
179* Thu Apr 19 2018 Paul Howarth <paul@city-fan.org> - 1:1.302136-1
180- Update to 1.302136
181  - Add test2_add_callback_testing_done to Test2::API
182
183* Fri Mar 30 2018 Paul Howarth <paul@city-fan.org> - 1:1.302135-1
184- Update to 1.302135
185  - Make sure all hubs, events, and contexts get a unique (per run) id
186  - Use a common generator for unique(enough) id's (not UUIDs)
187
188* Mon Mar 12 2018 Paul Howarth <paul@city-fan.org> - 1:1.302133-1
189- Update to 1.302133
190  - Make sure event puts the uuid into the about facet
191  - Add method to validate facet data
192  - Add Test2::Event::V2 event class, and context helpers
193  - Improve how events handle facets
194  - Break out meta_facet_data
195  - Document and fix Facets2Legacy
196  - Fix nested and in_subtest to look at hub facets
197  - Fix event->related and trace with uuid
198
199* Thu Mar  8 2018 Paul Howarth <paul@city-fan.org> - 1:1.302130-1
200- Update to 1.302130
201  - Make hubs tag events with a new facet
202
203* Tue Mar 06 2018 Petr Pisar <ppisar@redhat.com> - 1:1.302128-1
204- Update to 1.302128
205  - Add optional UUID tagging
206
207* Thu Feb 22 2018 Paul Howarth <paul@city-fan.org> - 1:1.302125-1
208- Update to 1.302125
209  - Make it possible to disable IPC
210  - Fix a test to skip without threads
211
212* Tue Feb  6 2018 Paul Howarth <paul@city-fan.org> - 1:1.302122-1
213- Update to 1.302122
214  - Add 'mode' to render facet
215
216* Mon Feb  5 2018 Paul Howarth <paul@city-fan.org> - 1:1.302121-1
217- Update to 1.302121
218  - Update Copyright
219  - Add 'render' facet
220
221* Thu Nov 30 2017 Paul Howarth <paul@city-fan.org> - 1:1.302120-1
222- Update to 1.302120
223  - Fix IPC reload bug
224
225* Wed Nov 29 2017 Paul Howarth <paul@city-fan.org> - 1:1.302118-1
226- Update to 1.302118
227  - Added pre-subtest hook to Test2::API (GH#801)
228  - ipc_wait now reports exit and signal values
229  - Add better interface for ipc_wait
230  - Fix event Out of Order bug
231  - Add driver_abort() hook for IPC Drivers
232
233* Tue Nov 21 2017 Paul Howarth <paul@city-fan.org> - 1:1.302113-1
234- Update to 1.302113
235  - Fix test on threaded 5.8
236  - Fix SIGPIPE in IPC test
237  - Mark t/Test2/regression/gh_16.t as usually AUTHOR_TESTING only
238
239* Mon Nov 20 2017 Paul Howarth <paul@city-fan.org> - 1:1.302111-1
240- Update to 1.302111
241  - Fix some fragile tests
242  - Apply p5p test patch from Craig A. Berry
243  - Allow regexp in Test::Tester
244
245* Mon Oct 23 2017 Paul Howarth <paul@city-fan.org> - 1:1.302106-1
246- Update to 1.302106
247  - Combine multiple diags into one event
248  - Make version number in HashBase sane
249
250* Mon Oct 16 2017 Paul Howarth <paul@city-fan.org> - 1:1.302103-1
251- Update to 1.302103
252  - Fix some TODO edge cases that were not previously accounted for
253
254* Fri Oct 13 2017 Paul Howarth <paul@city-fan.org> - 1:1.302101-1
255- Update to 1.302101
256  - Bump Test::Builder::IO::Scalar version for core
257
258* Wed Oct 11 2017 Paul Howarth <paul@city-fan.org> - 1:1.302100-1
259- Update to 1.302100
260  - Fix run_subtest inherit_trace option
261
262* Tue Oct  3 2017 Paul Howarth <paul@city-fan.org> - 1:1.302098-1
263- Update to 1.302098
264  - Add docs for test2_stdout and test2_stderr
265  - Fix 5.6 support
266
267* Tue Oct 3 2017 Paul Howarth <paul@city-fan.org> - 1:1.302097-1
268- Update to 1.302097
269  - Fix hub->process bug that could let an error pass
270  - Fix modification of read only value (#789)
271  - Fix typo in Test::Builder when looking for IPC (#777)
272  - Fix clone_io broke on scalar io layer (#791)
273  - Fix Exception event stringify exception (#756, #790)
274  - Localize $^E in context (#780)
275  - Fix test that failed in verbose mode (#770)
276
277* Mon Sep 11 2017 Paul Howarth <paul@city-fan.org> - 1:1.302096-1
278- Update to 1.302096
279  - Introduce 'Facets' for events
280  - Performance enhancements
281  - Upgrade inline HashBase
282  - Move Test2::Util::Trace to Test2::EventFacet::Trace
283  - Track hub id in Trace
284  - Remove Info event
285  - Add Pass and Fail events
286  - Remove Event JSON interface
287  - Fix tests on perl 5.25+ with newer Data::Dumper
288  - Fix plan in buffered subtest so that the facts say it is buffered
289  - Fix test that unintentionally required Test2::Suite
290  - Add 'new_root' constructor for formatters
291  - Add intercept_deep() to the API
292  - Fix bug in Version event
293  - Add 'number' attribute to assertion facet
294  - Fix bug in Facets for TodoDiag
295  - Add API command to reset after a fork
296  - Add 'important' flag to info event facet
297  - Make sure Test::Builder does not initialize Test2 too soon
298  - Fix Test::Builder in a preload scenario
299  - Make several tests work with preload
300  - Fix to work with subref-in-stash optimization
301
302* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.302086-2
303- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
304
305* Wed Jun 21 2017 Paul Howarth <paul@city-fan.org> - 1:1.302086-1
306- Update to 1.302086
307  - Make it possible to turn off result logging in Test::Builder
308
309* Sat Jun 03 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.302085-2
310- Perl 5.26 rebuild
311
312* Tue May  2 2017 Paul Howarth <paul@city-fan.org> - 1.302085-1
313- Update to 1.302085
314  - Better IO management
315  - Allow access to the STDERR/STDOUT Test2::API uses
316  - Formatters should use the Test2::API handles
317
318* Sat Apr 15 2017 Paul Howarth <paul@city-fan.org> - 1.302083-1
319- Update to 1.302083
320  - Fixes for '. in @INC' changes (#768)
321  - Timeout when waiting for child procs and threads (#765)
322  - Fix SIGSYS localization issue (#758)
323  - Fix outdated docs (#759, #754)
324  - Fix bail-out in buffered subtest (#747)
325  - Fix threads timeout for older perls (as best we can)
326  - Fix test that incorrectly called private function as method
327  - Update some breakage info for Test::More::Prefix and
328    Test::DBIx::Class::Schema
329
330* Thu Mar  2 2017 Paul Howarth <paul@city-fan.org> - 1.302078-1
331- Update to 1.302078
332  - Fix crash when TB->reset used inside subtest
333  - Fix #762, newlines for todo subtest
334  - Revisit #637, fix rare race condition it created
335
336* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.302075-2
337- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
338
339* Wed Jan 11 2017 Paul Howarth <paul@city-fan.org> - 1.302075-1
340- Update to 1.302075
341  - Add 'cid' to trace
342  - Add signatures to trace
343  - Add related() to events
344  - Now it is possible to check if events are related
345  - Add 'no_fork' option to run_subtest()
346
347* Mon Dec 19 2016 Paul Howarth <paul@city-fan.org> - 1.302073-1
348- Update to 1.302073
349  - Add TO_JSON and from_json methods to Test2::Event and Test2::Trace::Util to
350    facilitate transferring event data between processes (#741)
351  - Generate HashBase from Object::HashBase, which has been split out
352  - When a subtest is marked as todo, all of its contained Ok and Subtest
353    events are now updated so that they return true for $e->effective_pass
354    (#742)
355  - Added two new event classes, Test2::Event::Encoding and
356    Test2::Event::TAP::Version; these are primarily being added for the benefit
357    of Test2::Harness now, but they could be useful for other Test2 event
358    consumer tools in the future (#743)
359  - Expose tools.pl as Test2::Tools::Tiny
360
361* Thu Nov 24 2016 Paul Howarth <paul@city-fan.org> - 1.302067-1
362- Update to 1.302067
363  - Fix double release when 'throw' is used in context_do()
364  - Repo management improvements
365  - Better handling of info vs. diag in ->send_event
366  - Fix test that used 'parent'
367  - Better handling of non-bumping failures (#728)
368  - Set the TEST_ACTIVE env var to true
369  - Set the TEST2_ACTIVE env var to true
370  - Fix cmp_ok output in some confusing cases (#6)
371  - Update travis config
372  - Add missing author deps
373  - Fix handling of negative pids on Windows
374  - Add can() to Test::Tester::Delegate (despite deprecation)
375  - Fix some minor test issues
376  - Handle cases where SysV IPC can be available but not enabled
377  - Import 'context' into Test2::IPC; it is used by 'cull'
378  - Propagate warnings settings to use_ok (#736)
379  - Fix context test for recent blead
380
381* Thu Oct 20 2016 Paul Howarth <paul@city-fan.org> - 1.302062-1
382- Update to 1.302062
383  - Formatters now have terminate() and finalize() methods; these are called
384    when there is a skip_all or bail event (terminate), or when a test suite is
385    exiting normally (finalize), which allows formatters to finalize their
386    output - this is important for any sort of document-oriented format (as
387    opposed to a stream format like TAP) (#723)
388  - Removed a warning when using a non-TAP formatter with Test::Builder about
389    the formatter not supporting "no_header" and "no_diag"; this happened even
390    if the alternative formatter class implemented these attributes
391
392* Mon Sep 26 2016 Paul Howarth <paul@city-fan.org> - 1.302059-1
393- Update to 1.302059
394  - Documentation fixes
395  - Win32 color support in Test::Builder::Tester
396  - Support v-strings in is_deeply
397  - A streamed subtest run inside a buffered subtest will automatically be
398    converted to a buffered subtest; otherwise, the output from inside the
399    subtest is lost entirely (#721)
400  - Mask warning when comparing $@ in Test2::API::Context
401- Drop obsoletes/provides for perl-Test-Tester and perl-Test-use-ok, which
402  were integrated into this package in Fedora 22
403
404* Tue Sep 13 2016 Paul Howarth <paul@city-fan.org> - 1.302056-1
405- Update to 1.302056
406  - Fix skip_all in require in intercept (#696)
407  - Documentation of what is better in Test2 (#663)
408  - Document Test::Builder::Tester plan limitations
409  - Document limitations in is_deeply (#595)
410  - Better documentation of done_testing purpose (#151)
411  - Make ctx->send_event detect termination events (#707)
412  - Allow '#' and '\n' in ok names
413  - Fix special case of ok line ending in backslash
414  - Improve a test that captures STDERR/STDOUT
415
416* Sun Aug 14 2016 Paul Howarth <paul@city-fan.org> - 1.302052-1
417- Update to 1.302052
418  - Add contact info to main doc and readme
419  - Fix setting hub when getting context
420
421* Fri Jul 29 2016 Paul Howarth <paul@city-fan.org> - 1.302049-1
422- Update to 1.302049
423  - Add 'active' attribute to hub
424
425* Sat Jul 23 2016 Paul Howarth <paul@city-fan.org> - 1.302047-1
426- Update to 1.302047
427  - Restore traditional note/diag return values (#694)
428
429* Tue Jul 19 2016 Paul Howarth <paul@city-fan.org> - 1.302045-1
430- Update to 1.302045
431  - Work around IPC bug on windows
432  - Fix IPC event ordering bug
433  - Fix TODO in mixed T2/TB subtests
434  - Fix test that segv'd on older perls
435
436* Sun Jul 10 2016 Paul Howarth <paul@city-fan.org> - 1.302040-1
437- Update to 1.302040
438  - Fix broken MANIFEST.SKIP entries (#689)
439  - Add Info event for better diagnostics
440
441* Mon Jul  4 2016 Paul Howarth <paul@city-fan.org> - 1.302037-1
442- Update to 1.302037
443  - Restore PerlIO layer cloning on STDERR and STDOUT
444- Bump obsoletes/provides versions for perl-Test2 to maintain upgrade path from
445  packages in third-party repositories
446
447* Tue Jun 28 2016 Paul Howarth <paul@city-fan.org> - 1.302035-1
448- Update to 1.302035
449  - Fix some breakage info
450  - POD fixes
451
452* Fri Jun 24 2016 Paul Howarth <paul@city-fan.org> - 1.302033-1
453- Update to 1.302033
454  - Fix nested TODO handling of diags (#684)
455
456* Wed Jun 22 2016 Paul Howarth <paul@city-fan.org> - 1.302031-1
457- Update to 1.302031
458  - Remove Carp from dependency list (#682)
459
460* Sun Jun 19 2016 Paul Howarth <paul@city-fan.org> - 1.302030-1
461- Update to 1.302030
462  - Use pre_filter instead of filter for TODO in Test::Builder (fix #683)
463  - Fix typos in transitions doc (#681)
464  - Add 'inherit_trace' param to run_subtest
465  - Properly skip thread test when threads are broken
466
467* Tue Jun 14 2016 Paul Howarth <paul@city-fan.org> - 1.302026-1
468- Update to 1.302026
469  - Do not fail if Test2::API::Breakage cannot load (rare 5.10.0 issue)
470  - Potential fix for t/Legacy/Regression/637.t
471  - Make t/Legacy/Regression/637.t AUTHOR_TESTING for now
472  - Add Generic event type
473  - Make sure enabling culling/shm sets pid and tid (fix #679)
474
475* Sun May 29 2016 Paul Howarth <paul@city-fan.org> - 1.302022-1
476- Update to 1.302022
477  - Many micro-optimizations
478  - Spelling fixes and tests
479  - Fix leaky File.t file so that tmp doesn't fill up
480  - Move some modules out of the known broken list in xt tests
481  - Add Test2-based tools to downstream testing
482  - Change when PID/TID are stashed (for forkprove)
483  - VMS fixes for Files.t and IPC system
484  - Improve thread checks to better detect broken 5.10 builds
485  - Use thread checks to skip/run t/Legacy/Regression/637.t
486
487* Mon May 23 2016 Petr Pisar <ppisar@redhat.com> - 1.302019-2
488- Obsolete perl-Test2-0.000044-2 too
489
490* Thu May 19 2016 Paul Howarth <paul@city-fan.org> - 1.302019-1
491- Update to 1.302019
492  - Block signals in critical IPC section (fix #661 and #668)
493  - Merge Examples and examples into one dir (#660)
494  - Documentation and typo fixes
495  - Make Test2::Util::get_tid have a consistent prototype (#665)
496  - Make TB->no_plan a no-op if a plan is set
497  - Fix util.t win32 bug
498  - Handle Test::Builder::Exception properly
499  - Silence noisy STDERR in test suite
500  - POD spelling fixes
501- BR: perl-generators
502
503* Wed May 18 2016 Paul Howarth <paul@city-fan.org> - 1.302015-1
504- Update to 1.302015
505  - Major refactoring of existing API on top of (included) Test2
506- Obsolete/Provide perl-Test2
507
508* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.001014-365
509- Increase release to favour standalone package
510
511* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.001014-347
512- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
513
514* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.001014-346
515- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
516
517* Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.001014-345
518- Increase release to favour standalone package
519
520* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.001014-3
521- Perl 5.22 rebuild
522
523* Wed Mar 04 2015 Petr Šabata <contyk@redhat.com> - 1.001014-2
524- Correct the license tag
525
526* Wed Jan  7 2015 Paul Howarth <paul@city-fan.org> - 1.001014-1
527- Update to 1.001014
528  - Fix a unit test that broke on some platforms with spaces in the $^X path
529  - Add a test to ensure that the Changes file is updated
530
531* Wed Dec 24 2014 Paul Howarth <paul@city-fan.org> - 1.001012-1
532- Update to 1.001012
533  - Move test that was dropped in the wrong directory
534
535* Tue Dec 23 2014 Paul Howarth <paul@city-fan.org> - 1.001011-1
536- Update to 1.001011
537  - Fix windows test bug (GH#491)
538  - Integrate Test::Tester and Test::use::ok for easier downgrade from trial
539  - Remove POD Coverage test
540- Obsolete/Provide perl-Test-Tester and perl-Test-use-ok
541- Classify buildreqs by usage
542- Use features from recent ExtUtils::MakeMaker to simplify spec
543- Run tests with AUTHOR_TESTING=1 so we do the threads test too
544
545* Tue Nov  4 2014 Paul Howarth <paul@city-fan.org> - 1.001009-1
546- Update to 1.001009
547  - Backport cmp_ok fix from alphas (GH#478)
548
549* Thu Oct 16 2014 Paul Howarth <paul@city-fan.org> - 1.001008-1
550- Update to 1.001008
551  - Fix subtest name when skip_all is used
552
553* Tue Sep  9 2014 Paul Howarth <paul@city-fan.org> - 1.001006-1
554- Update to 1.001006
555  - Documentation updates
556  - Subtests accept args
557  - Outdent subtest diag
558  - Changed install path for perl 5.12 or higher
559
560* Tue Aug 26 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.001003-3
561- Perl 5.20 rebuild
562
563* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.001003-2
564- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
565
566* Sat Mar 22 2014 Paul Howarth <paul@city-fan.org> - 1.001003-1
567- Update to 1.001003
568  - Documentation updates for maintainer change
569- This release by EXODIST -> update source URL
570- Drop obsoletes/provides for old tests sub-package
571
572* Tue Nov  5 2013 Paul Howarth <paul@city-fan.org> - 1.001002-1
573- Update to 1.001002
574  - Restore ability to use regex with test_err and test_out (CPAN RT#89655)
575- Drop upstreamed regex patch
576
577* Sat Oct 12 2013 Paul Howarth <paul@city-fan.org> - 0.99-1
578- 0.99 bump
579- This release by RJBS -> update source URL
580
581* Fri Aug 09 2013 Petr Pisar <ppisar@redhat.com> - 0.98.05-3
582- Pass regular expression intact
583
584* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98.05-2
585- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
586
587* Mon Jul 15 2013 Petr Pisar <ppisar@redhat.com> - 0.98.05-1
588- 0.98_05 bump
589
590* Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 0.98-244
591- Perl 5.18 rebuild
592
593* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-243
594- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
595
596* Wed Nov 21 2012 Jitka Plesnikova <jplesnik@redhat.com> - 0.98-242
597- Update dependencies and comments
598
599* Thu Aug 23 2012 Paul Howarth <paul@city-fan.org> - 0.98-241
600- Merge tests sub-package back into main package
601- Don't need to remove empty directories from the buildroot
602- Drop %%defattr, redundant since rpm 4.4
603- Make %%files list more explicit
604- Don't use macros for commands
605- Mark Tutorial.pod as %%doc
606- Drop explicit dependency on perl-devel
607
608* Mon Aug 13 2012 Marcela Mašláňová <mmaslano@redhat.com> - 0.98-240
609- Bump release to override sub-package from perl.spec
610
611* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
612- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
613
614* Wed Jun 06 2012 Petr Pisar <ppisar@redhat.com> - 0.98-6
615- Perl 5.16 rebuild
616
617* Thu May 31 2012 Petr Pisar <ppisar@redhat.com> - 0.98-5
618- Specify all dependencies
619
620* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-4
621- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
622
623* Tue Aug 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.98-3
624- Change path on vendor, so our debuginfo are not conflicting with
625  perl core debuginfos
626
627* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.98-2
628- Perl mass rebuild
629
630* Thu Feb 24 2011 Iain Arnell <iarnell@gmail.com> - 0.98-1
631- Update to latest upstream version
632
633* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.96-2
634- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
635
636* Sat Nov 20 2010 Iain Arnell <iarnell@gmail.com> - 0.96-1
637- Update to latest upstream version
638- Clean up spec for modern rpmbuild
639
640* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.94-2
641- Mass rebuild with perl-5.12.0
642
643* Tue Mar 16 2010 Chris Weyl <cweyl@alumni.drew.edu> - 0.94-1
644- Specfile by Fedora::App::MaintainerTools 0.006
Note: See TracBrowser for help on using the repository browser.