source: projects/specs/trunk/p/perl-Test-Refcount/perl-Test-Refcount-vl.spec @ 8675

Revision 8675, 2.8 KB checked in by iwaim, 10 years ago (diff)

perl-Test-Refcount 0.07-2

Line 
1Name:           perl-Test-Refcount
2Version:        0.07
3Release:        2%{?_dist_release}
4Summary:        Assert reference counts on objects
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Test-Refcount/
9Source0:        http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Refcount-%{version}.tar.gz
10
11BuildArch:      noarch
12BuildRequires:  perl(ExtUtils::MakeMaker)
13BuildRequires:  perl(Devel::Refcount)
14BuildRequires:  perl(Devel::FindRef)
15BuildRequires:  perl(Test::Builder)
16BuildRequires:  perl(Test::Builder::Tester)
17BuildRequires:  perl(Test::More)
18BuildRequires:  perl(Test::Pod)
19Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21%description
22The Perl garbage collector uses simple reference counting during the normal
23execution of a program. This means that cycles or unweakened references in
24other parts of code can keep an object around for longer than intended. To
25help avoid this problem, the reference count of a new object from its class
26constructor ought to be 1. This way, the caller can know the object will be
27properly DESTROYed when it drops all of its references to it.
28
29
30%prep
31%setup -q -n Test-Refcount-%{version}
32
33
34%build
35%{__perl} Makefile.PL INSTALLDIRS=vendor
36make %{?_smp_mflags}
37
38
39%install
40rm -rf %{buildroot}
41make pure_install PERL_INSTALL_ROOT=%{buildroot}
42find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
43
44%{_fixperms} %{buildroot}/*
45
46
47%check
48make test
49
50%clean
51rm -rf %{buildroot}
52
53%files
54%doc Changes LICENSE README
55%{perl_vendorlib}/Test
56%{_mandir}/man3/Test*.3*
57
58
59%changelog
60* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.07-2
61- build with Perl 5.16
62
63* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.07-1
64- initial build for Vine Linux
65
66* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.07-1
67- update to 0.07
68
69* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
70- Perl mass rebuild
71
72* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
73- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
74
75* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-3
76- 661697 rebuild for fixing problems with vendorach/lib
77
78* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-2
79- Mass rebuild with perl-5.12.0
80
81* Sun Dec 27 2009 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.06-1
82- Update to 0.06
83- Remove workaround at make test for perl with debug - rhbz#514942
84
85* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 0.05-3
86- rebuild against perl 5.10.1
87
88* Fri Jul 31 2009 kwizart < kwizart at gmail.com > - 0.05-2
89- Add missing BR
90- Use %%{_fixperms}
91- Fix %%files section
92- Add comment about why it fails
93
94* Thu Jul  9 2009 kwizart < kwizart at gmail.com > - 0.05-1
95- Initial spec
96
Note: See TracBrowser for help on using the repository browser.