source: projects/specs/trunk/p/perl-Test-Refcount/perl-Test-Refcount-vl.spec @ 12120

Revision 12120, 3.0 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Test-Refcount
2Version:        0.08
3Release:        1%{?_dist_release}
4Summary:        Assert reference counts on objects
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Test-Refcount/
9Source0:        http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Refcount-%{version}.tar.gz
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14BuildArch:      noarch
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(Devel::Refcount)
17BuildRequires:  perl(Devel::FindRef)
18BuildRequires:  perl(Test::Builder)
19BuildRequires:  perl(Test::Builder::Tester)
20BuildRequires:  perl(Test::More)
21BuildRequires:  perl(Test::Pod)
22Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24%description
25The Perl garbage collector uses simple reference counting during the normal
26execution of a program. This means that cycles or unweakened references in
27other parts of code can keep an object around for longer than intended. To
28help avoid this problem, the reference count of a new object from its class
29constructor ought to be 1. This way, the caller can know the object will be
30properly DESTROYed when it drops all of its references to it.
31
32
33%prep
34%setup -q -n Test-Refcount-%{version}
35
36
37%build
38%{__perl} Makefile.PL INSTALLDIRS=vendor
39make %{?_smp_mflags}
40
41
42%install
43rm -rf %{buildroot}
44make pure_install PERL_INSTALL_ROOT=%{buildroot}
45find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
46
47%{_fixperms} %{buildroot}/*
48
49
50%check
51make test
52
53%clean
54rm -rf %{buildroot}
55
56%files
57%license LICENSE
58%doc Changes README
59%{perl_vendorlib}/Test
60%{_mandir}/man3/Test*.3*
61
62
63%changelog
64* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.08-1
65- updated to 0.07.
66- rebuilt with perl-5.26.
67
68* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.07-2
69- build with Perl 5.16
70
71* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.07-1
72- initial build for Vine Linux
73
74* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.07-1
75- update to 0.07
76
77* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
78- Perl mass rebuild
79
80* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
82
83* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-3
84- 661697 rebuild for fixing problems with vendorach/lib
85
86* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-2
87- Mass rebuild with perl-5.12.0
88
89* Sun Dec 27 2009 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.06-1
90- Update to 0.06
91- Remove workaround at make test for perl with debug - rhbz#514942
92
93* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 0.05-3
94- rebuild against perl 5.10.1
95
96* Fri Jul 31 2009 kwizart < kwizart at gmail.com > - 0.05-2
97- Add missing BR
98- Use %%{_fixperms}
99- Fix %%files section
100- Add comment about why it fails
101
102* Thu Jul  9 2009 kwizart < kwizart at gmail.com > - 0.05-1
103- Initial spec
104
Note: See TracBrowser for help on using the repository browser.