source: projects/specs/trunk/p/perl-Test-Perl-Critic/perl-Test-Perl-Critic-vl.spec @ 5798

Revision 5798, 5.0 KB checked in by shaolin, 12 years ago (diff)
  • rebuild
Line 
1%define pkgname Test-Perl-Critic
2
3Name:           perl-%{pkgname}
4Summary:        Use Perl::Critic in test programs
5Version:        1.02
6Release:        2%{?_dist_release}
7License:        Artistic or GPL+
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/T/TH/THALJEF/Test-Perl-Critic-%{version}.tar.gz
10URL:            http://search.cpan.org/dist/Test-Perl-Critic/
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
13BuildArch:      noarch
14
15BuildRequires:  perl(Carp)
16BuildRequires:  perl(English)
17BuildRequires:  perl(ExtUtils::MakeMaker)
18BuildRequires:  perl(Module::Build) >= 0.35
19BuildRequires:  perl(Perl::Critic) >= 1.105
20BuildRequires:  perl(Perl::Critic::Utils) >= 1.105
21BuildRequires:  perl(Perl::Critic::Violation) >= 1.105
22BuildRequires:  perl(Test::Builder)
23BuildRequires:  perl(Test::More)
24
25Requires:       perl(Carp)
26Requires:       perl(English)
27Requires:       perl(Perl::Critic) >= 1.105
28Requires:       perl(Perl::Critic::Utils) >= 1.105
29Requires:       perl(Perl::Critic::Violation) >= 1.105
30Requires:       perl(Test::Builder)
31
32Vendor:         Project Vine
33Distribution:   Vine Linux
34Packager:       shaolin
35
36
37%{?perl_default_filter}
38%{?perl_default_subpackage_tests}
39
40%description
41Test::Perl::Critic wraps the Perl::Critic engine in a convenient
42subroutine suitable for test programs written using the Test::More
43framework. This makes it easy to integrate coding-standards enforcement
44into the build process. For ultimate convenience (at the expense of some
45flexibility), see the criticism pragma.
46
47
48%prep
49%setup -q -n Test-Perl-Critic-%{version}
50
51
52%build
53%{__perl} Build.PL installdirs=vendor
54./Build
55
56
57%install
58rm -rf ${RPM_BUILD_ROOT}
59./Build install destdir=${RPM_BUILD_ROOT} create_packlist=0
60%{_fixperms} ${RPM_BUILD_ROOT}/*
61
62
63%check
64# Tests are failing with odd unpack errors.
65# TEST_AUTHOR=1 ./Build test
66./Build test
67
68
69%clean
70rm -rf ${RPM_BUILD_ROOT}
71
72
73%files
74%defattr(-,root,root,-)
75%doc Changes LICENSE README
76%{perl_vendorlib}/Test/
77%{_mandir}/man3/*.3pm*
78
79
80%changelog
81* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.02-2
82- rebuild
83
84* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.02-1
85- initial package for Vine Linux
86
87* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.02-6
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
89
90* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1.02-5
91- Perl mass rebuild
92
93* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.02-4
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
95
96* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.02-3
97- 661697 rebuild for fixing problems with vendorach/lib
98
99* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.02-2
100- Mass rebuild with perl-5.12.0
101
102* Sun Mar 14 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.02-1
103- update by Fedora::App::MaintainerTools 0.006
104- updating to latest GA CPAN version (1.02)
105- added a new br on perl(Carp) (version 0)
106- added a new br on perl(English) (version 0)
107- altered br on perl(Module::Build) (0 => 0.35)
108- altered br on perl(Perl::Critic) (0.21 => 1.105)
109- added a new br on perl(Perl::Critic::Utils) (version 1.105)
110- added a new br on perl(Perl::Critic::Violation) (version 1.105)
111- added a new br on perl(Test::Builder) (version 0)
112- added a new br on perl(Test::More) (version 0)
113- force-adding ExtUtils::MakeMaker as a BR
114- dropped old BR on perl(Test::Pod)
115- dropped old BR on perl(Test::Pod::Coverage)
116- added a new req on perl(Carp) (version 0)
117- added a new req on perl(English) (version 0)
118- added a new req on perl(Perl::Critic) (version 1.105)
119- added a new req on perl(Perl::Critic::Utils) (version 1.105)
120- added a new req on perl(Perl::Critic::Violation) (version 1.105)
121- added a new req on perl(Test::Builder) (version 0)
122
123* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 1.01-8
124- rebuild against perl 5.10.1
125
126* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.01-7
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
128
129* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.01-6
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
131
132* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.01-5
133- Rebuild for perl 5.10 (again)
134
135* Tue Jan 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.01-4
136- disable tests, take out patch, doesn't fix test failures
137
138* Tue Jan 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.01-3
139- patch for test failure
140
141* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.01-2
142- rebuild for new perl
143
144* Sat Jan 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-1
145- Update to 1.01.
146
147* Sun Nov 12 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.08-1
148- Update to 0.08.
149
150* Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.07-1
151- First build.
Note: See TracBrowser for help on using the repository browser.