source: projects/specs/trunk/p/perl-Test-MockObject/perl-Test-MockObject-vl.spec @ 5798

Revision 5798, 4.5 KB checked in by shaolin, 12 years ago (diff)
  • rebuild
Line 
1%define pkgname Test-MockObject
2
3Name:           perl-%{pkgname}
4Version:        1.09
5Release:        2%{?_dist_release}
6Summary:        Perl extension for emulating troublesome interfaces
7
8Group:          Development/Libraries
9License:        Artistic or GPL+
10URL:            http://search.cpan.org/dist/Test-MockObject/
11Source0:        http://www.cpan.org/authors/id/C/CH/CHROMATIC/Test-MockObject-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildArch:      noarch
15BuildRequires:  perl(CGI)
16BuildRequires:  perl(Module::Build)
17BuildRequires:  perl(Test::Exception)
18BuildRequires:  perl(Test::Pod), perl(Test::Pod::Coverage)
19BuildRequires:  perl(UNIVERSAL::can) >= 1.11
20BuildRequires:  perl(UNIVERSAL::isa) >= 0.06
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       shaolin
26
27%description
28Test::MockObject is a highly polymorphic testing object, capable of
29looking like all sorts of objects.  This makes white-box testing much
30easier, as you can concentrate on what the code being tested sends to
31and receives from the mocked object, instead of worrying about faking
32up your own data.  (Another option is not to test difficult things.
33Now you have no excuse.)
34
35
36%prep
37%setup -q -n Test-MockObject-%{version}
38
39
40%build
41%{__perl} Build.PL installdirs=vendor
42./Build
43
44
45%install
46rm -rf %{buildroot}
47./Build install destdir=%{buildroot} create_packlist=0
48find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
49%{_fixperms} %{buildroot}/*
50
51
52%check
53PERL_RUN_ALL_TESTS=1 ./Build test
54
55
56%clean
57rm -rf %{buildroot}
58
59
60%files
61%defattr(-,root,root,-)
62%doc Changes README
63%{perl_vendorlib}/Test/*.pm
64%dir %{perl_vendorlib}/Test/MockObject
65%{perl_vendorlib}/Test/MockObject/*.pm
66%{_mandir}/man3/*.3pm*
67
68
69%changelog
70* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.09-2
71- rebuild
72
73* Mon Feb 20 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.09-1
74- initial package for Vine Linux
75
76* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.09-9
77- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
78
79* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.09-8
80- 661697 rebuild for fixing problems with vendorach/lib
81
82* Thu Dec 09 2010 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.09-7
83- Add BR: perl(CGI) (Fix FTBFS: BZ 660972).
84
85* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.09-6
86- Mass rebuild with perl-5.12.0
87
88* Thu Feb  4 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.09-5
89- 552253 merge review
90
91* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 1.09-4
92- rebuild against perl 5.10.1
93
94* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.09-3
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
96
97* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.09-2
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
99
100* Thu Nov 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.09-1
101- update to 1.09
102
103* Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.08-2
104- rebuild for new perl
105
106* Fri Jun 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
107- Update to 1.08.
108
109* Thu Oct  5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.07-1
110- Update to 1.07.
111
112* Fri Apr 21 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
113- Update to 1.06.
114
115* Tue Apr 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
116- Update to 1.05.
117
118* Thu Mar 30 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
119- Update to 1.04.
120- Makefile.PL -> Build.PL.
121
122* Mon Mar 13 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
123- Update to 1.03.
124
125* Tue Feb 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
126- Update to 1.02.
127
128* Fri Jul 15 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.00-1
129- Update to 1.00.
130
131* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0:0.15-3
132- rebuilt
133
134* Tue Dec 28 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:0.15-2
135- Build requires Test::Simple >= 0.44 (bug 2324).
136
137* Wed Dec 01 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:0.15-0.fdr.1
138- Update to 0.15.
139
140* Tue May 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:0.14-0.fdr.1
141- Update to 0.14.
142- Require perl >= 1:5.6.1 for vendor install dir support.
143- Use pure_install to avoid perllocal.pod workarounds.
144- Moved make test to section %%check.
145
146* Wed Nov 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.12-0.fdr.1
147- First build.
Note: See TracBrowser for help on using the repository browser.