source: projects/specs/trunk/p/perl-Test-Memory-Cycle/perl-Test-Memory-Cycle-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           perl-Test-Memory-Cycle
2Version:        1.04
3Release:        1%{?_dist_release}
4Summary:        Check for memory leaks and circular memory references
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Test-Memory-Cycle/
9Source0:        http://www.cpan.org/authors/id/P/PE/PETDANCE/Test-Memory-Cycle-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12BuildArch:      noarch
13BuildRequires:  perl(Devel::Cycle) >= 1.07
14BuildRequires:  perl(PadWalker)
15BuildRequires:  perl(Test::Builder::Tester)
16BuildRequires:  perl(Test::Simple) >= 0.62
17BuildRequires:  perl(Test::Pod)
18BuildRequires:  perl(Test::Pod::Coverage)
19Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21%description
22Perl's garbage collection has one big problem: Circular references
23can't get cleaned up.  A circular reference can be as simple as two
24objects that refer to each other.
25"Test::Memory::Cycle" is built on top of "Devel::Cycle" to give you an
26easy way to check for these circular references.
27
28
29%prep
30%setup -q -n Test-Memory-Cycle-%{version}
31
32
33%build
34%{__perl} Makefile.PL INSTALLDIRS=vendor
35%{__make} %{?_smp_mflags}
36
37
38%install
39%{__rm} -rf $RPM_BUILD_ROOT
40%{__make} pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
41find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
42find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
43%{__chmod} -R u+w $RPM_BUILD_ROOT/*
44
45
46%check
47%{__make} test
48
49
50%clean
51%{__rm} -rf $RPM_BUILD_ROOT
52
53
54%files
55%defattr(-,root,root,-)
56%doc Changes README
57%{perl_vendorlib}/Test/
58%{_mandir}/man3/*.3pm*
59
60
61%changelog
62* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.04-1
63- initial build for Vine Linux based on fedora development
64
65* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.04-7
66- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
67
68* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.04-6
69- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
70
71* Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.04-5
72- Rebuild normally, second pass
73
74* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.04-4
75- Rebuild for perl 5.10 (again), first pass
76
77* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.04-3
78- rebuild normally, second pass
79
80* Sun Jan 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.04-2
81- rebuild for new perl, disable T-P-C and tests for first pass
82
83* Wed Aug  9 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
84- Update to 1.04.
85
86* Mon Feb 20 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-2
87- Rebuild for FC5 (perl 5.8.8).
88
89* Tue May 24 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
90- Update to 1.02.
91
92* Sat May 14 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.00-4
93- Add dist tag.
94
95* Fri Apr 22 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.00-3
96- Fedora Extras: FC-4 version.
97
98* Fri Apr 22 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.00-2
99- Fedora Extras: FC-3 version.
100
101* Wed Apr 20 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.00-0.fdr.2
102- RedHat 9.0 (8.0 and 7.3): CGI.pm is shipped as perl-CGI (#1824).
103
104* Mon Jan 24 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.00-0.fdr.1
105- Update to 1.00.
106
107* Sun Jul 04 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:0.02-0.fdr.1
108- First build.
Note: See TracBrowser for help on using the repository browser.