source: projects/specs/trunk/p/perl-Test-LeakTrace/perl-Test-LeakTrace-vl.spec @ 8703

Revision 8703, 3.2 KB checked in by tomop, 10 years ago (diff)

updated perl modules.

Line 
1Name:           perl-Test-LeakTrace
2Summary:        Traces memory leaks
3Version:        0.14
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/Test-LeakTrace-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/Test-LeakTrace
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
11
12BuildRequires:  perl(Exporter) >= 5.57
13BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.42
14BuildRequires:  perl(Test::More) >= 0.62
15
16Requires:       perl(Exporter) >= 5.57
17
18%{?perl_default_filter}
19%{?perl_default_subpackage_tests}
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23Packager:       shaolin
24
25%description
26'Test::LeakTrace' provides several functions that trace memory leaks.
27This module scans arenas, the memory allocation system, so it can detect
28any leaked SVs in given blocks.  *Leaked SVs* are SVs which are not
29released after the end of the scope they have been created. These SVs
30include global variables and internal caches. For example, if you call a
31method in a tracing block, perl might prepare a cache for the method.
32Thus, to trace true leaks, 'no_leaks_ok()' and 'leaks_cmp_ok()' executes
33a block more than once.
34
35%prep
36%setup -q -n Test-LeakTrace-%{version}
37
38find . -type f -exec chmod -c -x {} +
39
40%build
41%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
42make %{?_smp_mflags}
43
44%install
45rm -rf %{buildroot}
46
47make pure_install DESTDIR=%{buildroot}
48find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
49find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
50find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
51
52%{_fixperms} %{buildroot}/*
53
54%check
55make test
56
57
58%clean
59rm -rf %{buildroot}
60
61%files
62%defattr(-,root,root,-)
63%doc Changes README
64%{perl_vendorarch}/*
65%exclude %dir %{perl_vendorarch}/auto
66%{_mandir}/man3/*.3*
67
68%changelog
69* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.14-1
70- new upstream release.
71
72* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.13-1
73- initial build for Vine Linux
74
75* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-4
76- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
77
78* Wed Jun 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.13-3
79- Perl mass rebuild
80
81* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-2
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
83
84* Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.13-1
85- update to 0.13
86  - use ">= 0", instead of "== 0" for no_leaks_ok()
87  - add count_sv() to count all the SVs in a perl interpreter
88  - fix tests broken for some perls in 0.12
89
90* Wed Nov 17 2010 Paul Howarth <paul@city-fan.org> - 0.11-1
91- update to 0.11 (#654301)
92  - fix false-positive related to XS code (CPAN RT #58133)
93
94* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.10-2
95- Mass rebuild with perl-5.12.0
96
97* Sun Apr 04 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.10-1
98- specfile by Fedora::App::MaintainerTools 0.006
99
Note: See TracBrowser for help on using the repository browser.