source: projects/specs/trunk/p/perl-Test-File/perl-Test-File-vl.spec @ 12120

Revision 12120, 8.9 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# This module usually ships with version numbers having two digits after the decimal point
2%global cpanversion 1.443
3%global rpmversion 1.44.3
4
5Summary:        Test file attributes through Test::Builder
6Name:           perl-Test-File
7Version:        %{rpmversion}
8Release:        8%{?_dist_release}
9License:        GPL+ or Artistic
10URL:            https://metacpan.org/release/Test-File
11Source0:        https://cpan.metacpan.org/authors/id/B/BD/BDFOY/Test-File-%{cpanversion}.tar.gz
12
13Vendor:        Project Vine
14Distribution:  Vine Linux
15
16BuildArch:      noarch
17# Module Build
18BuildRequires:  coreutils
19BuildRequires:  make
20BuildRequires:  perl >= 2:5.26.2
21BuildRequires:  perl(ExtUtils::MakeMaker)
22BuildRequires:  perl(ExtUtils::Manifest)
23# Module Runtime
24BuildRequires:  perl(base)
25BuildRequires:  perl(Exporter)
26BuildRequires:  perl(File::Spec)
27BuildRequires:  perl(strict)
28BuildRequires:  perl(Test::Builder)
29BuildRequires:  perl(vars)
30BuildRequires:  perl(warnings)
31# Test Suite
32BuildRequires:  perl(Cwd)
33BuildRequires:  perl(File::Spec::Functions)
34BuildRequires:  perl(Test::Builder)
35BuildRequires:  perl(Test::Builder::Tester)
36BuildRequires:  perl(Test::More)
37BuildRequires:  perl(Test::utf8)
38BuildRequires:  perl(utf8)
39# Optional Tests
40BuildRequires:  perl(Test::Pod)
41BuildRequires:  perl(Test::Pod::Coverage)
42# Runtime
43Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
44
45%description
46This module provides a collection of test utilities for file attributes.
47
48Some file attributes depend on the owner of the process testing the file
49in the same way the file test operators do.
50
51%prep
52%setup -q -n Test-File-%{cpanversion}
53
54%build
55perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
56make %{?_smp_mflags}
57
58%install
59make install DESTDIR=%{buildroot}
60%{_fixperms} -c %{buildroot}
61
62%check
63make test
64
65%files
66%license LICENSE
67%doc Changes README.pod
68%{perl_vendorlib}/Test/
69%{_mandir}/man3/Test::File.3*
70
71%changelog
72* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.44.3-8
73- initial build for Vine Linux.
74
75* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.3-7
76- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
77
78* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.3-6
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
80
81* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.44.3-5
82- Perl 5.28 rebuild
83
84* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.3-4
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
86
87* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.3-3
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
89
90* Tue Jun 06 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.44.3-2
91- Perl 5.26 rebuild
92
93* Mon Apr 17 2017 Paul Howarth <paul@city-fan.org> - 1.44.3-1
94- Update to 1.443
95  - Found another relative path require issue:
96    http://blogs.perl.org/users/ryan_voots/2017/04/trials-and-troubles-with-changing-inc.html
97  - This is another attempt at avoiding failures from the v5.26 removal of . from @INC
98- Drop redundant Group: tag
99
100* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.2-2
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
102
103* Fri Oct 14 2016 Paul Howarth <paul@city-fan.org> - 1.44.2-1
104- Update to 1.442
105  - Fix for missing . in @INC; this relates to CVE-2016-1238
106    (https://github.com/briandfoy/test-file/issues/14)
107- Split rpm and upstream versioning
108- Use features from recent EUMM to simplify %%install section
109
110* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.44-3
111- Perl 5.24 rebuild
112
113* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.44-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
115
116* Mon Jul  6 2015 Paul Howarth <paul@city-fan.org> - 1.44-1
117- Update to 1.44
118  - Fix problem with META* specifying requirements (CPAN RT#105210)
119  - Don't install README.pod
120  - check file_mode_has tests for Windows
121  - Fix file_has_* tests to work on Windows (GH#13)
122
123* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.41-3
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
125
126* Fri Jun 12 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.41-2
127- Perl 5.22 rebuild
128
129* Wed Sep 24 2014 Paul Howarth <paul@city-fan.org> - 1.41-1
130- Update to 1.41
131  - Uncomment accidentally commented symlink_target_is_absolute_ok
132  - Add mtime test functions (GH#8)
133  - Allow tests to run in parallel (CPAN RT#89908, CPAN RT#91862)
134  - Fix up tests for UTF-8 checks
135- This release by BDFOY → update source URL
136- Classify buildreqs by usage
137- Use %%license
138
139* Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.36-3
140- Perl 5.20 rebuild
141
142* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.36-2
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
144
145* Thu Jan  2 2014 Paul Howarth <paul@city-fan.org> - 1.36-1
146- Update to 1.36
147  - Fix bad line counts on latest dev version of Perl (CPAN RT#89849)
148
149* Thu Oct 10 2013 Paul Howarth <paul@city-fan.org> - 1.35-1
150- Update to 1.35
151  - Don't distribute MYMETA.* (CPAN RT#89175)
152  - Add dir_exists_ok and dir_contains_ok
153  - Add file_contains_* functions
154- Specify all dependencies
155
156* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.34-4
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
158
159* Sun Jul 21 2013 Petr Pisar <ppisar@redhat.com> - 1.34-3
160- Perl 5.18 rebuild
161
162* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.34-2
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
164
165* Tue Jul 24 2012 Paul Howarth <paul@city-fan.org> - 1.34-1
166- Update to 1.34
167  - Added dir_exists_ok and dir_contains_ok
168  - Added file_contains_like and file_contains_unlike
169  - Fixed a few grammatical errors in POD
170  - Added some SKIP blocks to avoid test failures when running as root
171  - Fixed qr//mx patterns to work with older Perls (CPAN RT#74365)
172  - Fixed incorrect spelling of "privileges" in SKIP blocks (CPAN RT#74483)
173  - Skip testing of symlinks on Windows (CPAN RT#57682)
174  - Fixed automatically generated test name for owner_isnt (CPAN RT#37676)
175  - Fixed problem in MANIFEST file (CPAN RT#37676)
176  - Fixed problem in links.t (CPAN RT#76853)
177- This release by BAREFOOT -> update source URL
178- BR: perl(base), perl(Exporter) and perl(File::Spec)
179- Bump perl(Test::Manifest) version requirement to 1.21
180- Bump perl(Test::More) version requirement to 0.88
181- Drop perl(ExtUtils::MakeMaker) version requirement
182- BR: at least version 1.00 of perl(Test::Pod)
183- Drop buildreq perl(Test::Prereq) since t/prereq.t isn't in the test_manifest
184- Package LICENSE file
185- Expand %%summary and %%description
186- Drop %%defattr, redundant since rpm 4.4
187- Don't need to remove empty directories from the buildroot
188- Don't use macros for commands
189- Make %%files list more explicit
190- Use %%{_fixperms} macro rather than our own chmod incantation
191- Use DESTDIR rather than PERL_INSTALL_ROOT
192
193* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-7
194- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
195
196* Wed Jun 13 2012 Petr Pisar <ppisar@redhat.com> - 1.29-6
197- Perl 5.16 rebuild
198
199* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-5
200- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
201
202* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.29-4
203- Perl mass rebuild
204
205* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-3
206- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
207
208* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.29-2
209- Rebuild to fix problems with vendorarch/lib (#661697)
210
211* Tue Jun 29 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.29-1
212- update to 1.29
213
214* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.25-5
215- Mass rebuild with perl-5.12.0
216
217* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 1.25-4
218- rebuild against perl 5.10.1
219
220* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.25-3
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
222
223* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.25-2
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
225
226* Tue Jan 20 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.25-1
227- Upstream update.
228
229* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.22-3
230- helps if you upload new source
231
232* Fri Feb  8 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.22-2
233- rebuild for new perl
234
235* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.22-1
236- bump to 1.22
237- fix license tag
238
239* Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
240- Update to 1.16.
241
242* Fri May 19 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
243- Update to 1.15.
244
245* Wed May 03 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.14-1
246- First build.
Note: See TracBrowser for help on using the repository browser.