source: projects/specs/trunk/p/perl-Test-Fatal/perl-Test-Fatal-vl.spec @ 5803

Revision 5803, 3.7 KB checked in by shaolin, 12 years ago (diff)
  • new packages (and a few updates)
Line 
1Summary:        Incredibly simple helpers for testing code with exceptions
2Name:           perl-Test-Fatal
3Version:        0.010
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Url:            http://search.cpan.org/dist/Test-Fatal/
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-%{version}.tar.gz
9Patch0:         Test-Fatal-0.008-old-EU::MM.patch
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
11BuildArch:      noarch
12BuildRequires:  perl(Carp)
13BuildRequires:  perl(Exporter) >= 5.57
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Test::Builder::Tester)
16BuildRequires:  perl(Test::More)
17BuildRequires:  perl(Test::Pod)
18BuildRequires:  perl(Try::Tiny) >= 0.07
19Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
20
21%description
22Test::Fatal is an alternative to the popular Test::Exception. It does much
23less, but should allow greater flexibility in testing exception-throwing code
24with about the same amount of typing.
25
26%prep
27%setup -q -n Test-Fatal-%{version}
28
29%build
30perl Makefile.PL INSTALLDIRS=vendor
31make %{?_smp_mflags}
32
33%install
34rm -rf %{buildroot}
35make pure_install DESTDIR=%{buildroot}
36find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
37find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
38%{_fixperms} %{buildroot}
39
40%check
41make test RELEASE_TESTING=1
42
43%clean
44rm -rf %{buildroot}
45
46%files
47%defattr(-,root,root,-)
48%doc Changes LICENSE README
49%{perl_vendorlib}/Test/
50%{_mandir}/man3/Test::Fatal.3pm*
51
52%changelog
53* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.010-1
54- initial build for Vine Linux
55
56* Thu Feb 16 2012 Paul Howarth <paul@city-fan.org> 0.010-1
57- Update to 0.010
58  - Avoid tickling an overloading bug in perl 5.6 during testing
59    (CPAN RT#74847)
60
61* Fri Feb 10 2012 Paul Howarth <paul@city-fan.org> 0.009-1
62- Update to 0.009
63  - Advise against using isnt(exception{...},undef)
64
65* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.008-2
66- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
67
68* Mon Nov  7 2011 Paul Howarth <paul@city-fan.org> 0.008-1
69- Update to 0.008
70  - Revert the mistake by which 0.004 allowed blocks after "exception" as well
71    as "success"
72- BR: perl(Carp)
73- Update patch for building with ExtUtils::MakeMaker < 6.30
74
75* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> 0.006-2
76- Perl mass rebuild
77
78* Thu Jun  2 2011 Paul Howarth <paul@city-fan.org> 0.006-1
79- Update to 0.006
80  - Crank back the Test::More and Exporter requirements (CPAN RT#62699)
81  - Add lives_ok and dies_ok emulation (CPAN RT#67598)
82- Versions patch replaced by workaround for old ExtUtils::MakeMaker
83- BR: perl(Test::Builder::Tester)
84
85* Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.005-1
86- Update to 0.005
87  - Fix the logic that picks tests for 5.13.1+
88
89* Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.004-1
90- Update to 0.004
91  - success blocks now allow trailing blocks like finally, catch, etc.
92- Remove remaining uses of macros for commands
93- Re-order %%install section to conventional position in spec
94
95* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.003-2
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
97
98* Fri Oct 29 2010 Paul Howarth <paul@city-fan.org> 0.003-1
99- Update to 0.003
100  - More tests for false exceptions, especially on 5.13
101- Update versions patch
102
103* Thu Oct 28 2010 Paul Howarth <paul@city-fan.org> 0.002-1
104- Update to 0.002
105  - Add tests for handling of false exceptions
106  - Fix precedence error in documentation
107- Update versions patch
108
109* Wed Oct 27 2010 Paul Howarth <paul@city-fan.org> 0.001-2
110- Sanitize spec for Fedora submission
111
112* Tue Oct 26 2010 Paul Howarth <paul@city-fan.org> 0.001-1
113- Initial RPM version
Note: See TracBrowser for help on using the repository browser.