source: projects/specs/trunk/p/perl-Test-EOL/perl-Test-EOL-vl.spec @ 5844

Revision 5844, 3.5 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1# We don't really need ExtUtils::MakeMaker > 6.30
2%global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.30 ? 1 : 0;' 2>/dev/null || echo 0)
3
4Name:           perl-Test-EOL
5Version:        1.1
6Release:        1%{?_dist_release}
7Summary:        Check the correct line endings in your project
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/Test-EOL/
11Source0:        http://search.cpan.org/CPAN/authors/id/R/RI/RIBASUSHI/Test-EOL-%{version}.tar.gz
12Patch0:         Test-EOL-1.0-old-EU::MM.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
14BuildArch:      noarch
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(File::Find)
17BuildRequires:  perl(File::Spec)
18BuildRequires:  perl(FindBin)
19# Simplify breaking dependency loops at bootstrap time
20%if 0%{!?perl_bootstrap:1}
21BuildRequires:  perl(Pod::Coverage::TrustPod)
22%endif
23BuildRequires:  perl(Test::Builder)
24BuildRequires:  perl(Test::More)
25BuildRequires:  perl(Test::NoTabs)
26BuildRequires:  perl(Test::Pod)
27BuildRequires:  perl(Test::Pod::Coverage)
28Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
29
30%description
31This module scans your project/distribution for any perl files (scripts,
32modules, etc.) with Windows line endings. It can also check for trailing
33whitespace.
34
35%prep
36%setup -q -n Test-EOL-%{version}
37
38# We don't really need ExtUtils::MakeMaker > 6.30
39%if %{old_eumm}
40%patch0 -p1
41%endif
42
43%build
44perl Makefile.PL INSTALLDIRS=vendor
45make %{?_smp_mflags}
46
47%install
48rm -rf %{buildroot}
49make pure_install DESTDIR=%{buildroot}
50find %{buildroot} -type f -name .packlist -exec rm -f {} \;
51find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
52%{_fixperms} %{buildroot}
53
54%check
55make test RELEASE_TESTING=1
56
57%clean
58rm -rf %{buildroot}
59
60%files
61%defattr(-,root,root,-)
62%doc Changes LICENSE README
63%{perl_vendorlib}/Test/
64%{_mandir}/man3/Test::EOL.3pm*
65
66%changelog
67* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1-1
68- initial build for Vine Linux
69
70* Mon Jan 16 2012 Paul Howarth <paul@city-fan.org> 1.1-1
71- Update to 1.1
72  - Fix test fails on < 5.8 perls
73  - Fix t/13-latin1.t failures on Win32 and under TB1.5
74- Add buildreqs for required core modules, which might be dual-lived
75
76* Thu Jan  5 2012 Paul Howarth <paul@city-fan.org> 1.0-1
77- Update to 1.0
78  - Fix misleading test failure diagnostics when only issue is trailing
79    whitespace
80  - No longer blindly assume utf8 on input files (CPAN RT#59877)
81  - Properly document testing options
82- This release by RIBASUSHI -> update source URL
83- Drop upstreamed patch for CPAN RT#59877
84- Update patch for building with old ExtUtils::MakeMaker versions
85
86* Thu Jun 30 2011 Paul Howarth <paul@city-fan.org> - 0.9-5
87- Restore EPEL-4 compatibility
88- perl(Pod::Coverage::TrustPod) is available everywhere now
89- %%{?perl_default_filter} isn't needed for this tiny package
90- Nobody else likes macros for commands
91
92* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.9-4
93- Perl mass rebuild
94- Add macro perl_bootstrap
95
96* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-3
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
98
99* Mon Oct 18 2010 Paul Howarth <paul@city-fan.org> 0.9-2
100- Don't assume tested files are UTF-8 encoded (CPAN RT#59877)
101
102* Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> 0.9-1
103- Update to 0.9 (fix warnings on very old perls - CPAN RT#58442)
104- Use DESTDIR instead of PERL_INSTALL_ROOT
105- Add %%{?perl_default_filter}
106
107* Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> 0.8-1
108- Initial RPM version
Note: See TracBrowser for help on using the repository browser.