source: projects/specs/trunk/p/perl-Test-Differences/perl-Test-Differences-vl.spec @ 9104

Revision 9104, 4.4 KB checked in by inagaki, 9 years ago (diff)

2014-11-19 Ryoichi INAGAKI <ryo1@…>

  • perl-B-Keywords, perl-PadWalker?, perl-Test-{Base, Differences, Taint}, perl-Text-Autoformat, perl-YAML-Tiny: updated
  • perl-Pod-Spell: rebuilt
  • perl-Capture-Tiny: NEW


Line 
1# RPM version needs 4 digits after the decimal to preserve upgrade path
2%global module_version 0.62
3%global RPM_version %(echo %{module_version} | %{__perl} -pi -e 's/(.*)/sprintf("%.4f", $1)/e')
4
5Name:           perl-Test-Differences
6Version:        %{RPM_version}
7Release:        1%{?_dist_release}
8Summary:        Test strings and data structures and show differences if not OK
9
10Group:          Development/Libraries
11License:        GPL+ or Artistic
12URL:            http://search.cpan.org/dist/Test-Differences/
13Source0:        http://search.cpan.org/CPAN/authors/id/O/OV/OVID/Test-Differences-%{module_version}.tar.gz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildArch:      noarch
17BuildRequires:  perl(Text::Diff) >= 0.35
18BuildRequires:  perl(ExtUtils::MakeMaker)
19BuildRequires:  perl(Test::More)
20BuildRequires:  perl(Test::Pod)
21BuildRequires:  perl(Test::Pod::Coverage)
22BuildRequires:  perl(Capture::Tiny)
23# not detected
24Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
25
26%description
27When the code you're testing returns multiple lines, records or data
28structures and they're just plain wrong, an equivalent to the Unix
29diff utility may be just what's needed.
30
31
32%prep
33%setup -q -n Test-Differences-%{module_version}
34
35
36%build
37%{__perl} Makefile.PL INSTALLDIRS=vendor
38make %{?_smp_mflags}
39
40
41%install
42rm -rf %{buildroot}
43make pure_install PERL_INSTALL_ROOT=%{buildroot}
44find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
45find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
46chmod -R u+w %{buildroot}/*
47
48
49%check
50make test
51
52
53%clean
54rm -rf %{buildroot}
55
56
57%files
58%defattr(-,root,root,-)
59%doc Changes README
60%{perl_vendorlib}/Test/
61%{_mandir}/man3/Test::Differences.3pm*
62
63
64%changelog
65* Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.6200-1
66- updated to 0.62
67- built with perl 5.16.3
68- added BR: perl(Capture::Tiny)
69
70* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5000-1
71- initial build for Vine Linux
72
73* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5000-6
74- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
75
76* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.5000-5
77- Perl mass rebuild
78
79* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5000-4
80- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
81
82* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.5000-3
83- 661697 rebuild for fixing problems with vendorach/lib
84
85* Thu Jul 08 2010 Iain Arnell <iarnell@gmail.com> 0.500-2
86- explicitly require perl(Text::Diff)
87
88* Tue Jun 29 2010 Paul Howarth <paul@city-fan.org> - 0.5000-1
89- Update to 0.500
90  - Add support for all diff styles supplied by Text::Diff (CPAN RT#23579)
91  - Add Build.PL
92  - Convert to universally use Test::More instead of Test
93  - Convert to modern Perl distribution.
94  - Applied doc suggestion from CPAN RT#24297
95  - Fix the { a => 1 } versus { a => '1' } bug (CPAN RT#3029)
96- Upstream dropped eg/ docs
97- Bump perl(Text::Diff) requirement to 0.35
98- BR: perl(Test::Pod) and perl(Test::Pod::Coverage) for extra test cover
99
100* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.4801-5
101- Mass rebuild with perl-5.12.0
102
103* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 0.4801-4
104- rebuild against perl 5.10.1
105
106* Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4801-3
107- fix source url
108
109* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4801-2
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
111
112* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4801-1
113- update to 0.4801
114
115* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.47-5
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
117
118* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-4
119- Rebuild for perl 5.10 (again)
120
121* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-3
122- rebuild for new perl
123
124* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-2.2
125- add BR: perl(Test::More)
126
127* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-2.1
128- correct license tag
129- add BR: perl(ExtUtils::MakeMaker)
130
131* Sun May 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.47-2
132- Bumping release (repodata checksum inconsistency for previous release).
133
134* Mon May 01 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.47-1
135- First build.
Note: See TracBrowser for help on using the repository browser.