source: projects/specs/trunk/p/perl-Test-Classy/perl-Test-Classy-vl.spec @ 4920

Revision 4920, 1.9 KB checked in by yasumichi, 13 years ago (diff)

Import spec file.

Line 
1%define pkgname Test-Classy
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.09
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        write your unit tests in other modules than *.t
17Summary(ja):    *.t 以外のモジュールで単体テストを書く
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26This is yet another Test::Class-like unit testing framework. As stated in
27Test::Class pod, you don't need to care if your tests are small and working
28correctly. If not, this may be one of your options.
29
30Unlike Test::Class, Test::Classy (actually Test::Classy::Base) is based on
31Test::More and exports everything Test::More exports. Test::Classy doesn't
32control test flow as fully as Test::Class, but it may be easier to skip and
33limit tests.
34
35#%%description -l ja
36
37%prep
38%setup -q -n Test-Classy-0.09
39
40%build
41perl Makefile.PL
42%{__make}
43
44%install
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%{__make} install DESTDIR=${RPM_BUILD_ROOT}
47
48find $RPM_BUILD_ROOT%{_prefix} -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v ^%{_mandir} |
51        grep -v perllocal.pod |
52        grep -v "\.packlist" > %{name}.files
53if [ "$(cat %{name}.files)X" = "X" ] ; then
54        echo "ERROR: EMPTY FILE LIST"
55        exit -1
56fi
57
58# remove unnecessary files.
59%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
60%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Test/Classy/.packlist
61
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66
67%files -f %{name}.files
68%defattr(-,root,root)
69%doc Changes README
70%dir %{perl_sitelib}/Test/Classy
71%{_mandir}/*/*
72
73
74%changelog
75* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.09-1
76- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.