source: projects/specs/trunk/p/perl-Template-Toolkit/perl-Template-Toolkit-vl.spec @ 5871

Revision 5871, 6.2 KB checked in by shaolin, 12 years ago (diff)
  • perl-XML-XPath, perl-Test-Manifest, perl-XML-RSS
    • update and/or rebuild
  • others: new packages
Line 
1Name:           perl-Template-Toolkit
2Version:        2.22
3Release:        1%{?_dist_release}
4Summary:        Template processing system
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://www.template-toolkit.org/
8Source0:        http://search.cpan.org/CPAN/authors/id/A/AB/ABW/Template-Toolkit-%{version}.tar.gz
9Source1:        http://tt2.org/download/TT_v222_html_docs.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12BuildRequires:  perl(Test::More)
13BuildRequires:  perl(AppConfig), perl(Text::Autoformat), perl(GD::Graph3d), perl(GD::Graph)
14BuildRequires:  perl(GD::Text), perl(Image::Info), perl(Image::Size), perl(Pod::POM)
15BuildRequires:  perl(XML::DOM), perl(XML::RSS), perl(XML::XPath)
16Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
17Provides:       perl-Template-Toolkit-examples = %{version}-%{release}
18Obsoletes:      perl-Template-Toolkit-examples < 2.22-1
19
20%if "%{_dist_release}" > "vl6"
21%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}perl\\(bytes\\)
22%else
23%global provfilt /bin/sh -c "%{__perl_provides} | grep -Ev '^perl[(](bytes)[)]'"
24%define __perl_provides %{provfilt}
25%endif
26
27Vendor:         Project Vine
28Distribution:   Vine Linux
29
30%description
31The Template Toolkit is a collection of modules which implement a
32fast, flexible, powerful and extensible template processing system.
33It was originally designed and remains primarily useful for generating
34dynamic web content, but it can be used equally well for processing
35any other kind of text based documents: HTML, XML, POD, PostScript,
36LaTeX, and so on.
37
38%prep
39%setup -q -n Template-Toolkit-%{version} -a 1
40find lib -type f | xargs chmod -c -x
41find TT_v*_html_docs -depth -name .svn -type d -exec rm -rf {} \;
42
43# Convert file to UTF-8
44iconv -f iso-8859-1 -t utf-8 -o Changes{.utf8,}
45mv Changes{.utf8,}
46
47%build
48CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS=vendor \
49  TT_DBI=n TT_ACCEPT=y
50make %{?_smp_mflags} OPTIMIZE="%{optflags}"
51
52%install
53rm -rf %{buildroot}
54# install (+ INSTALLARCHLIB) instead of pure_install to get docs
55# and the template library installed too
56make install \
57  PERL_INSTALL_ROOT=%{buildroot} \
58  INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
59  TT_PREFIX=%{buildroot}%{_datadir}/tt2
60find %{buildroot} -type f \( -name perllocal.pod -o \
61  -name .packlist -o -name '*.bs' -size 0 \) -exec rm -f {} ';'
62find %{buildroot} -depth -type d -empty -exec rmdir {} ';'
63chmod -R u+w %{buildroot}/*
64# Nuke buildroot where it hides
65sed -i "s|%{buildroot}||g" %{buildroot}%{perl_vendorarch}/Template/Config.pm
66
67%check
68make test
69
70%clean
71rm -rf %{buildroot}
72
73%files
74%defattr(-,root,root,-)
75%doc Changes HACKING README TODO TT_v*_html_docs/*
76%{_bindir}/tpage
77%{_bindir}/ttree
78%{perl_vendorarch}/Template.pm
79%{perl_vendorarch}/auto/Template
80%{perl_vendorarch}/Template
81%{_mandir}/man1/*.1*
82%{_mandir}/man3/*.3*
83
84%changelog
85* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22-1
86- initial build for Vine Linux
87
88* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22-11
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
90
91* Mon Jul 25 2011 Iain Arnell <iarnell@gmail.com> 2.22-10
92- update filtering for rpm 4.9
93
94* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 2.22-9
95- Perl mass rebuild
96
97* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22-8
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
99
100* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.22-7
101- 661697 rebuild for fixing problems with vendorach/lib
102
103* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.22-6
104- Mass rebuild with perl-5.12.0
105
106* Tue Feb  9 2010 Stepan Kasal <skasal@redhat.com> - 2.22-5
107- delete the buildroot before install
108
109* Fri Jan 15 2010 Stepan Kasal <skasal@redhat.com> - 2.22-4
110- use filtering macros
111
112* Fri Jan 15 2010 Stepan Kasal <skasal@redhat.com> - 2.22-3
113- drop build requirements for TeX; LaTeX support has been removed in 2.14a
114- fix the Obsoletes tag
115
116* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 2.22-2
117- rebuild against perl 5.10.1
118
119* Sat Jul 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.22-1
120- update to 2.22
121- obsolete examples package, upstream got rid of them
122
123* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.20-1
124- update to 2.20
125
126* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.19-5
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
128
129* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-4
130- Rebuild for perl 5.10 (again)
131
132* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.19-3
133- Autorebuild for GCC 4.3
134
135* Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-2
136- rebuild for new perl
137
138* Sun Aug 26 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-1
139- 2.19
140- license tag fix
141- rebuild for BuildID
142
143* Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 2.18-1
144- go to 2.18
145
146* Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.15-2
147- bump for fc6
148
149* Mon May 29 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.15-1
150- bump to 2.15
151- gd test is gone, don't need to patch anything
152
153* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-8
154- really resolve bug 173756
155
156* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-7
157- use proper TT_PREFIX setting everywhere, resolve bug 173756
158
159* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-6
160- bump for FC-5
161
162* Mon Jul 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-5
163- don't need Tie::DBI as a BuildRequires, since we're not running
164  the tests
165
166* Mon Jul 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-4
167- put examples in their own subpackage
168
169* Sat Jul  9 2005 Ville Skyttä <ville.skytta at iki.fi> - 2.14-3
170- Filter false positive provides.
171- Include template library, switch to %%{_datadir}/tt2.
172- Tune build dependencies for full test suite coverage.
173- Fix and enable GD tests.
174- Include more documentation.
175- Fine tune dir ownerships and file permissions.
176
177* Fri Jul  8 2005 Tom "spot" Callaway <tcallawa@redhat.com> 2.14-2
178- cleanups
179
180* Wed Jul  6 2005 Tom "spot" Callaway <tcallawa@redhat.com> 2.14-1
181- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.