source: projects/specs/trunk/p/perl-Template-Toolkit/perl-Template-Toolkit-vl.spec @ 9187

Revision 9187, 6.5 KB checked in by inagaki, 9 years ago (diff)

2014-12-23 Ryoichi INAGAKI <ryo1@…>

  • perl-CGI-FormBuilder?, perl-Devel-{EnforceEncapsulation?, GlobalDestruction?}, perl-Moose, perl-Net-{Pcap, Radius, Telnet, Write}, perl-Template-Toolkit, perl-Text-Unidecode, perl-XML-RSS: updated
  • perl-CGI-SSI, perl-Geography-Countries, perl-MIME-Lite-TT, perl-MP3-Info, perl-Text-Glob: rebuilt
  • perl-Sub-Exporter-Progressive: new


Line 
1Name:           perl-Template-Toolkit
2Version:        2.26
3Release:        1%{?_dist_release}
4Summary:        Template processing system
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://www.template-toolkit.org/
8Source0:        http://search.cpan.org/CPAN/authors/id/A/AB/ABW/Template-Toolkit-%{version}.tar.gz
9Source1:        http://tt2.org/download/TT_v224_html_docs.tar.gz
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12BuildRequires:  perl(Test::More)
13BuildRequires:  perl(AppConfig)
14BuildRequires:  perl(Text::Autoformat)
15BuildRequires:  perl(GD::Graph3d)
16BuildRequires:  perl(GD::Graph)
17BuildRequires:  perl(GD::Text)
18BuildRequires:  perl(Image::Info)
19BuildRequires:  perl(Image::Size)
20BuildRequires:  perl(Pod::POM)
21BuildRequires:  perl(XML::DOM)
22BuildRequires:  perl(XML::RSS)
23BuildRequires:  perl(XML::XPath)
24Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
25Provides:       perl-Template-Toolkit-examples = %{version}-%{release}
26Obsoletes:      perl-Template-Toolkit-examples < 2.22-1
27
28%if "%{_dist_release}" > "vl6"
29%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}perl\\(bytes\\)
30%else
31%global provfilt /bin/sh -c "%{__perl_provides} | grep -Ev '^perl[(](bytes)[)]'"
32%define __perl_provides %{provfilt}
33%endif
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37
38%description
39The Template Toolkit is a collection of modules which implement a
40fast, flexible, powerful and extensible template processing system.
41It was originally designed and remains primarily useful for generating
42dynamic web content, but it can be used equally well for processing
43any other kind of text based documents: HTML, XML, POD, PostScript,
44LaTeX, and so on.
45
46%prep
47%setup -q -n Template-Toolkit-%{version} -a 1
48find lib -type f | xargs chmod -c -x
49find TT_v*_html_docs -depth -name .svn -type d -exec rm -rf {} \;
50
51# Convert file to UTF-8
52iconv -f iso-8859-1 -t utf-8 -o Changes{.utf8,}
53mv Changes{.utf8,}
54
55%build
56CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS=vendor \
57  TT_DBI=n TT_ACCEPT=y
58make %{?_smp_mflags} OPTIMIZE="%{optflags}"
59
60%install
61rm -rf %{buildroot}
62# install (+ INSTALLARCHLIB) instead of pure_install to get docs
63# and the template library installed too
64make install \
65  PERL_INSTALL_ROOT=%{buildroot} \
66  INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
67  TT_PREFIX=%{buildroot}%{_datadir}/tt2
68find %{buildroot} -type f \( -name perllocal.pod -o \
69  -name .packlist -o -name '*.bs' -size 0 \) -exec rm -f {} ';'
70find %{buildroot} -depth -type d -empty -exec rmdir {} ';'
71chmod -R u+w %{buildroot}/*
72# Nuke buildroot where it hides
73sed -i "s|%{buildroot}||g" %{buildroot}%{perl_vendorarch}/Template/Config.pm
74
75%check
76make test
77
78%clean
79rm -rf %{buildroot}
80
81%files
82%defattr(-,root,root,-)
83%doc Changes HACKING README TODO TT_v*_html_docs/*
84%{_bindir}/tpage
85%{_bindir}/ttree
86%{perl_vendorarch}/Template.pm
87%{perl_vendorarch}/auto/Template
88%{perl_vendorarch}/Template
89%{_mandir}/man1/*.1*
90%{_mandir}/man3/*.3*
91
92%changelog
93* Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.26-1
94- updated Source0 to 2.26
95- updated Source1 to 2.24
96- built with perl 5.16.3
97
98* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22-1
99- initial build for Vine Linux
100
101* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22-11
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
103
104* Mon Jul 25 2011 Iain Arnell <iarnell@gmail.com> 2.22-10
105- update filtering for rpm 4.9
106
107* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 2.22-9
108- Perl mass rebuild
109
110* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22-8
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
112
113* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.22-7
114- 661697 rebuild for fixing problems with vendorach/lib
115
116* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.22-6
117- Mass rebuild with perl-5.12.0
118
119* Tue Feb  9 2010 Stepan Kasal <skasal@redhat.com> - 2.22-5
120- delete the buildroot before install
121
122* Fri Jan 15 2010 Stepan Kasal <skasal@redhat.com> - 2.22-4
123- use filtering macros
124
125* Fri Jan 15 2010 Stepan Kasal <skasal@redhat.com> - 2.22-3
126- drop build requirements for TeX; LaTeX support has been removed in 2.14a
127- fix the Obsoletes tag
128
129* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 2.22-2
130- rebuild against perl 5.10.1
131
132* Sat Jul 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.22-1
133- update to 2.22
134- obsolete examples package, upstream got rid of them
135
136* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.20-1
137- update to 2.20
138
139* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.19-5
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
141
142* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-4
143- Rebuild for perl 5.10 (again)
144
145* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.19-3
146- Autorebuild for GCC 4.3
147
148* Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-2
149- rebuild for new perl
150
151* Sun Aug 26 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 2.19-1
152- 2.19
153- license tag fix
154- rebuild for BuildID
155
156* Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 2.18-1
157- go to 2.18
158
159* Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.15-2
160- bump for fc6
161
162* Mon May 29 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.15-1
163- bump to 2.15
164- gd test is gone, don't need to patch anything
165
166* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-8
167- really resolve bug 173756
168
169* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-7
170- use proper TT_PREFIX setting everywhere, resolve bug 173756
171
172* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-6
173- bump for FC-5
174
175* Mon Jul 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-5
176- don't need Tie::DBI as a BuildRequires, since we're not running
177  the tests
178
179* Mon Jul 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.14-4
180- put examples in their own subpackage
181
182* Sat Jul  9 2005 Ville Skyttä <ville.skytta at iki.fi> - 2.14-3
183- Filter false positive provides.
184- Include template library, switch to %%{_datadir}/tt2.
185- Tune build dependencies for full test suite coverage.
186- Fix and enable GD tests.
187- Include more documentation.
188- Fine tune dir ownerships and file permissions.
189
190* Fri Jul  8 2005 Tom "spot" Callaway <tcallawa@redhat.com> 2.14-2
191- cleanups
192
193* Wed Jul  6 2005 Tom "spot" Callaway <tcallawa@redhat.com> 2.14-1
194- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.