source: projects/specs/trunk/p/perl-Sub-Name/perl-Sub-Name-vl.spec @ 12120

Revision 12120, 4.9 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# Only need manual requires for "use base XXX;" prior to rpm 4.9
2%global rpm49 %(rpm --version | perl -pi -e 's/^.* (\\d+)\\.(\\d+).*/sprintf("%d.%03d",$1,$2) ge 4.009 ? 1 : 0/e')
3
4Name:           perl-Sub-Name
5Version:        0.21
6Release:        1%{?_dist_release}
7Summary:        Name - or rename - a sub
8License:        GPL+ or Artistic
9Group:          Development/Libraries
10URL:            http://search.cpan.org/dist/Sub-Name/
11Source0:        http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Sub-Name-%{version}.tar.gz
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  perl(base)
18BuildRequires:  perl(Devel::CheckBin)
19BuildRequires:  perl(DynaLoader)
20BuildRequires:  perl(Exporter)
21BuildRequires:  perl(ExtUtils::MakeMaker)
22BuildRequires:  perl(strict)
23BuildRequires:  perl(Test::More)
24BuildRequires:  perl(warnings)
25BuildRequires:  libxcrypt-devel
26Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
27%if ! %{rpm49}
28Requires:       perl(DynaLoader)
29Requires:       perl(Exporter)
30%endif
31
32
33# Don't "provide" private perl objects
34%{?perl_default_filter}
35
36%description
37This module allows one to "name" or rename subroutines, including anonymous
38ones.
39
40Note that this is mainly for aid in debugging; you still cannot call the sub
41by the new name (without some deep magic).
42
43%prep
44%setup -q -n Sub-Name-%{version}
45
46%build
47perl Makefile.PL INSTALLDIRS=vendor optimize="%{optflags}"
48make %{?_smp_mflags}
49
50%install
51rm -rf %{buildroot}
52make pure_install DESTDIR=%{buildroot}
53find %{buildroot} -type f -name .packlist -exec rm -f {} \;
54find %{buildroot} -type f -name '*.bs' -size 0 -exec rm -f {} \;
55find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
56%{_fixperms} %{buildroot}
57
58%check
59make test
60
61%clean
62rm -rf %{buildroot}
63
64%files
65%defattr(-,root,root,-)
66%doc Changes README
67%{perl_vendorarch}/auto/Sub/
68%{perl_vendorarch}/Sub/
69%{_mandir}/man3/Sub::Name.3pm*
70
71%changelog
72* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.21-1
73- new upstream release.
74- rebuilt with perl-5.26.
75- added BR:libxcrypt-devel.
76
77* Sat Nov 22 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12-1
78- updated to 0.12
79- added BR: perl(Devel::CheckBin)
80- built with perl 5.16.3
81
82* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.05-1
83- initial build for Vine Linux
84
85* Sat Feb 18 2012 Paul Howarth <paul@city-fan.org> - 0.05-6
86- Add patch for CPAN RT#50524 (copy contents of %%DB::sub entry if it exists)
87- Reinstate compatibility with old distributions like EL-5
88  - Add BuildRoot definition
89  - Clean buildroot in %%install
90  - Restore %%clean section
91  - Restore %%defattr
92  - Don't use + to terminate find -exec commands
93- Spec clean-up
94  - Make %%files list more explicit
95  - Use DESTDIR rather than PERL_INSTALL_ROOT
96  - Don't use macros for commands
97  - Use tabs
98  - Add buildreqs for Perl core modules that might be dual-lived
99  - Explicit requires for "use base XXX;" only required prior to rpm 4.9
100
101* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.05-5
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
103
104* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.05-4
105- Perl mass rebuild
106
107* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.05-3
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
109
110* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.05-2
111- Rebuild to fix problems with vendorarch/lib (#661697)
112
113* Sat Dec 18 2010 Iain Arnell <iarnell@gmail.com> - 0.05-1
114- Update to latest upstream version
115- Clean up spec for modern rpmbuild
116- BR perl(Test::More)
117- Requires perl(DynaLoader) and perl(Exporter)
118
119* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.04-6
120- Mass rebuild with perl-5.12.0
121
122* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.04-5
123- Rebuild against perl 5.10.1
124
125* Thu Aug 27 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.04-4
126- Filtering errant private provides
127
128* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-3
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
130
131* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-2
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
133
134* Sun Aug 03 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.04-1
135- Update to 0.04
136
137* Sat Mar 15 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-1
138- Update to 0.03
139
140* Tue Mar  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.02-5
141- Rebuild for new perl
142
143* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.02-4.1
144- Autorebuild for GCC 4.3
145
146* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.02-3.1
147- Correct license tag
148- Add BR: perl(ExtUtils::MakeMaker)
149
150* Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-3
151- Bump
152
153* Wed Sep 06 2006 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-2
154- Bump
155
156* Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-1
157- Specfile autogenerated by cpanspec 1.69.1
Note: See TracBrowser for help on using the repository browser.