source: projects/specs/trunk/p/perl-Sub-Name/perl-Sub-Name-vl.spec @ 9111

Revision 9111, 4.7 KB checked in by inagaki, 9 years ago (diff)

2014-11-22 Ryoichi INAGAKI <ryo1@…>


RevLine 
[5844]1# Only need manual requires for "use base XXX;" prior to rpm 4.9
2%global rpm49 %(rpm --version | perl -pi -e 's/^.* (\\d+)\\.(\\d+).*/sprintf("%d.%03d",$1,$2) ge 4.009 ? 1 : 0/e')
3
4Name:           perl-Sub-Name
[9111]5Version:        0.12
[5844]6Release:        1%{?_dist_release}
7Summary:        Name - or rename - a sub
8License:        GPL+ or Artistic
9Group:          Development/Libraries
10URL:            http://search.cpan.org/dist/Sub-Name/
11Source0:        http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Sub-Name-%{version}.tar.gz
[9111]12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
[5844]14BuildRequires:  perl(base)
[9111]15BuildRequires:  perl(Devel::CheckBin)
[5844]16BuildRequires:  perl(DynaLoader)
[9111]17BuildRequires:  perl(Exporter) >= 5.57
[5844]18BuildRequires:  perl(ExtUtils::MakeMaker)
19BuildRequires:  perl(strict)
[9111]20BuildRequires:  perl(Test::More) >= 0.88
[5844]21BuildRequires:  perl(warnings)
22Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
23%if ! %{rpm49}
24Requires:       perl(DynaLoader)
25Requires:       perl(Exporter)
26%endif
27
28# Don't "provide" private perl objects
29%{?perl_default_filter}
30
31%description
32This module allows one to "name" or rename subroutines, including anonymous
33ones.
34
35Note that this is mainly for aid in debugging; you still cannot call the sub
36by the new name (without some deep magic).
37
38%prep
39%setup -q -n Sub-Name-%{version}
40
41%build
42perl Makefile.PL INSTALLDIRS=vendor optimize="%{optflags}"
43make %{?_smp_mflags}
44
45%install
46rm -rf %{buildroot}
47make pure_install DESTDIR=%{buildroot}
48find %{buildroot} -type f -name .packlist -exec rm -f {} \;
49find %{buildroot} -type f -name '*.bs' -size 0 -exec rm -f {} \;
50find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
51%{_fixperms} %{buildroot}
52
53%check
54make test
55
56%clean
57rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root,-)
61%doc Changes README
62%{perl_vendorarch}/auto/Sub/
63%{perl_vendorarch}/Sub/
64%{_mandir}/man3/Sub::Name.3pm*
65
66%changelog
[9111]67* Sat Nov 22 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12-1
68- updated to 0.12
69- added BR: perl(Devel::CheckBin)
70- built with perl 5.16.3
71
[5844]72* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.05-1
73- initial build for Vine Linux
74
75* Sat Feb 18 2012 Paul Howarth <paul@city-fan.org> - 0.05-6
76- Add patch for CPAN RT#50524 (copy contents of %%DB::sub entry if it exists)
77- Reinstate compatibility with old distributions like EL-5
78  - Add BuildRoot definition
79  - Clean buildroot in %%install
80  - Restore %%clean section
81  - Restore %%defattr
82  - Don't use + to terminate find -exec commands
83- Spec clean-up
84  - Make %%files list more explicit
85  - Use DESTDIR rather than PERL_INSTALL_ROOT
86  - Don't use macros for commands
87  - Use tabs
88  - Add buildreqs for Perl core modules that might be dual-lived
89  - Explicit requires for "use base XXX;" only required prior to rpm 4.9
90
91* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.05-5
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
93
94* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.05-4
95- Perl mass rebuild
96
97* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.05-3
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
99
100* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.05-2
101- Rebuild to fix problems with vendorarch/lib (#661697)
102
103* Sat Dec 18 2010 Iain Arnell <iarnell@gmail.com> - 0.05-1
104- Update to latest upstream version
105- Clean up spec for modern rpmbuild
106- BR perl(Test::More)
107- Requires perl(DynaLoader) and perl(Exporter)
108
109* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.04-6
110- Mass rebuild with perl-5.12.0
111
112* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.04-5
113- Rebuild against perl 5.10.1
114
115* Thu Aug 27 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.04-4
116- Filtering errant private provides
117
118* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-3
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
123
124* Sun Aug 03 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.04-1
125- Update to 0.04
126
127* Sat Mar 15 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-1
128- Update to 0.03
129
130* Tue Mar  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.02-5
131- Rebuild for new perl
132
133* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.02-4.1
134- Autorebuild for GCC 4.3
135
136* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.02-3.1
137- Correct license tag
138- Add BR: perl(ExtUtils::MakeMaker)
139
140* Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-3
141- Bump
142
143* Wed Sep 06 2006 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-2
144- Bump
145
146* Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-1
147- Specfile autogenerated by cpanspec 1.69.1
Note: See TracBrowser for help on using the repository browser.