source: projects/specs/trunk/p/perl-Sub-Install/perl-Sub-Install-vl.spec @ 12120

Revision 12120, 1.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define pkgname Sub-Install
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.928
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        install subroutines into packages easily
17Summary(ja):    簡単にパッケージにサブルーチンをインストールする
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26This module makes it easy to install subroutines into packages without the
27unslightly mess of no strict or typeglobs lying about where just anyone can
28see them.
29
30#%%description -l ja
31
32%prep
33%setup -q -n %{pkgname}-%{version}
34
35%build
36perl Makefile.PL
37%{__make}
38
39%install
40%{__rm} -rf ${RPM_BUILD_ROOT}
41%{__make} install DESTDIR=${RPM_BUILD_ROOT}
42
43find $RPM_BUILD_ROOT%{_prefix} -type f -print |
44        sed "s@^$RPM_BUILD_ROOT@@g" |
45        grep -v ^%{_mandir} |
46        grep -v perllocal.pod |
47        grep -v "\.packlist" > %{name}.files
48if [ "$(cat %{name}.files)X" = "X" ] ; then
49        echo "ERROR: EMPTY FILE LIST"
50        exit -1
51fi
52
53# remove unnecessary files.
54%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
55%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Sub/Install/.packlist
56
57
58%clean
59%{__rm} -rf ${RPM_BUILD_ROOT}
60
61
62%files -f %{name}.files
63%defattr(-,root,root)
64%license LICENSE
65%doc Changes README
66%{_mandir}/*/*
67
68
69
70%changelog
71* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.928-1
72- new upstream release.
73- rebuilt with perl-5.26.
74
75* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.927-1
76- update to 927-1
77
78* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.925-1
79- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.