source: projects/specs/trunk/p/perl-Sub-Exporter-Progressive/perl-Sub-Exporter-Progressive-vl.spec @ 12120

Revision 12120, 5.3 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# We need to patch the test suite if we have old versions of Test::More
2%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
3
4Name:           perl-Sub-Exporter-Progressive
5Version:        0.001013
6Release:        1%{?_dist_release}
7Summary:        Only use Sub::Exporter if you need it
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/Sub-Exporter-Progressive/
11Source0:        http://search.cpan.org/CPAN/authors/id/F/FR/FREW/Sub-Exporter-Progressive-%{version}.tar.gz
12Patch1:         Sub-Exporter-Progressive-0.001010-old-Test::More.patch
13
14Vendor:        Project Vine
15Distribution:  Vine Linux
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch:      noarch
19# =============== Module Build ======================
20BuildRequires:  perl(ExtUtils::MakeMaker)
21# =============== Module Runtime ====================
22BuildRequires:  perl(Carp)
23BuildRequires:  perl(Exporter)
24BuildRequires:  perl(List::Util)
25BuildRequires:  perl(Sub::Exporter)
26# =============== Test Suite ========================
27BuildRequires:  perl(lib)
28BuildRequires:  perl(Test::More)
29# =============== Module Runtime ====================
30Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
31Requires:       perl(Exporter)
32Requires:       perl(Sub::Exporter)
33
34%description
35Sub::Exporter is an incredibly powerful module, but with that power comes
36great responsibility, er- as well as some runtime penalties. This module is a
37Sub::Exporter wrapper that will let your users just use Exporter if all they
38are doing is picking exports, but use Sub::Exporter if your users try to use
39Sub::Exporter's more advanced features features, like renaming exports, if
40they try to use them.
41
42Note that this module will export @EXPORT and @EXPORT_OK package variables for
43Exporter to work. Additionally, if your package uses advanced Sub::Exporter
44features like currying, this module will only ever use Sub::Exporter, so you
45might as well use it directly.
46
47%prep
48%setup -q -n Sub-Exporter-Progressive-%{version}
49
50# We need to patch the test suite if we have old versions of Test::More
51%if %{old_test_more}
52%patch1
53%endif
54
55%build
56perl Makefile.PL INSTALLDIRS=vendor
57make %{?_smp_mflags}
58
59%install
60rm -rf %{buildroot}
61make pure_install DESTDIR=%{buildroot}
62find %{buildroot} -type f -name .packlist -exec rm -f {} \;
63%{_fixperms} %{buildroot}
64
65%check
66make test
67
68%clean
69rm -rf %{buildroot}
70
71%files
72%doc Changes README
73%{perl_vendorlib}/Sub/
74%{_mandir}/man3/Sub::Exporter::Progressive.3pm*
75
76%changelog
77* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net>
78- new upstream release.
79- rebuilt with perl-5.26.
80
81* Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.001011-4
82- initial build for Vine Linux
83- built with perl 5.16.3
84
85* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.001011-3
86- Perl 5.20 rebuild
87
88* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001011-2
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
90
91* Mon Oct 28 2013 Paul Howarth <paul@city-fan.org> - 0.001011-1
92- Update to 0.001011
93  - Fix in global destruction
94  - Fix SYNOPSIS
95  - Fix duplicate word in DESCRIPTION (CPAN RT#86072)
96
97* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001010-3
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
99
100* Sun Jul 21 2013 Petr Pisar <ppisar@redhat.com> - 0.001010-2
101- Perl 5.18 rebuild
102
103* Wed Mar 27 2013 Paul Howarth <paul@city-fan.org> - 0.001010-1
104- Update to 0.001010
105  - Fix module name in Makefile.PL (CPAN RT#83932)
106  - Work around Exporter.pm not installable on perl < 5.8.0
107- Update old Test::More patch
108
109* Wed Mar 13 2013 Paul Howarth <paul@city-fan.org> - 0.001009-1
110- Update to 0.001009
111  - Disallow version names in random parts of the import list for consistency
112    with Sub::Exporter (CPAN RT#83491)
113- Update old Test::More patch, and apply if we have Test::More < 0.88
114
115* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001008-2
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
117
118* Tue Jan 22 2013 Paul Howarth <paul@city-fan.org> - 0.001008-1
119- Update to 0.001008
120  - Rewrite -tag to :tag for Exporter.pm
121  - Fix prereqs
122- Update old Test::More patch, and apply if we have Test::More < 0.96
123- Bump perl(Exporter) version requirement to 5.58
124
125* Mon Aug 27 2012 Paul Howarth <paul@city-fan.org> - 0.001006-1
126- Update to 0.001006
127  - Handle ':all' correctly
128- Update old Test::More patch
129- Drop redundant buildreq perl(Test::Pod)
130
131* Sat Aug 25 2012 Paul Howarth <paul@city-fan.org> - 0.001005-1
132- Update to 0.001005
133  - Add support for tags
134  - Warn if defaults are not in exports
135  - Add explicit dependency on Test::More 0.89
136- This release by LEONT -> update source URL
137- Update old Test::More patch
138
139* Thu Aug  9 2012 Paul Howarth <paul@city-fan.org> - 0.001004-1
140- Update to 0.001004 (fix skipping when Sub::Exporter isn't installed)
141- This release by MSTROUT -> update source URL
142- No LICENSE file in this release
143- Update old Test::More patch
144
145* Wed Aug  1 2012 Paul Howarth <paul@city-fan.org> - 0.001003-1
146- Update to 0.001003 (remove warning if there are no defaults)
147
148* Wed Aug  1 2012 Paul Howarth <paul@city-fan.org> - 0.001002-2
149- Sanitize for Fedora submission
150
151* Wed Aug  1 2012 Paul Howarth <paul@city-fan.org> - 0.001002-1
152- Initial RPM build
Note: See TracBrowser for help on using the repository browser.