source: projects/specs/trunk/p/perl-Sub-Exporter-Progressive/perl-Sub-Exporter-Progressive-vl.spec @ 9187

Revision 9187, 5.1 KB checked in by inagaki, 9 years ago (diff)

2014-12-23 Ryoichi INAGAKI <ryo1@…>

  • perl-CGI-FormBuilder?, perl-Devel-{EnforceEncapsulation?, GlobalDestruction?}, perl-Moose, perl-Net-{Pcap, Radius, Telnet, Write}, perl-Template-Toolkit, perl-Text-Unidecode, perl-XML-RSS: updated
  • perl-CGI-SSI, perl-Geography-Countries, perl-MIME-Lite-TT, perl-MP3-Info, perl-Text-Glob: rebuilt
  • perl-Sub-Exporter-Progressive: new


Line 
1# We need to patch the test suite if we have old versions of Test::More
2%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
3
4Name:           perl-Sub-Exporter-Progressive
5Version:        0.001011
6Release:        4%{?_dist_release}
7Summary:        Only use Sub::Exporter if you need it
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/Sub-Exporter-Progressive/
11Source0:        http://search.cpan.org/CPAN/authors/id/F/FR/FREW/Sub-Exporter-Progressive-%{version}.tar.gz
12Patch1:         Sub-Exporter-Progressive-0.001010-old-Test::More.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildArch:      noarch
16# =============== Module Build ======================
17BuildRequires:  perl(ExtUtils::MakeMaker)
18# =============== Module Runtime ====================
19BuildRequires:  perl(Carp)
20BuildRequires:  perl(Exporter) >= 5.58
21BuildRequires:  perl(List::Util)
22BuildRequires:  perl(Sub::Exporter)
23# =============== Test Suite ========================
24BuildRequires:  perl(lib)
25BuildRequires:  perl(Test::More)
26# =============== Module Runtime ====================
27Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
28Requires:       perl(Exporter) >= 5.58
29Requires:       perl(Sub::Exporter)
30
31%description
32Sub::Exporter is an incredibly powerful module, but with that power comes
33great responsibility, er- as well as some runtime penalties. This module is a
34Sub::Exporter wrapper that will let your users just use Exporter if all they
35are doing is picking exports, but use Sub::Exporter if your users try to use
36Sub::Exporter's more advanced features features, like renaming exports, if
37they try to use them.
38
39Note that this module will export @EXPORT and @EXPORT_OK package variables for
40Exporter to work. Additionally, if your package uses advanced Sub::Exporter
41features like currying, this module will only ever use Sub::Exporter, so you
42might as well use it directly.
43
44%prep
45%setup -q -n Sub-Exporter-Progressive-%{version}
46
47# We need to patch the test suite if we have old versions of Test::More
48%if %{old_test_more}
49%patch1
50%endif
51
52%build
53perl Makefile.PL INSTALLDIRS=vendor
54make %{?_smp_mflags}
55
56%install
57rm -rf %{buildroot}
58make pure_install DESTDIR=%{buildroot}
59find %{buildroot} -type f -name .packlist -exec rm -f {} \;
60%{_fixperms} %{buildroot}
61
62%check
63make test
64
65%clean
66rm -rf %{buildroot}
67
68%files
69%doc Changes README
70%{perl_vendorlib}/Sub/
71%{_mandir}/man3/Sub::Exporter::Progressive.3pm*
72
73%changelog
74* Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.001011-4
75- initial build for Vine Linux
76- built with perl 5.16.3
77
78* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.001011-3
79- Perl 5.20 rebuild
80
81* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001011-2
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
83
84* Mon Oct 28 2013 Paul Howarth <paul@city-fan.org> - 0.001011-1
85- Update to 0.001011
86  - Fix in global destruction
87  - Fix SYNOPSIS
88  - Fix duplicate word in DESCRIPTION (CPAN RT#86072)
89
90* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001010-3
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
92
93* Sun Jul 21 2013 Petr Pisar <ppisar@redhat.com> - 0.001010-2
94- Perl 5.18 rebuild
95
96* Wed Mar 27 2013 Paul Howarth <paul@city-fan.org> - 0.001010-1
97- Update to 0.001010
98  - Fix module name in Makefile.PL (CPAN RT#83932)
99  - Work around Exporter.pm not installable on perl < 5.8.0
100- Update old Test::More patch
101
102* Wed Mar 13 2013 Paul Howarth <paul@city-fan.org> - 0.001009-1
103- Update to 0.001009
104  - Disallow version names in random parts of the import list for consistency
105    with Sub::Exporter (CPAN RT#83491)
106- Update old Test::More patch, and apply if we have Test::More < 0.88
107
108* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.001008-2
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
110
111* Tue Jan 22 2013 Paul Howarth <paul@city-fan.org> - 0.001008-1
112- Update to 0.001008
113  - Rewrite -tag to :tag for Exporter.pm
114  - Fix prereqs
115- Update old Test::More patch, and apply if we have Test::More < 0.96
116- Bump perl(Exporter) version requirement to 5.58
117
118* Mon Aug 27 2012 Paul Howarth <paul@city-fan.org> - 0.001006-1
119- Update to 0.001006
120  - Handle ':all' correctly
121- Update old Test::More patch
122- Drop redundant buildreq perl(Test::Pod)
123
124* Sat Aug 25 2012 Paul Howarth <paul@city-fan.org> - 0.001005-1
125- Update to 0.001005
126  - Add support for tags
127  - Warn if defaults are not in exports
128  - Add explicit dependency on Test::More 0.89
129- This release by LEONT -> update source URL
130- Update old Test::More patch
131
132* Thu Aug  9 2012 Paul Howarth <paul@city-fan.org> - 0.001004-1
133- Update to 0.001004 (fix skipping when Sub::Exporter isn't installed)
134- This release by MSTROUT -> update source URL
135- No LICENSE file in this release
136- Update old Test::More patch
137
138* Wed Aug  1 2012 Paul Howarth <paul@city-fan.org> - 0.001003-1
139- Update to 0.001003 (remove warning if there are no defaults)
140
141* Wed Aug  1 2012 Paul Howarth <paul@city-fan.org> - 0.001002-2
142- Sanitize for Fedora submission
143
144* Wed Aug  1 2012 Paul Howarth <paul@city-fan.org> - 0.001002-1
145- Initial RPM build
Note: See TracBrowser for help on using the repository browser.