source: projects/specs/trunk/p/perl-String-CRC32/perl-String-CRC32-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Perl interface for cyclic redundency check generation
2Name:           perl-String-CRC32
3Version:        1.4
4Release:        1%{?_dist_release}
5
6Group:          Development/Libraries
7License:        Public Domain
8URL:            http://search.cpan.org/dist/String-CRC32/
9Source0:        http://search.cpan.org/CPAN/authors/id/S/SO/SOENKE/String-CRC32-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12BuildRequires:  perl >= 1:5.6.1
13Requires:  perl >= 1:%(eval "`%{__perl} -V:version`"; echo $version)
14
15%description
16This packages provides a perl module to generate checksums from strings
17and from files.
18
19The checksums are the same as those calculated by ZMODEM, PKZIP,
20PICCHECK and many others.
21There's another perl module called String::CRC which allows to calculate
22not only 32 bit CRC numbers, but the generated sums differ from those of
23the programs mentioned above.
24
25%prep
26%setup -q -n String-CRC32-%{version}
27
28%build
29%{__perl} Makefile.PL INSTALLDIRS=vendor
30make %{?_smp_mflags}
31
32%install
33rm -rf $RPM_BUILD_ROOT
34make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
35find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
36find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
37find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
38chmod -R u+w $RPM_BUILD_ROOT/*
39
40%check || :
41make test
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(-,root,root,-)
48%doc README
49%{perl_vendorarch}/String/
50%{perl_vendorarch}/auto/String
51%{_mandir}/man3/*.3*
52
53%changelog
54* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-1
55- applied new versioning policy
56
57* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-0vl1
58- new upstream release
59
60* Sat Feb 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3-3vl1
61- rebuild for VineSeed
62
63* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3-3.FC5.2
64- bump again for double-long bug on ppc(64)
65
66* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3-3.FC5.1
67- rebuilt for new gcc4.1 snapshot and glibc changes
68
69* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0:1.03-3.FC5
70- rebuild for new perl-5.8.8
71
72* Thu Jan 19 2006 Jason Vas Dias <jvdias@redhat.com> - 0:1.03-2.FC5
73- bug 176175 addendum: license should be 'Public Domain'
74
75* Fri Jan 13 2006 Jason Vas Dias <jvdias@redhat.com> - 0.1.03-1.4.FC5
76- fix bug 177700: differentiate version from FE4, FE dev versions
77
78* Fri Dec 16 2005 Jason Vas Dias <jvdias@redhat.com> - 0:1.03-1
79- Initial build.
80- Required by lftp-3.3.x+
81- Imported to fix bug 176175
Note: See TracBrowser for help on using the repository browser.