source: projects/specs/trunk/p/perl-Spiffy/perl-Spiffy-vl.spec @ 12120

Revision 12120, 4.2 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Spiffy
2Version:        0.46
3Release:        2%{?_dist_release}
4Summary:        Framework for doing object oriented (OO) programming in Perl
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Spiffy/
8Source0:        http://www.cpan.org/authors/id/I/IN/INGY/Spiffy-%{version}.tar.gz
9
10Vendor:        Project Vine
11Distribution:  Vine Linux
12
13BuildArch:      noarch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(Test::More)
17Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
18
19%if "%{_dist_release}" <= "vl6"
20# Filter bogus provide of perl(DB) (rpm < 4.9)
21%global provfilt /bin/sh -c "%{__perl_provides} | sed -e '/^perl(DB)$/d'"
22%define __perl_provides %{provfilt}
23%else
24# Equivalent filter for rpm 4.9 onwards
25%global __provides_exclude ^perl\\(DB\\)
26%endif
27
28%description
29"Spiffy" is a framework and methodology for doing object oriented (OO)
30programming in Perl. Spiffy combines the best parts of Exporter.pm,
31base.pm, mixin.pm and SUPER.pm into one magic foundation class. It attempts
32to fix all the nits and warts of traditional Perl OO, in a clean,
33straightforward and (perhaps someday) standard way.
34
35%prep
36%setup -q -n Spiffy-%{version}
37
38%build
39%{__perl} Makefile.PL INSTALLDIRS=vendor
40make %{?_smp_mflags}
41
42%install
43rm -rf %{buildroot}
44
45make pure_install PERL_INSTALL_ROOT=%{buildroot}
46
47find %{buildroot} -type f -name .packlist -exec rm -f {} \;
48find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
49
50%{_fixperms} %{buildroot}/*
51
52%check
53make test
54
55%clean
56rm -rf %{buildroot}
57
58%files
59%defattr(-,root,root,-)
60%doc Changes README
61%{perl_vendorlib}/*
62%{_mandir}/man3/*
63
64%changelog
65* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.46-2
66- rebuilt with perl-5.26.
67
68* Thu Nov 06 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.46-1
69- update to 0.46
70- built with perl 5.16.3
71
72* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.30-1
73- initial build for Vine Linux
74
75* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-18
76- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
77
78* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.30-17
79- Perl mass rebuild
80
81* Tue Apr 19 2011 Paul Howarth <paul@city-fan.org> - 0.30-16
82- Make the provides filter work with rpm 4.9 too
83
84* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-15
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
86
87* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.30-14
88- Rebuild to fix problems with vendorarch/lib (#661697)
89
90* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.30-13
91- Mass rebuild with perl-5.12.0
92
93* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.30-12
94- rebuild against perl 5.10.1
95
96* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-11
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
98
99* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-10
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
101
102* Sat Feb 02 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.30-9
103- rebuild for new perl
104
105* Wed Jan 02 2008 Ralf Corsépius <rc040203@freenet.de> 0.30-8
106- Adjust License-tag.
107- BR: perl(Test::More) (BZ 419631).
108
109* Wed Apr 18 2007 Steven Pritchard <steve@kspei.com> 0.30-7
110- Use fixperms macro instead of our own chmod incantation.
111- BR ExtUtils::MakeMaker.
112
113* Mon Sep 04 2006 Steven Pritchard <steve@kspei.com> 0.30-6
114- Rework spec to look more like current cpanspec output.
115
116* Tue Feb 28 2006 Steven Pritchard <steve@kspei.com> 0.30-5
117- Improve filter.
118
119* Mon Feb 27 2006 Steven Pritchard <steve@kspei.com> 0.30-4
120- Drop dummy mixin.pm.
121
122* Mon Feb 27 2006 Steven Pritchard <steve@kspei.com> 0.30-3
123- Filter out Provides: perl(DB).
124
125* Mon Feb 27 2006 Steven Pritchard <steve@kspei.com> 0.30-2
126- Drop explicit Provides: mixin.
127- Add dummy mixin.pm.
128- Improve Summary.
129- Fix Source0.
130
131* Sat Feb 25 2006 Steven Pritchard <steve@kspei.com> 0.30-1
132- Update to 0.30.
133- Drop explicit perl BR.
134
135* Wed Dec 28 2005 Steven Pritchard <steve@kspei.com> 0.24-1
136- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.