source: projects/specs/trunk/p/perl-SVG-Parser/perl-SVG-Parser-vl.spec @ 521

Revision 521, 1.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        SVG::Parser - XML Parser for SVG documents
2Name:           perl-SVG-Parser
3Version:        1.01
4Release:        2%{?_dist_release}
5License:        GNU/GPL
6URL:            http://search.cpan.org/~peterw/SVG-Parser/
7Group:          Development/Libraries
8Source0:        SVG-Parser-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10BuildArch:      noarch
11
12Requires:       perl >= 5.8.6
13BuildRequires:  perl >= 5.8.6
14
15Distribution:   Vine Linux
16
17%description
18SVG::Parser is an XML parser for SVG Documents. It takes XML as input and produces an SVG object as its output.
19SVG::Parser supports both XML::SAX and XML::Parser (Expat) parsers, with SAX preferred by default. Only one of these needs to be installed for SVG::Parser to function.
20A list of preferred parsers may be specified in the import list - SVG::Parser will use the first parser that successfully loads. Some basic measures are taken to provide cross-compatability.
21For more details see: http://search.cpan.org/~peterw/SVG-Parser/
22
23%prep
24%setup -n SVG-Parser-%{version}
25
26%build
27perl Makefile.PL INSTALLDIRS=vendor
28make
29
30%check
31make test
32
33%install
34rm -rf $RPM_BUILD_ROOT
35make install DESTDIR=$RPM_BUILD_ROOT
36
37pushd $RPM_BUILD_ROOT%{_mandir}/man3
38gzip *
39popd
40
41find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
42find $RPM_BUILD_ROOT/usr -type f -print | \
43        sed "s@^$RPM_BUILD_ROOT@@g" | \
44        grep -v perllocal.pod | \
45        grep -v "\.packlist" > SVG-Parser-%{version}-filelist
46if [ "$(cat SVG-Parser-%{version}-filelist)X" = "X" ] ; then
47    echo "ERROR: EMPTY FILE LIST"
48    exit -1
49fi
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54
55%files -f SVG-Parser-%{version}-filelist
56%defattr(-,root,root)
57
58%changelog
59* Fri Jul 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.01-2
60- rebuild
61- applied new versioning policy
62
63* Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.01-1vl1
64- initial build for Vine Linux
65
66* Mon Feb 05 2007 Karsten Brockmann <arcam@ccux-linux.de> 1.01-1
67- Initial Release
Note: See TracBrowser for help on using the repository browser.