source: projects/specs/trunk/p/perl-SUPER/perl-SUPER-vl.spec @ 9128

Revision 9128, 4.4 KB checked in by inagaki, 9 years ago (diff)

2014-12-01 Ryoichi INAGAKI <ryo1@…>

  • perl-Algorithm-Depndency, perl-Thread-{Conveyor, Conveyor-Monitored, Pool}: rebuilt
  • perl-BDB, perl-Coro, perl-URI, perl-SUPER: updated


Line 
1Name:           perl-SUPER
2Version:        1.20141117
3Release:        1%{?_dist_release}
4Summary:        Sane superclass method dispatcher
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/SUPER/
8Source0:        http://search.cpan.org/CPAN/authors/id/C/CH/CHROMATIC/SUPER-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
10BuildArch:      noarch
11BuildRequires:  perl(Carp)
12BuildRequires:  perl(Exporter)
13BuildRequires:  perl(Module::Build)
14BuildRequires:  perl(Scalar::Util) >= 1.20
15BuildRequires:  perl(Sub::Identify) >= 0.03
16BuildRequires:  perl(Test::Simple) >= 0.61
17Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
18Requires:       perl(Scalar::Util) >= 1.20
19Requires:       perl(Sub::Identify) >= 0.03
20
21# Filter out bogus provides (rpm 4.9 onwards)
22%global __provides_exclude ^perl\\((DB|UNIVERSAL)\\)
23
24%description
25When subclassing a class, you occasionally want to dispatch control to the
26superclass - at least conditionally and temporarily. This module provides
27an easier, cleaner way for class methods to access their ancestor's
28implementation.
29
30%prep
31%setup -q -n SUPER-%{version}
32
33# Filter out bogus provides (prior to rpm 4.9)
34%global provfilt /bin/sh -c "%{__perl_provides} | grep -Evx 'perl[(](DB|UNIVERSAL)[)]'"
35%define __perl_provides %{provfilt}
36
37%build
38perl Build.PL installdirs=vendor
39./Build
40
41%install
42rm -rf %{buildroot}
43./Build install destdir=%{buildroot} create_packlist=0
44%{_fixperms} %{buildroot}
45
46%check
47./Build test
48
49%clean
50rm -rf %{buildroot}
51
52%files
53%doc Changes README
54%{perl_vendorlib}/SUPER.pm
55%{_mandir}/man3/SUPER.3pm*
56
57%changelog
58* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.20141117-1
59- new upstream release
60- built with perl 5.16.3
61
62* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
63- initial build for Vine Linux
64
65* Tue Mar  6 2012 Paul Howarth <paul@city-fan.org> - 1.17-7
66- Add provides filters that work with all supported distributions
67- BR: perl(Carp) and perl(Exporter)
68- Make %%files list more explicit
69- Drop explicit requires of perl(Exporter) since it's auto-detected by rpm
70  4.9 onwards, and is bundled with perl on all older distributions
71- Don't need to remove empty directories from buildroot
72- Don't use macros for commands
73- %%defattr redundant since rpm 4.4
74- Use tabs
75
76* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-6
77- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
78
79* Sun Jun 19 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.17-5
80- Perl mass rebuild
81
82* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-4
83- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
84
85* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.17-3
86- Rebuild to fix problems with vendorarch/lib (#661697)
87
88* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.17-2
89- Mass rebuild with perl-5.12.0
90
91* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> - 1.17-1
92- Update filtering
93- Auto-update to 1.17 (by cpan-spec-update 0.01)
94- Added a new br on perl(Scalar::Util) (version 1.20)
95- Altered br on perl(Sub::Identify) (0 => 0.03)
96- Altered br on perl(Test::Simple) (0 => 0.61)
97- Added a new req on perl(Scalar::Util) (version 1.20)
98- Added a new req on perl(Sub::Identify) (version 0.03)
99
100* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-5
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
102
103* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-4
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
105
106* Tue Mar 04 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.16-3
107- Rebuild for new perl
108
109* Wed Jan 02 2008 Ralf Corsépius <rc040203@freenet.de> - 1.16-2
110- Adjust License-tag
111- BR: perl(Test::Simple) (BZ 419631)
112
113* Wed Apr 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 1.16-1
114- Update to 1.16
115
116* Tue Oct 03 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.15-1
117- Update to 1.15
118- Add explict requires on perl(Exporter); missed due to a use base construct
119
120* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-4
121- Bump
122
123* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-3
124- Update %%description and %%summary
125
126* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-2
127- Filter errant perl(DB) provide
128
129* Tue Sep 05 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-1
130- Specfile autogenerated by cpanspec 1.69.1
Note: See TracBrowser for help on using the repository browser.