source: projects/specs/trunk/p/perl-SUPER/perl-SUPER-vl.spec @ 12120

Revision 12120, 4.5 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-SUPER
2Version:        1.20141117
3Release:        2%{?_dist_release}
4Summary:        Sane superclass method dispatcher
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/SUPER/
8Source0:        http://search.cpan.org/CPAN/authors/id/C/CH/CHROMATIC/SUPER-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
10
11Vendor:        Project Vine
12Distribution:  Vine Linux
13
14BuildArch:      noarch
15BuildRequires:  perl(Carp)
16BuildRequires:  perl(Exporter)
17BuildRequires:  perl(Module::Build)
18BuildRequires:  perl(Scalar::Util)
19BuildRequires:  perl(Sub::Identify)
20BuildRequires:  perl(Test::Simple)
21Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
22Requires:       perl(Scalar::Util)
23Requires:       perl(Sub::Identify)
24
25# Filter out bogus provides (rpm 4.9 onwards)
26%global __provides_exclude ^perl\\((DB|UNIVERSAL)\\)
27
28%description
29When subclassing a class, you occasionally want to dispatch control to the
30superclass - at least conditionally and temporarily. This module provides
31an easier, cleaner way for class methods to access their ancestor's
32implementation.
33
34%prep
35%setup -q -n SUPER-%{version}
36
37# Filter out bogus provides (prior to rpm 4.9)
38%global provfilt /bin/sh -c "%{__perl_provides} | grep -Evx 'perl[(](DB|UNIVERSAL)[)]'"
39%define __perl_provides %{provfilt}
40
41%build
42perl Build.PL installdirs=vendor
43./Build
44
45%install
46rm -rf %{buildroot}
47./Build install destdir=%{buildroot} create_packlist=0
48%{_fixperms} %{buildroot}
49
50%check
51./Build test
52
53%clean
54rm -rf %{buildroot}
55
56%files
57%doc Changes README
58%{perl_vendorlib}/SUPER.pm
59%{_mandir}/man3/SUPER.3pm*
60
61%changelog
62* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.20141117-2
63- rebuilt with perl-5.26.
64
65* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.20141117-1
66- new upstream release
67- built with perl 5.16.3
68
69* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
70- initial build for Vine Linux
71
72* Tue Mar  6 2012 Paul Howarth <paul@city-fan.org> - 1.17-7
73- Add provides filters that work with all supported distributions
74- BR: perl(Carp) and perl(Exporter)
75- Make %%files list more explicit
76- Drop explicit requires of perl(Exporter) since it's auto-detected by rpm
77  4.9 onwards, and is bundled with perl on all older distributions
78- Don't need to remove empty directories from buildroot
79- Don't use macros for commands
80- %%defattr redundant since rpm 4.4
81- Use tabs
82
83* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-6
84- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
85
86* Sun Jun 19 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.17-5
87- Perl mass rebuild
88
89* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-4
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
91
92* Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.17-3
93- Rebuild to fix problems with vendorarch/lib (#661697)
94
95* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.17-2
96- Mass rebuild with perl-5.12.0
97
98* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> - 1.17-1
99- Update filtering
100- Auto-update to 1.17 (by cpan-spec-update 0.01)
101- Added a new br on perl(Scalar::Util) (version 1.20)
102- Altered br on perl(Sub::Identify) (0 => 0.03)
103- Altered br on perl(Test::Simple) (0 => 0.61)
104- Added a new req on perl(Scalar::Util) (version 1.20)
105- Added a new req on perl(Sub::Identify) (version 0.03)
106
107* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-5
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
109
110* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-4
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
112
113* Tue Mar 04 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.16-3
114- Rebuild for new perl
115
116* Wed Jan 02 2008 Ralf Corsépius <rc040203@freenet.de> - 1.16-2
117- Adjust License-tag
118- BR: perl(Test::Simple) (BZ 419631)
119
120* Wed Apr 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 1.16-1
121- Update to 1.16
122
123* Tue Oct 03 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.15-1
124- Update to 1.15
125- Add explict requires on perl(Exporter); missed due to a use base construct
126
127* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-4
128- Bump
129
130* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-3
131- Update %%description and %%summary
132
133* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-2
134- Filter errant perl(DB) provide
135
136* Tue Sep 05 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-1
137- Specfile autogenerated by cpanspec 1.69.1
Note: See TracBrowser for help on using the repository browser.