source: projects/specs/trunk/p/perl-SQL-Statement/perl-SQL-Statement-vl.spec @ 8637

Revision 8637, 2.2 KB checked in by iwaim, 10 years ago (diff)

perl-SQL-Statement 1.33-3

Line 
1%define perl_vendorlib  %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2Summary: SQL-Statement module for perl
3Name: perl-SQL-Statement
4Version: 1.33
5Release: 3%{?_dist_release}
6License: Artistic/GPL
7Group: Development/Libraries
8Source0: http://www.cpan.org/authors/id/J/JZ/JZUCKER/SQL-Statement-%{version}.tar.gz
9URL: http://search.cpan.org/~jzucker/SQL-Statement/
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildArch: noarch
12
13Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14Requires:       perl(DBI) >= 1.612
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(Clone) >= 0.30
17BuildRequires:  perl(Params::Util) >= 1.00
18
19%description
20SQL-Statement module for perl
21
22%prep
23%setup -q -n SQL-Statement-%{version}
24
25%build
26CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
27make
28
29%check
30make test
31
32%clean
33rm -rf $RPM_BUILD_ROOT
34
35%install
36rm -rf $RPM_BUILD_ROOT
37make DESTDIR=$RPM_BUILD_ROOT install
38
39find $RPM_BUILD_ROOT%{_prefix} -type f -print |
40        sed "s@^$RPM_BUILD_ROOT@@g" |
41        grep -v ^%{_mandir} |
42        grep -v perllocal.pod |
43        grep -v "\.packlist" > %{name}.files
44if [ "$(cat %{name}.files)X" = "X" ] ; then
45    echo "ERROR: EMPTY FILE LIST"
46    exit -1
47fi
48
49%files -f %{name}.files
50%defattr(-,root,root)
51%doc README Changes
52%dir %{perl_vendorlib}/SQL
53%dir %{perl_vendorlib}/SQL/Dialects
54%dir %{perl_vendorlib}/SQL/Statement
55%{_mandir}/*/*
56
57%changelog
58* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.33-3
59- build with Perl 5.16
60
61* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.33-2
62- rebuild
63
64* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.33-1
65- updated to 1.33
66
67* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.15-2
68- rebuild with perl-5.12.3
69
70* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15-1
71- applied new versioning policy
72
73* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15-0vl1
74- updated to 1.15
75- changed Group to Development/Libraries
76- s/Copyright/License/
77
78* Wed Sep  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14-0vl1
79- updated to 1.14, build for perl 5.8.x
80- updated URL
81- use vendor_perl
82
83* Sat Apr 13 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.004-0vl1
84- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.